none
Connectors don't stick to shapes anymore RRS feed

  • Question

  • Hello,

    I have been working on a visio diagram with many pages. After a while, the connectors don't stick to the shapes anymore. i.e. I have two squar shapes and using an arrow to connect them (flow chart). Up to this point the arrows (connectors) were sitcking on both ends to the shapes and if I move the shapes arrow adjusted itself too. Now the arrow end stays where it was when I move the shape.

    Auto connect option in the advanced menu is on. This has happened to me in the past also, after working on a document for a while this annoying issue came abut. BTW, this is visio 2010.

    thank you for your help.

    Wednesday, April 13, 2011 7:53 PM

All replies

  • Hard to say. If you glued the connectors, then turned off glue somehow, the glued connectors should still stay glued.

    If you selected a bunch of connectors, and then nudged them using the arrow keys, that would break the glue, but the connectors would still appear to be coming into the boxes as if they were glued.

    Other than that, not sure. Which template are you using? Do you have a very large number of objects on the page? Have you done anything with layers?


    Chris Roth Visio Guy (http://www.visguy.com)
    • Proposed as answer by Paul Herber Thursday, March 1, 2012 7:38 PM
    Thursday, April 14, 2011 9:16 AM
  • Hi,

    I understand what you're saying with using arows to move the object, but that's not the case.

    I do have a large number of objects on each page of my flow charts, but I have not used the layering.

     

    What I have been doing to remedy this, is to open a brand new Visio document, copy/paste my current diagram onto it, which works fine and then copy it back to the master document...

    Thank you

    Thursday, April 14, 2011 4:00 PM
  • Hmm. Very strange. I wonder if Visio is somehow being overwhelmed, OR if it is a refresh problem. When the connectors stop gluing, try changing the view by zooming out. See if the connectors update. If that doesn't work, save and close the drawing, then re-open. See if the moved shapes are connected after all.

    Chris Roth Visio Guy (http://www.visguy.com)
    Thursday, April 14, 2011 9:19 PM
  • Thank you for those suggestions. I have used them in the past and they have not helped me.

    I have many projects that I use similar diagrams for. So what I typically do is copy an existing file from a past projet to my new project folder, rename it and delete the pages I don't need and then start building on top of what I have. everyday that I work on this file I rename it to something diferent so I can maintain a trace of my work and changes; i.e. Proj-X-04142011, next day it would be named Proj-X-04152011 and so on.

    Do you think reusing an existing file and modifying it may cause my problem? As I mentioned before, if I copy the diagram that is not sticking to a new Visio file, then it works and sticks.

    thank you

    Friday, April 15, 2011 1:03 PM
  • I was having a similar problem:

    First I checked that AutoConnect was enabled

    1) File - Options - Advanced - Enable AutoConnect

    2) View - Visual Aids - Check "AutoConnect"

    and the kicker was:

    3) View - Visual Aids - click on the little arrow for more options - Check "Snap" and "Glue"

    Sorry to dig this one up but it came up in my search. Hope this helps someone in the future.


    • Proposed as answer by Nick Grivas Thursday, November 17, 2011 11:11 AM
    • Edited by Nick Grivas Thursday, November 17, 2011 11:18 AM
    Thursday, November 17, 2011 11:11 AM
  • Your solution worked great! Thanks for posting Nick.
    Wednesday, February 29, 2012 3:48 PM
  • Nick, your answer just took care of my issue also.  Great documentation.  Thanks!
    Saturday, March 3, 2012 1:15 AM
  • I am having the same exact issue, except the fix for automatic connections does not work. On some objects where I created a connection points, and copied those objects worked like a champ then some ceased to even highlight when hovering a connector over the point.

    What I have resorted to doing, and is a pain, is to find a object that has continued to show a glue attachment point, and copy that object - replacing the defective object. However, as a peculiar observation, this has happened to me in earlier versions of visio; and then it seemed to be regional on the page - in some areas connections work with out a hitch, while in other zones - nada.

    I use layers extensively and have checked to make sure the objects are not locked and active.

    I turned off automatic connections and back on several times and compared properties in the shape sheets for like items.

    It's not a show stopper, but frustrating - help would be greatly appreciated.

    Sunday, April 15, 2012 3:42 AM
  • It works very well, thank you so much!
    Tuesday, August 7, 2012 8:31 PM
  • Hello everyone!

    Playing around with this issue I have found true someones remark that this problem occures when the region of page you are in is overhelmed with connection points. Removing some of them makes shape to start gluing again, so be careful with a number of cennector points in your shapes!

    I think the maximum number of connectors per page can be changed somewhere in the registry. I have seen this for the Visio 2007. Does anyone have an idea how to do it with Visio 2010?

    Tuesday, January 22, 2013 12:25 PM
  • I am having the same problem.  I have all of the recommended things checked.  I have even uninstalled and reinstalled 3 times.

    Its really frusterating as there are weird connections everywhere and when I try and expand a band in my cross functional flow diagram I lose all my connections.

    Very Very frusterating.

    Help!

    Thursday, January 24, 2013 5:02 PM
  • YOU ROCK!! THANKS!!
    Tuesday, August 20, 2013 3:32 PM
  • Thank you so much Nick. You saved me.
    Friday, September 27, 2013 1:03 PM
  • and the kicker was:

    3) View - Visual Aids - click on the little arrow for more options - Check "Snap" and "Glue"

    Sorry to dig this one up but it came up in my search. Hope this helps someone in the future.


      Nick - thank you so much... this has solved my issue and saved me having to copy and paste all my flows into a new document!!

    Thank you Nick! :-)

    Thursday, November 21, 2013 11:16 AM
  • Nick,

    You're a life saver!  The little arrow Glue setting was the ticket for me too!

    Monday, June 8, 2015 7:58 PM
  • Me too!!

    Thanks, Nick.

    Tuesday, July 7, 2015 2:12 AM
  • I had this same problem... but Auto-connect was checked and the "View - visual aids" menu also had everything checked.  S

    Then, on the Home tab, I click Layers - Layer Properties and found MORE check boxes for snap & glue.  Somehow, mine were unchecked... once I checked them the connectors started working again!  I know I didn't change it, so I wonder if an accidental hotkey press is causing this?

    Wednesday, August 19, 2015 2:42 PM
  • That worked for me as well. Thanks!
    Sunday, August 23, 2015 7:45 PM
  • I was having the same issue and this solution worked.  Thank you!
    Friday, May 13, 2016 5:26 PM
  • That was very helpful. Thanks.

    Enabling the autoconnect + snap & glue options worked. :)

    Thursday, May 26, 2016 3:11 AM
  • Thank you.  That solved my problem.
    Monday, November 7, 2016 3:57 PM
  • This solved the issue for me.  Thanks Nick!
    Tuesday, January 17, 2017 2:59 PM
  • THANK YOU VERY MUCH !!! YOU SAVED MY DAY ! This problem was driving me crazy! :P
    Wednesday, July 19, 2017 3:27 PM
  • Thank you so much, this worked great.  Now my concern is how did the document ever become "unglued" to begin with?
    Wednesday, October 18, 2017 6:49 PM
  • Each document have own 'glued' settings ! If you need change these settings in some document, you need write macro or add-in
    Wednesday, October 18, 2017 11:03 PM
  • View - Visual Aids - click on the little arrow for more options - Check "Snap" and "Glue"

    check snap ON

    snap to connection points

    check Glue ON

    and check Glue to connection points

    Thursday, February 15, 2018 6:17 PM
  • Snap and Glue worked for me. This appears to be a per drawing setting - you need to check it for every drawing you open. 
    Monday, April 30, 2018 1:07 PM
  • The document I was working on had this issue and true enough, each layer can have snap and glue disabled... as was my case.  Enabling snap and glue on each layer I needed it solved my issue.  Thank you for the deeper dive.
    Monday, August 27, 2018 12:41 PM
  • Many thanks Nic.

    I dont know how those options turned off but I am back in business now.

    Thanks for your post.

    Thursday, September 13, 2018 4:26 AM
  • My hero, works like a charm, I was in a world of pain.
    Tuesday, May 28, 2019 8:07 AM