Crawling does not happing on a content database from set of DBs of my Web Application (MOSS)


  • Hi Team,

    This is regarding indexing in MOSS content sources. I have an MOSS application(web site) configured as Content source for crawling. A user reported that his is not able to search on the content uploaded to his site. After performing quite a few checks and investigatations. We found below info in crawl log, we suspect that this is  crawling of all sites in Content Database(i.e., non are crawled and searchable). Atleast that is what we understand by trying search of quite a few sites residing in the databse.

    Exception from HRESULT: 0x81070504 (There is no Web named "/sites/020045t".)

    Also we find the site only in SiteMap table in SharePoint config Database only. We tried deletesite command with -force and -siteid switch, both were unsuccessful. Can someone tell us how to remove this orphan site/ entry in sitemap table? We are hesitent to delete the row in sitemap table since we do not impact of doing it from backend.

    Thank you,


    • Moved by Mike Walsh FIN Thursday, April 08, 2010 7:12 AM search questions go to the Search forum (From:SharePoint - General Question and Answers and Discussion (pre-SharePoint 2010))
    Thursday, April 08, 2010 7:05 AM


All replies

  • Ram,

    You can remove orphans from the command line with the DatabaseRepair command:


    Matthew McDermott, MVP MOSS
    • Marked as answer by Reach Ram Tuesday, November 30, 2010 7:37 AM
    Thursday, September 23, 2010 8:45 PM
  • Hi, sorry to dredge up an old post, I have the same issue as the OP, my error points to /sites/test. I tried the stsadm -o deletesite and databaserepair commands, which didn't find any orphans. Also tried deleting 'sites' through SPDesigner, but got "Server error: THe URL http://sitename/sites/_vti_bin/_vti_aut/author.dll" is not contained within a WIndows SharePoint Services site."

    Any recommendations appreciated.



    Wednesday, February 22, 2012 4:34 PM
  • Hi Matthew,

    Database Repair command is not reporting any orphan objects.  Do you know what might be other things that affects the crawling.

    I looked at the permissions and everything looks similar to other DBs.

    Thanks in Advance...



    regards, Sudhir Kesharwani

    Thursday, February 21, 2013 4:20 PM