none
Error en IIS Windows Server 2008 RRS feed

  • Pregunta

  • Hola !!!!

    Quisiera que me ayudaran con un problema que tengo.

    Resulta que en mi servidor con windows server 2008 instale IIS para publicar mis sitios web en internet, pues después de hacer la instalación resulto que si funciono, cree otro sitio por error con los mismos enlaces y ya no funciono; pues desinstale el IIS, pero ahora que lo he vuelto a instalar me da este Error: 1007 IIS w3svc y no se visualiza en internet.

    Ayuda por favor


    David Aguirre

    miércoles, 13 de febrero de 2013 22:20

Todas las respuestas

  • Hola deac0307!

    No está claro el error que generó tu primera desinstalación. Si tu objetivo es mantener varios sitios IIS en el mismo servidor, te sugiero revises el siguiente tutorial:

    Allí encontrarás paso a paso como configurar en forma standard el IIS para cumplir con dicho objetivo.

    Si tu objetivo es alojar solo un sitio, podés utilizar el mismo tutorial pero configurando un solo sitio!

    Saludos y espero que te sirva!!


    Pablo Ariel Di Loreto
    IT Consultant

    This posting is provided "AS IS" with no warranties and confers no rights! Always test ANY suggestion in a test environment before implementing!

    jueves, 14 de febrero de 2013 5:48
  • Muchas gracias Pablo por tu respuesta;

    El material esta muy bueno, el problema que tengo fue que tenia dos sitios con el mismo enlace, esto provoco un error, pues lo que hice fue desinstalar el IIS pero al volverlo a instalar me tiraba el error 1007 W3SVC y no he logrado quitar el error.

    Muchas gracias por tu tiempo. 


    David Aguirre

    jueves, 14 de febrero de 2013 15:21
  • Hola !

    Ya logre arreglar el problema borre las carpetas intsvr y lo reinstale y funciono, ahora la consulta es como hago para que mi servidor se vea en internet, a la máquina le he configurado la IP pública pero no funciona aun, alguna idea????


    David Aguirre

    jueves, 14 de febrero de 2013 17:24
  • Hola deac0307!

    Ante todo, que bueno que pudiste arreglar tu problema. Con respecto a tu consulta, te comento:

    • Para que tu web se vea en internet, necesitás que tenga asociado un nombre de dominio y por lo menos un registro WWW apuntando hacia tu IP pública.
    • En el IIS tenés que tener configurado, para dicho sitio, que el binding de la página acepte la URL pública. Por ejemplo, si tu sitio es www.sitio.com, tenés que tener el registro WWW de la zona sitio.com apuntando hacia la dirección ip pública de tu servidor, y en el sitio web del IIS tenés que aceptar como binding a "www.sitio.com" para dicho sitio web.

    Ahora bien, esto es en términos "simples". No tenemos el dato si tenés firewall activado en tu servidor. Si tenés el firewall habilitado deberías crear una regla de acceso por el puerto 80 (suponiendo que tu web utiliza HTTP).

    Es importante, igualmente, transmitirte que no es conveniente que tu server exponga una IP pública. Lo ideal es que tengas un firewall delante de tu servidor que tenga cargadas las ip públicas, y que publique tu web hacia internet, de modo tal de no exponer tu web server directamente al mundo público.

    Decinos si necesitás alguna guía mas.

    Saludos!


    Pablo Ariel Di Loreto
    IT Consultant

    This posting is provided "AS IS" with no warranties and confers no rights! Always test ANY suggestion in a test environment before implementing!

    viernes, 15 de febrero de 2013 6:22
  • Hola deac0307!

    ¿Cómo estás? ¿Pudiste resolver el problema de visbiilidad externa?

    Esperamos tu feedback!

    Saludos!!


    Pablo Ariel Di Loreto
    IT Consultant

    This posting is provided "AS IS" with no warranties and confers no rights! Always test ANY suggestion in a test environment before implementing!

    martes, 19 de febrero de 2013 2:32
  • Hola si lo logre!!!

    Mi dominio lo asocie a la dirección IP Pública y listo ya esta funcionando, de hecho esta dres de Un Firewall Cisco y dentro de la DMZ.

    Muchas gracias por el interes y por los materiales.


    David Aguirre

    martes, 19 de febrero de 2013 22:50
  • Hola deac0307!!

    Me alegro mucho que hayas podido solucionar tu problema!! Y excelente que esté detrás de un firewall y dentro de una DMZ.

    Saludos!!


    Pablo Ariel Di Loreto
    IT Consultant

    This posting is provided "AS IS" with no warranties and confers no rights! Always test ANY suggestion in a test environment before implementing!

    miércoles, 20 de febrero de 2013 16:06