none
Proveedor de canalizaciones con nombre, error: 40 - No se pudo abrir una conexión con SQL Server RRS feed

  • Pregunta

  • Hola buenas tardes

    Tengo instalado en mi servidor SQL Server 2008 Express, Inicio mi aplicacion y la abre bien tengo data-tables funcionando y si me carga datos pero en una consulta de datos me marca el siguiente error:

    "Error relacionado con la red o específico de la instancia mientras se establecía una conexión con el servidor SQL Server.  No se encontró el servidor o éste no estaba accesible. Compruebe que el nombre de la instancia es correcto y que SQL Server está configurado para admitir conexiones remotas. (provider: Proveedor de canalizaciones con nombre, error: 40 - No se pudo abrir una conexión con SQL Server) "

    Ya revise que los servicios esten levantados el de mi instancia y SQL Browser, que el SQL este configurado para conexiones remotas, permisos para mi usuario en inicio de sesion, abri el puerto 1433 ... deshabilte el FireWall de Windows y nada....

    Nota: Si puedo abrir en el SQL Managment estudio la BD .. con mi usuario.. solo en el programa me marca error, esta es mi cadena de coneccion

    Public Coneccion_Gral As String = "Data Source=" & My.Settings.servidor.ToString & "; Initial Catalog=" & My.Settings.bd.ToString & "; User Id=" & My.Settings.usuario.ToString & "; Password=" & My.Settings.pwd.ToString

    Public Str_Cn As New SqlClient.SqlConnection(Coneccion_Gral)

    En la conexion tampoco me marca error hasta que llego al punto de la siguiente imagen


    Que mas puedo hacer ?.. reinstalar SQL no en version Express sino en Estandar ?

    JM




    • Editado jamlfito lunes, 2 de marzo de 2015 23:56
    lunes, 2 de marzo de 2015 22:41

Respuestas

  • y ya revisaste la cadena de conexion... revisala puede ser que te estes equivocando en algo...

    Saludos

    Si te sirvio marca como respuesta

    • Marcado como respuesta jamlfito martes, 3 de marzo de 2015 17:00
    lunes, 2 de marzo de 2015 23:08

Todas las respuestas

  • Hola jamlfito,

    Entiendo que has habilitado los protocolos TCP/IP, la canalización con nombre, etc en el SQL Server Configuration Manager.

    Comprueba que en la instancia (a traves de SQL Management Studio, click derecha , Propiedades, tienes en el submenu de Conexiones, la propiedad de "Permitir conexiones remotas" habilitada).

    Básicamente es revisar este tutorial, quizás te has saltado algún paso. -> Link

    El tema de la versión de Express o Standard no debería ser un problema.

    Un saludo, espero que te sea de ayuda.


    lunes, 2 de marzo de 2015 22:59
  • y ya revisaste la cadena de conexion... revisala puede ser que te estes equivocando en algo...

    Saludos

    Si te sirvio marca como respuesta

    • Marcado como respuesta jamlfito martes, 3 de marzo de 2015 17:00
    lunes, 2 de marzo de 2015 23:08
  • Haz una prueba de udl a tu base http://blogs.msdn.com/b/farukcelik/archive/2007/12/31/basics-first-udl-test.aspx

    Checa que el servicio de sql este arriba y checa que los meotod de conexion de tcp/ip esten arriba.

    martes, 3 de marzo de 2015 2:17
  • Les agradezco a los 3 por su colaboracion ...me fui por esta..revise la conexion y creo q era por aqui

    martes, 3 de marzo de 2015 17:00