Lync - Deploy Monitoring Server Reports Wizard - Unauthorized


  • Hello,

    When installing Monitoring Server Reports Wizard, I encounter the following error:

    > Deploying Monitoring Server Reports... This might take a few minutes.The Monitoring Server is using SQL instance "<MonitoringBackEnd>".The data source is using SQL instance "<MonitoringBackEnd>".The following URL will be used for deployment:<ReportingServer> Server logon credentials for "<UserName>" already exist. Use the existing logon credentials."[QoEMetrics]" role "[ReportsReadOnlyRole]" has already assigned to "<UserName>"."[LcsCDR]" role "[ReportsReadOnlyRole]" has already assigned to "<UserName>".Start to deploy reports...The request failed with HTTP status 401: Unauthorized.An error occurred when deploying Monitoring Server Reports. For details, see the log.

    Unfortunatly, no log file to access.

    The account installing has full Admin Rigths on both servers + SysAdmin Rights on the database. The Reporting instances are running on a different SQL server then the SSRS insance. I'm running the setup on the Monitoring Server.

    Does anybody know how to solve this?



    mercredi 23 mars 2011 15:12

Toutes les réponses

  • Hi

    Struggled with the same issue. I ended up doing the installation of the reports directly on the sql server. But i think it also was a problem with the AD user i used as sql reporting service account and that it didnt have enough access in ad so it was unable to authenticate users..


    mardi 29 mars 2011 06:57
  • Same here...ended up installing directly on SQL... :-(

    Anyone from MS have any tips?


    vendredi 8 avril 2011 11:15
  • Did you solve this? I´m facing a similar issue.

    Best regards, Daniel
    mardi 12 avril 2011 19:45
  • Well, only with the workaround mentioned above...



    mardi 12 avril 2011 19:49
  • ok, thanks. I don´t want reporting services running on a SQL cluster node since reporting services isnt  cluster aware.

    The technet documentation on monitoring deplyment is rather thin.

    Br, Daniel
    mardi 12 avril 2011 19:57
  • I finally solved this. It's stupid simple: install a separate Instance of SQL Server and it works...


    jeudi 21 avril 2011 18:49
  • I manged to solve the problem by uninstalling all SQL compontents on my monioring server, and reinstalling.

    Works great but I´m not certain of why..this is my configuration

    server09: SQL 2008 DB instance (clustered) with databases for reporting services, monitoring and
    server10: Lync monitoring server with SQL 2008 reporting services

    reporting services on server10 is running using network service account (built in) and connects to DB server09 using AD service account that has SQL priviliges and is local admin on server10.

    With this setup I could publish the reports successfully.


    • Proposé comme réponse Ullmark mercredi 4 mai 2011 08:19
    mercredi 4 mai 2011 08:19
  • The technet documentation on monitoring deplyment is rather thin

    Keep sending feedbacks on the relevant pages using the included URL, maybe they will put effort into making those articles a lot more useful! Otherwise it may remain as useless and incomplete as it is currently :(
    mercredi 1 juin 2011 12:46
  • Have a look at below Lync monittoring server deployment guide,


    samedi 30 juillet 2011 20:30
  • I have a SQL 2008 R2 SP1 Enterprise cluster. I wanted to deploy the reporting Services to the Monitoring server. I also created an internal certificate during the deployment for the web service. I received the same error on the Monitoring server during the reports deployment and found that I COULD access the URLs of and remotely. I tried the URLs locally on the server and I kept getting prompts for authentication over and over after entering them correctly. I knew I remembered seeing this somewhere else. I did a search and found this page: I followed the instructions to DisableLoopbackCheck.

    1. Click Start, click Run, type regedit, and then click OK.
    2. In Registry Editor, locate and then click the following registry key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa
    3. Right-click Lsa, point to New, and then click DWORD Value.
    4. Type DisableLoopbackCheck, and then press ENTER.
    5. Right-click DisableLoopbackCheck, and then click Modify.
    6. In the Value data box, type 1, and then click OK.
    7. Quit Registry Editor, and then restart your computer.

    After a restart I attempted adding the reports and they succeeded. WOOHOO!!! 3 hours of my life I can never get back!

    I read that the Reporting Services are not cluster aware which is why I did not place it on the SQL cluster.

    I also adjusted IE security on my local machine to "Automatic logon with current user name and password" so I no longer was prompted to login.

     FYI... I also had to add local firewall rules for 80 and 443 as IIS is not used so it is not added automatically.  I also forgot to intially add the DNS record for my internal certificate which caused an error during the reports deployment.  I also updated SQl 2008 Express to 2008 R2 SP1 to match the SQL 2008 R2 SP2 Enterprise Cluster before I installed the reports.  I also used IIS from my FE server to generate the certificate as IIS was not installed on the monitor server.  I then exported it from the FE server and imported it to the Monitor server. 

    Mike Niccum


    • Modifié mniccum mercredi 21 décembre 2011 23:59
    • Proposé comme réponse mniccum jeudi 22 décembre 2011 22:51
    mercredi 21 décembre 2011 23:38
  • Running the following commands in PowerShell on the SQL server resolved it for me.

    New-NetFirewallRule -DisplayName “HTTP” -Direction Inbound –Protocol TCP –LocalPort 80 -Action allow
    New-NetFirewallRule -DisplayName “SSL” -Direction Inbound –Protocol TCP –LocalPort 443 -Action allow

    Otherwise try some of the other ports listed in this blog:

    jeudi 18 juillet 2013 19:32