MOSS 2007, Recover data from content database


  • Hi,

    After changing the administrator password on our SBS2008 server earlier today, sharepoint stopped working, now we simply get HTTP/1.1 200 OK Server: Microsoft-IIS/7.0 Date: ....... Connection: close.

    Inside central admin the web application is still there, access mappings are all correct however when I look inside the web app there is now no site collection, the content database is still connected and seems to be working both within SQL and central admin.

    I have restored the database back from last night but it has made no difference, what other files/settings would need to be changed in order to restore this content.

    I also tried creating a new web app, restoring a copy of the database to a new name and connecting that database to my new app however it shows as a blank new site, despite having around 2gb of data within the database.

    If I cant restore the database is there anyway to access the lists within the detached content database so that I can recover the data.

    Thanks in advance

    22 Juni 2012 3:18

Semua Balasan

  • Hello Anthony Wilkin,

    Firstly try the below KB article and try accessing the site once again

    How to change service accounts and service account passwords in SharePoint Server 2007 and in Windows SharePoint Services 3.0



    22 Juni 2012 7:54
  • Hi,

    It might be worth restoring the sharepointconfig databases to an earlier point in time, only problem with that is whenI run my tape drive backup there are always errors thrown, I managed to get the content database by completely detaching it and then recovering the files and reattaching, I dont want to do this for the sharepointconfig however as I have enough problems with it at present.

    I have used stsadm to remove the content database from the original web application in the hope I could reattache however when I have now tried to reattach I get the database is not empy message I would expect if this was dealing with a search database but not the content one, I found a post on here some time back which was only resolved by installing a new farm so my solution is still probably to go back in to the database and manualy remove lists and sites (if I can do it that way it would be great).

    Many thanks,

    22 Juni 2012 11:23
  • Just to add, my new application with my restored and connected database attached has all of my list data in when I look within sql, however it does not show within the site, is this an easier fix perhaps?
    22 Juni 2012 11:42
  • HI,

    Looking inside the content database, I have two tp_SiteId values, as all of my site content is still in my newly mounted database, only the site and user information is not beeing seen by sharepoint, is it possible to change the siteId value to match the site data that I can see, will this enable sharepoint to read the list/library information stored within the database that it cannot currently see? or are there additional steps needed.

    Kind regards

    25 Juni 2012 8:31