Lync Audio Conference Service DTMF issues


  • We are seeing random issues with the audio conference service and DTMF. When users dial into the bridge and enter the conf ID, they are told it cant be found. They call back, enter the ID and are connected. It is hit or miss and very random. Lync phone<>Bridge works 100%. Cisco IP phone/external phone>Lync Bridge is hit or miss. Lync<>CUCM by SIP Trunk. Anyone else experiencing DTMF issues with CUCM and Lync?
    5 aprilie 2011 20:00

Toate mesajele

  • Have you tried requiring MTP on the trunk to Lync?
    5 aprilie 2011 21:05
  • Yes - Media Termination Point Required is checked on the SIP Trunks on CUCM.
    6 aprilie 2011 02:00
  • What version of UCM are you running?
    6 aprilie 2011 15:24
  • Did you fix this. I have a very similar issue that started today following a minot upgrade to CUCM (to fix a memory leak).

    Since this fix i can not use dtmf from any cisco phone to enter conference ID. If i use the Lync client to dial in works fine. If i use PSTN dial in it works. If i use one of out PBX phones that are E1 connected to CUCM it works. All very strange.



    7 aprilie 2011 19:28
  • no this was not fixed. we are running CUCM 7.1.2. In fact, the issue is getting much worse. I am curious if this is a Lync CU1 issue and Im just placing blame on CUCM.
    8 aprilie 2011 14:35
  • Ah. We had an issue where CM8 wasn't using a media resource group where hardware and software resources both existed. 

    Are you seeing the DTMF fail on all calls? Every 3rd/4th/etc? Specific digits? 

    8 aprilie 2011 18:13
  • the DTMF issue is very random at this point. sometimes it works, sometimes it doesnt. we are debating rolling off CU1 or waiting for CU2 at this point.
    12 aprilie 2011 18:50
  • removing CU1 didnt make a difference so it has been reapplied.
    13 aprilie 2011 01:29
  • I would run a trace for the conference attendant to see if Lync even sees the digits being sent when this happen so you can narrow down if you should be looking in Lync or UCM.

    Unless you're seeing some errors on your back-end SQL that match up with the timing of these events I would assume the issue is probably more on UCM. Definitely sounds like an MTP problem somewhere.

    14 aprilie 2011 14:51
  • Yes, we have opened a case with MS on this. It appears (from the Lync Logging Tool, S4) when the Mediation server receives the DTMF, its missing numbers. We are now trying to narrow down if CUCM is sending the full 5 digits via Wireshark trace. if CUCM is indeed sending the 5 digit ConfID then its getting mangled somewhere between CUCM and Lync Mediation.
    17 aprilie 2011 00:19
  • Any news about this issue?
    12 mai 2011 11:20
  • Any update on this issue?  we're  experiencing  the same symptoms,  CUCM 7.1.3 --> SIP Trunk --> Lync2010  and  no DTMF tones...   the trace tool in Lync  shows  nothing coming across.. we have MTP  and the MRG in CUCM is  correct..
    13 mai 2011 01:42
  • No solution although our workaround was to capture the bridge numbers as route patterns within call manager, and keep the call from Lync to CUCM instead of sending it out the PSTN and back in. This appears to have bypassed the issue for us.

    19 mai 2011 21:46
  • I was having the same issue with Lync and my Cisco SIP trunk on CUCM 8.  I'm finding that I have to provide a PVDM transcoder resource on my SIP trunk to Lync and Exchange Unified Messaging for certain outside SIP callers in order to get DTMF to work correctly.  Be sure your media resource list on your trunk has a hardware (PVDM) transcoder available to it.

    Jeffrey Kelso, Enterprise Communications Specialist - CCNA
    1 iunie 2011 13:21
  • We had similar issues with CUCM 7.1.3. Incoming calls were on a trunk configed for H.323 that was pointed at MeetingPlace. We couldn't get it to translate the DMTF over to the outbound DirectSip trunk to Lync. Internal calls originating on the Cisco phones worked fine. We grabbed a DID from our pool that comes in via a PRI, routed that to Lync, set its number up as the DIC number in Lync, and it all works... We suspect that somewhere in the H.323 to SIP conversion, the DMTF gets lost.
    16 iunie 2011 17:19
  • I'm having the same issue..did you found the problem?

    In my cenario we have cisco 7.1 and lync 2010 with the latest CU


    4 iulie 2011 13:11
  • Hi,

    I have the same similar issue, the DTMF is not sensing on second try. Mostly for 3 or 4 digit of the number.



    2 martie 2012 00:53
  • you mean the first Digit in DTMF is transmitted and received?

    Had you tested this?

    21 martie 2012 20:58
  • Hi,

    I am also having same issue, we have recently integrated CUCM 8.1 with Lync 2010, issue is with DTMF, when i enable use MTP on SIP trunk, DTMF tones are not going thru if call is coming from a CUCM registered IP Phone, but all external (PSTN) calls work fine i.e DTMF goes through.

    When i disable use of MTP then internal (CUCM IP Phone) starts working fine but external calls cannot even connect and i get the following error:

    488 Invalid incoming Gateway SDP: Invalid media

    Any help would be appreciated!

    Thanks in Adavance


    9 mai 2012 07:12
  • did you fix this i'm having exactly the same issue . DTMF works on internal call without the MTP but breaks external calls.

    pls let me know...

    17 mai 2012 18:42
  • Interestingly, I have the same issue as ManiMans, but disabling MTP resolved the issue both for internal and external calls.  The strange thing is it was working fine both inside and outside for a couple of days (we just set Lync 2010 up) and then suddenly stopped working.  I think it has to be an issue with transcoding.  We're using hardware based DSP transcoders.
    7 iunie 2012 16:33
  • Environment: CUCM 8.5 SIP trunk to Lync 2013 to allow for dial in conferencing from internal callers and callers from PSTN. 

    Issues: Internal Cisco IP 796X phones DTMF tones not recognized by Lync and outside callers DTMF was ok.  Disabling MTP on trunk broke out side calling (call failed completely).  SIP/2.0 488 Invalid incoming Gateway SDP: Gateway ParseSdpOffer Error: No DTMF support on Gateway side - was the error on the trace on Lync 21013 server. However, disabling MTP required fixed the DTMF tone issue for internal callers from Cisco IP phones.

    Resolution: on CUCM ->Trunk config: remove check for <label for="MTPREQUIRED">Media Termination Point Required </label>and on you -> SIP Profile config -> trunk specific configuration: remove the check for <label for="EARLYOFFERSUPPORTFORVOICECALL">Early Offer support for voice and video calls (insert MTP if needed) </label>. 

    27 iunie 2013 20:05