Automation error: The object invoked has disconnected from its clients (Office)



    I got this error: "Automation error: The object invoked has disconnected from its clients" when I try to save a document(Word), spredsheet(Excel) etc. in Office 2010.

    I try it for office 2007 /2003, the issue is same.

    It is a new error, my Office have worked fine with this installation before.

    26 августа 2012 г. 12:38

Все ответы

  • Hi,

    Can you check if the Security Update MS12-060 has been installed ?
    If so, please try the following on a test machine.

    Open Notepad and paste the content below the line.
    Save the File as .bat and run it. Try again Word to see if you get the message.


    reg delete hkcr\typelib\{831FDD16-0C5C-11D2-A9FC-0000F8754DA1}\2.0 /f

    if exist %systemroot%\SysWOW64\cscript.exe goto 64 
    %systemroot%\system32\regsvr32 /u mscomctl.ocx
    %systemroot%\system32\regsvr32 mscomctl.ocx

    %systemroot%\sysWOW64\regsvr32 /u mscomctl.ocx
    %systemroot%\sysWOW64\regsvr32 mscomctl.ocx


    Take a look also at this one:

    Cheers, Petru

    26 августа 2012 г. 23:41
  • Appreciate your quick reply.

    I have try to run your .bat file, but occurred this error message, means "Mscomctl.ocx has been loaded successfully but failed to call DllRegisterServer, the error code is 0x80004005."

    • Изменено Logoncafe 27 августа 2012 г. 3:31
    27 августа 2012 г. 3:29
  • @Logoncafe, please try to then run the script again with Administrator permission, hold Shift key and right click on it, and choose Run as administrator.

    Max Meng
    TechNet Community Support

    29 августа 2012 г. 3:27
  • Hi Max Meng,

    I execute the about scripts successfully, but the automation error still exists. -_-!

    29 августа 2012 г. 15:15
  • ehmmm...

    Try to run Word in safe mode, and save the document again.

    If this error won't occur in the safe mode, remove the macros or disable the add-ins and check again.

    Max Meng

    TechNet Community Support

    29 августа 2012 г. 15:50
  • Any updates/ fresh insights on this? 

    I get the exact same error when trying to use "Save as" from Excel.  I get it regardless of the state of the document, whether I try to save an empty document from a freshly opened Excel session or if I try to "Save as" an existing document. Just using Save on an existing document does not initiate the error.

    In Word I get the message only sporadically when trying to save.

    I have tried the registry fix to no avail and running in safe mode does not make any difference. 

    I tried reinstalling Microsoft Office (2007) - that did not help. Today IT department rolled out Office 2010 and I installed that, but I still get the same error.

    As for the OP my problems started recently, and without remembering the exact date it was definitely later than the  15th of August (time of the infamous patch).

    We are a pretty big organisation, and as far as I know none of my colleagues have the same problem and our IT helpdesk is miffed.

    The only solution left to me now is to reinstall windows unless some clever soul in here have a tip that might remedy the issue.

    • Изменено olecs 10 сентября 2012 г. 12:42
    10 сентября 2012 г. 12:39
  • I, too, was still having the error message in Excel 2010 on one user's computer.  I even tried creating a clean Excel14.xlb file, but that didn't make a difference.

    At this point I knew it was likely to be an add-in creating the issue since I was getting this error message just opening Excel without actually opening an existing file.

    I went to File>Options>Add-Ins>Excel Add-Ins and unchecked "Analysis Toolpak - VBA", closed Excel, opened Excel and the message had gone away.

    Then I enabled the Add-In again, but the error message did not return.  So far, so good, but time will tell if this was the fix. 

    What actually happened under the hood, though? 

    Views expressed do not represent those of my employer.

    27 декабря 2012 г. 17:55