Cannot receive federated instant message texts...can get presence, even invites.


  • Have a strange issue in which we are federated with Yahoo and MSN, (PIC licenses in place yadayada)..

    I can see my yahoo and MSN partners status, and they can see mine... I can send them instant messages, and they receive my text.

    They can send me instant message invites, however the text does not come across, and even after I reply to them, I cannot see their text.. they can receive mine just fine.

    No block lists..etc..

    Single FrontEnd server, Single Director , and Edge in DMZ.

    (we were load balanced (internally) behind a F5..but I took the F5 out of the equation by disabling the pools for the director and Front end and setting up local hosts files on the Edge, FE and Director (as well as the client box I'm using internally), with the pool names pointing directly at the FE, EDGE, DIR IP Addresses..

    what would allow me to receive external presence, and even the actual instant message Invites/notifications from external...but not the text??

    19 ธันวาคม 2554 21:10


  • Hi systemnt,

    Please check the Conversation History folder.

    If you’ve deployed Archiving, peer-to-peer instant messages will be archived, you could confirm it accordingly.

    Noya Liu

    TechNet Community Support

    21 ธันวาคม 2554 9:50
  • Huh?

    think you meant to answer someone else's post?

    This is about external IM's with federated users, not peer to peer.

    21 ธันวาคม 2554 13:59
  • for clarification--

    Is Presence available from Yahoo/MSN to BUSINESSLYNC – YES

    Is Presence available from BUSINESSLYNC to Yahoo/MSN – YES

    Can send invitation (received at recipient) to instant message from Yahoo/MSN to BUSINESSLYNC – YES

    a)      Original text received - NO

    Can send invitation (received at recipient) to instant message from BUSINESSLYNC to Yahoo/MSN – YES

    a)      Original text received – YES

    Can reply to invitation (received at recipient) and begin Instant Message conversation from Yahoo/MSN to BUSINESSLYNC – NO

    Can reply to invitation (received at recipient) and begin Instant Message conversation from BUSINESSLYNC to Yahoo/MSN – YES


    21 ธันวาคม 2554 16:59
  • not that this helps but I'm having almost the same issue. I get a notice to start a conversation on my Lync client but no actual text. I also see presence just fine as well as status messages (going both ways). I can send texts out (although sometimes that fails too). To add data to it I see these sorts of errors with Sip logging:

    Start-Line: SIP/2.0 480 Temporarily Unavailable
    ms-diagnostics: 13013;reason="No route exists for the requested endpoint.";AppUri


    Start-Line: SIP/2.0 481 Call Leg/Transaction Does Not Exist


    I also get some "504 Server Time Out" type messages but that is only from MSN PICs.

    I did just get successfully provisioned about 7 days ago so I'm wondering if it takes a long time for the changes to trickle through the system



    3 มกราคม 2555 19:46
  • Scarr.. that is Exactly the same issue we are seeing.

    We are well over the 7 day provisioning...and this occurs for both YAHOO and MSN...

    Are you using any HWLB internally or externally?

    3 มกราคม 2555 19:49
  • nope, not using any load balancing, just one Edge server and one FE server so far. I did contact the provisioning folks about it but they told me they don't deal with anything after it is provisioned (which they verified happened on the 27th of December) so they gave me some useless links and told me to spend money with Microsoft Technical support. Nice!

    Based on a lot of digging around on these forums and elsewhere it seems when users have had these issues many times it magically starts to work at some point so maybe that will happen to me too since I have everything configured correctly (all tests pass with "success") and everything else works smoothly now (including federated push notifications for Lync mobility on iPhones and WP7 phones). If I do figure something out I will let you know


    3 มกราคม 2555 20:36
  • So, still no luck although it does work intermittently.  I did even have a chat today that worked both ways quickly (normally there is a lag in the actual text going through). It seems like I'm now down to just the one error now which is:

    Start-Line: SIP/2.0 481 Call Leg/Transaction Does Not Exist


    Everything else in the trace logs looks good, the TLS handshake is good, there are SUBSCRIBE's going back and forth etc.


    I'm still hoping that it is just a matter of time but man this is a sketchy system for sure.

    6 มกราคม 2555 0:57
  • found the answer finally to getting AOL IM federation working well. You need to change the SSL cipher order on the Edge server so it tries one the AOL likes first. The instructions are here:

    Also, if you are running R2 of Windows 2008 you may not be able to paste back into the Group Policy box so you will need to find the actual registry key to do it once enabled. You can get that info here:

    Hope that works for you, it definitely fixed it for me. Now if I can just get MSN to stop giving me 504 errors. One step at a time I guess



    • เสนอเป็นคำตอบโดย scarr4 10 มกราคม 2555 20:19
    6 มกราคม 2555 20:12
  • Edit: We thought we had figured out our issue. Our primary Director server had something inherently wrong with it that wasnt allowing it to 'let go' of the session after handing it off to the FE.

    We removed it from the topology, created a new Director pool with just one Director server (another box entirely), and everything worked as it should now- federation with public providers (yahoo, MSN, AIM) all work, as does federation with companies.

    It worked for approximately 13 hours.. then reverted back to the EXACT same issue of not being able to see incoming text from Federated partners.

    No changes to the Network/Firewall/Director Pool/Topology, or servers.

    Wondering if theres a company GPO that is being applied on something...  anyone have an idea of what to even look to in that regard?



    • ทำเครื่องหมายเป็นคำตอบโดย systemnt 12 มกราคม 2555 15:20
    • แก้ไขโดย systemnt 13 มกราคม 2555 13:52
    • ยกเลิกการทำเครื่องหมายเป็นคำตอบโดย systemnt 13 มกราคม 2555 13:52
    12 มกราคม 2555 15:19