New Exchange 2010 / EMS / WinRM error


  • New Exchange 2010 / EMS fails to connectQuestion:
    New Exchange 2010 installation on windows 2008.  An Exchange 2003 server already exists on a Windows 2003 server.
    AD DC = Windows 2003
    Logging on as domain\administrator, same account used to install Exchange.

    When EMS is opened, error includes "... connecting to remote server failed .... The WinRM client cannot process the request.  It cannot determine the content type of the HTTP response from the destination computer.  The content type is absent or invalid...."

    I have downloaded the Exchange Management Troubleshooter and run it.  The response is "The user account hat is attempting to connect is not Remote PowerShell Enabled ...".   (However, the account is domain\administrator, the same account used to install Exchange.)

    If i look in  IIS Manager | default Website | Powershell | Autentication, status is "retrieving status" for all 6 entries. Also error message "There was an error while performing this operation.  Details.
    Filename: \\?\c:\program files\microsoft\exchange server\v14\clientaccess\PowerShell\web.config   Error:  [ this is blank ]   "

    I have searched extensively on these errors, even trying suggested solutions like renaming / editing the web.config file mentioned above. 

    I'm getting to the point of thinking about wiping the server and starting over. 
    Any ideas?

    2011年11月8日 20:09


  • Hi,

    1 Go to Default Web Site physical location & find web.config and redirect.htm.
    Move the files to another location & do iisreset.

    2 Removing WinRM feature and reinstalling it . Then try again.


    Best Regards!
    2011年11月9日 6:35
  • Hi,

    Rowen-Xu, thank you, I followed your recommendation. 

    OK, after that, the EMS gives the error  "...The winRM client cannot process the request.  The WinRM client tried to use kerberos authentication mechanism, but the destination computer ( name  ) returned an 'access denied' error.  Change the confiruation to allow Kerberos authentication...."


    in this thread:


    I found the following instructions, quoted here to help others: 



    1) Check to seeif OWA is working.  If it is not, go to IIS Manager and check the Modules:

    Note:  If The KerbAuth.dll module had been loaded at the Default Web Site level this can cause OWA as well as the Exchange Management tools (EMC/EMS) not to work.

    -KERBAUTH should only be registered in IIS under modules on the PowerShell Site (not at the Default Site, and not at the Server level)
    -KERBAUTH should only be registered as NATIVE, not as Managed at the PowerShell Site in IIS
    -KERBAUTH should only be registered directly at the PowerShell Site in IIS, not Inherited.

    If the Kerbauth.dll is registered as a "Managed" module not a "Native" Module, do the following:
    • Remove Kerbauth from the Powershell web site as a Managed Module
    • Verify if Kerbauth.dll is in the C:/Program Files/Microsoft/Exchange/V14/BIN directory. 
    • In IIS go to the server level and register Kerbauth.dll using the name "Kerbauth" and the path to  C:/Program Files/Microsoft/Exchange/V14/BIN/KERBAUTH.DLL
    • Go back to the Server level in IIS and Remove Kerbauth. 
    Note: We are simply removing it from the server level, and since it is registered now, it should be available at lower levels.
    • Under IIS Powershell in MODULES select Manage Native Modules, and check by Kerbauth which now should appear.
    • Ran IISRESET from a Command Prompt
    • Try opening EMC and EMS again.


    NOW, when EMS is opened, we have the error "...Connecting to the remote server failed with the following error message : Acces is denied...."

    Still working on this. 


    2011年11月9日 15:06
  • Next, I followed the instructions in "EMC Permissions Gone - Part Deux"

    but at step 6, got an "access denied" error. 

    Still working on this ...

    2011年11月9日 16:01

    Well, I've decided to wipe the server and start over.  I'll be back to confirm if that works. 


    2011年11月9日 19:52
  • Hi ,


    Its a Temporary Issue with Exchange to Contact Active Directory.

    Restart Exchange Servers AD Topology Service & Revert Back


    2011年11月18日 12:00
  • Guys,

    I was installing Exchange Server 2010 I choose only MB server and CAS.  During my installation I don't have any issue or problem encountered.  After finished installation, I rebooted the Exchange Server pc.  When I am already on the desktop I launch EMC,  error messages come up on screen "Initialization Failed   The following error occurred  when searching  for On-Premises Exchange Server:  [] Connecting to remote  server failed  with the following error message: The WinRM client cannot process the request.  It cannot determine the content type of the HTTP  response from the destination computer.  The content type is absent or invalid.".  Even the EMS there is an error "Failed to connect to any Exchange Server in the current site".  What I did to fix this was I tried to check IIS>Powershell kerbauth it was showing native.  I go to cmd then run the netsh winhttp proxy, I am connected directly.  What to do to fix my problem?  Kindly help and assist me.  


    2012年4月25日 11:22