Install Error - Visio 2010 Premium


  • Hi there,

    I'm tryng to install Visio 2010 Premium (32bit) on my Windows 7 Home Premium (64bit) laptop (all MS Office components are 32 bit). I DL'd the install file from DigitalRiver. When I start the install I get the following message shortly after I provide the activation key & click "Install Now":

    "Setup cannot find Visio.en-us\ Browse to a valid installation source, and then click OK."

    The dialogue box takes me to a view of my User temp folder and sets focus on a particular folder that contains the cab file it claims it can't find. If I choose any other folder, or even the Visio.en-us folder itself I get an "Invalid Location" error.

    Another link (regarding an Office install, but a similar message) implies it might be an issue with the local cache??

    Here is a link to a similar problem with Visio 2007:

    Finally, I took a look at the Setup.xml file in the phantom Visio.en-us folder and found this at the end (the paths described seem to be correct):

     <LocalCache DownloadCode="{90140000-0054-0409-0000-0000000FF1CE}" SkuComponentDirectory="Visio.en-us">
      <File Id="VisioMUI.xml" MD5="3ABD97FD9719AB5883548BD0674DCD17" Size="9502" RelativeCachePath="VisioMUI.xml" RelativeSourcePath="VisioMUI.xml"/>
      <File Id="VisioMUI.msi" MD5="A33BDFEBC93C64B507D1E70C0AD1F946" Size="2087424" RelativeCachePath="VisioMUI.msi" RelativeSourcePath="VisioMUI.msi"/>
      <File Id="" MD5="23819FCA31B730E23ECFD5CE4061BAD9" Size="50798159" RelativeCachePath="" RelativeSourcePath=""/>
      <File Id="Setup.xml" MD5="" Size="" RelativeCachePath="Setup.xml" RelativeSourcePath="Setup.xml"/>

    Any help is greatly appreciated. Thanks in advance!






    2011年1月5日 6:29


  • I should also add that I run F-Secure AV ( I tried the install with the AV turned on and turned off - same result. Also tried rebooting - no change.




    2011年1月5日 19:22
  • Hi, Rob



    You can try referring to the post in the forum:


    Visio 2010 setup error






    2011年1月7日 3:14
  • Harry,

    Unfortunately, neither here OR on that thread (even though it's listed as having the question answered) is there an actual fix for this issue! Please, PLEASE revisit this ASAP and get us an actual answer for how to install this program!

    Thank you!

    2011年1月14日 18:05
  • Has anyone found a solution to this?  I'm getting the same error "Setup cannot find Visio.en-us\ Browse to a valid installation source, and then click OK."  
    2011年3月16日 15:48
  • Same problem here...2010 Standard on i386 XP SP3.
    2011年5月10日 13:15
  • Hi Rob,

    Take the system into a "clean boot" state, and then run Office setup. This disables the third-party applications.

    The third-party application that is denying access to the registry subkey can no longer deny access.

    For more information about how to take the system into a "clean boot" state, click the following link to view the article in the Microsoft Knowledge Base:



    2011年5月11日 1:44
  • I had this same error message when installing it from a disk that I burned the image on to. I solved the problem by re-burning the image at a slower speed. Probably not what you are looking for though.
    2012年3月29日 21:55
  • I had same issue and realized the probelm was with installation media I was trying to run.

    I was running Windows 2008 R2 (x64) and was attempting to install x86 MS Visio and x86 Project. Was seeing this issue. I pulled down the x86_x64 install packages from the MSDN and seem to have everything running now.

    • 已编辑 jaylab88 2012年4月24日 16:48
    • 已建议为答案 DueyDooDah2 2012年5月24日 21:58
    • 取消建议作为答案 DueyDooDah2 2012年5月24日 21:58
    2012年4月24日 13:19
  • I have fixed my problem but am not sure my solution is a valid one. I installed the Trial version under an admin account (everything went smoothly). I then uninstalled it then switched to another account, the user account (this one had Admin access, which I reset to standard once I was done). The installation of the purchased product (a volume license image) installed without a flaw. Go figure.
    2012年5月24日 22:02