none
Error: 17806, Severity: 20, State: 14. RRS feed

  • Question

  • Error: 17806, Severity: 20, State: 14.
    SSPI handshake failed with error code 0x8009030c, state 14 while establishing a connection with integrated security; the connection has been closed. Reason: AcceptSecurityContext failed. The Windows error code indicates the cause of failure.

    we are continouesly geting errors in our SQL logs.

    Can please help me to fix the issue.

    Wednesday, August 15, 2012 10:07 AM

Answers

  • Error: 17806, Severity: 20, State: 14.
    SSPI handshake failed with error code 0x8009030c, state 14 while establishing a connection with integrated security; the connection has been closed. Reason: AcceptSecurityContext failed. The Windows error code indicates the cause of failure.


    Hi Kiran Kumar,

    It may seem that the issue is related to Kerberos, because we see most of the SSPI handshake error messages due to Kerberos failure, which would most likely be related to non-existent SPN or bad SPN for SQL Server. We would expect that, for local connections, we are connecting over NTLM and the SPN is not required for NTLM.

    A reference discussion on the error “SSPI handshake failed with error code 0x8009030c” can be found in this forum post: http://social.msdn.microsoft.com/Forums/en-US/sqlsecurity/thread/c46b0257-7304-47dc-a8b5-090001ff70a5.
     
    Please see this blog for more information about this issue.

    Thanks,
    Maggie

     

     


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. This can be beneficial to other community members reading the thread.

    Thursday, August 16, 2012 12:27 PM
    Moderator

All replies

  • Hello,

    SSPI handshake errors can have many different reasons, the most common reason is that the client clock differs more the 5 minutes from the server clock, so you may check this first.


    Olaf Helper
    Blog Xing

    Wednesday, August 15, 2012 10:11 AM
    Moderator
  • Also, make sure that the server is configured correctly with the Windows Domain and Active Directory.

    Eitan Blumin; SQL Server Consultant - Madeira SQL Server Services; http://www.madeira.co.il/author/eitan/

    Wednesday, August 15, 2012 2:03 PM
  • Error: 17806, Severity: 20, State: 14.
    SSPI handshake failed with error code 0x8009030c, state 14 while establishing a connection with integrated security; the connection has been closed. Reason: AcceptSecurityContext failed. The Windows error code indicates the cause of failure.


    Hi Kiran Kumar,

    It may seem that the issue is related to Kerberos, because we see most of the SSPI handshake error messages due to Kerberos failure, which would most likely be related to non-existent SPN or bad SPN for SQL Server. We would expect that, for local connections, we are connecting over NTLM and the SPN is not required for NTLM.

    A reference discussion on the error “SSPI handshake failed with error code 0x8009030c” can be found in this forum post: http://social.msdn.microsoft.com/Forums/en-US/sqlsecurity/thread/c46b0257-7304-47dc-a8b5-090001ff70a5.
     
    Please see this blog for more information about this issue.

    Thanks,
    Maggie

     

     


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. This can be beneficial to other community members reading the thread.

    Thursday, August 16, 2012 12:27 PM
    Moderator
  • Possible Resolution:

    The registry setting to disable loopback check needs to be entered. In MOSS 2007, logging in to a SharePoint site from the server would result in a timeout and/or error message. In SPS 2010, the server returns an error upon first load to the GUI and upon refresh will display the requested page.

    To set DisableLoopBackCheck:

    1. Click Start

    2. Search for "regedit"

    3. Right click on regedit.exe and select Run as Administrator

    4. Expand the tree to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa

    5. Right click on LSA and click New --> DWORD Value

    6. Enter the name DisableLoopbackCheck

    7. Right click on DisableLoopBackCheck and click Modify

    8. Enter 1 for the Value and click OK

    9. Restart the server

     

    Helpful links:

     

    http://www.itmonotony.com/Lists/Posts/Post.aspx?ID=42

    http://stackoverflow.com/questions/1538027/sspi-handshake-failed-with-error-code-0x8009030c-while-establishing-a-connection


    Please click the Mark as Answer or Vote As Helpful if a post solves your problem or is helpful!


    • Edited by RohitGarg Thursday, August 16, 2012 1:46 PM
    Thursday, August 16, 2012 1:45 PM
  • Hello,

    Check out the threads below. It may help you.

    http://social.msdn.microsoft.com/Forums/en-US/sqlintegrationservices/thread/b5d48c3d-65b6-401d-8b21-5e127faeb5f1/

    http://www.allenkinsel.com/archive/2010/06/sql-server-and-sspi-handshake-failed-error-hell/

    http://dbaduck.com/2007/08/31/error-in-sql-error-17806-error-18452-sspi-problem/

    Friday, August 17, 2012 11:10 AM
  • why is this severity 20? login failure is not a fatal error this causes false alarms for sql monitor.

    Severity Level 20: SQL Server Fatal Error in Current Process

    These messages indicate that a statement has encountered a problem. Because the problem has affected only the current process, it is unlikely that the database itself has been damaged.

    Friday, November 23, 2012 11:40 PM
  • This can happen when a user changed the password and is still logged on with the old password.

    Logoff/logon helps in this case.

    Wednesday, August 7, 2019 2:29 PM