none
Afte uploading the document, Icon not reflecting in Project Center. Environment : Project Server 2013 RRS feed

  • Question

  • After adding doc to project site there is no document icon in "project center", and no icons on project schedule level " exists. Tried to create new blank project, add docs to Documents library via WebApps, Send document feature, use new drag-n-drop feature, tried to link related file from library to project task but icon doesn't appear.

    Please help to resolve the issue.

    Thursday, February 5, 2015 5:06 PM

Answers

  • All,

    To confirm, after patching my Project Server 2013 environment with a later patch the document icon does in fact appear as expected.

    It appears for my server with only SP1 the document icon functionality didn't work but after applying the February 2015 server roll up package (http://support.microsoft.com/kb/2920796) this functionality does work after using the Upload Document functionality on the document library. It might be fixed in a patch between SP1 and the February 2015 CU but I am not sure which one - unless the issue was isolated to my Project Server SP1 environment only!

    EPMadmin, it might be worth looking to apply a later patch to resolve this issue. Fully test any patch on a replica test / non production environment first and have a roll back plan in place should you need to revert the system back to the previous state.

    Paul


    Paul Mather | Twitter | http://pwmather.wordpress.com | CPS | MVP | Downloads

    Monday, February 23, 2015 9:33 PM
    Moderator

All replies

  • Hello,

    In Project Server 2013 you do not get the documents icon, only Issues and Risks. This is due to the way the backend now works with linking SharePoint items to Projects / tasks, documents don't have any event receivers so the data can't be synchronised.

    Paul


    Paul Mather | Twitter | http://pwmather.wordpress.com | CPS | MVP | Downloads

    Thursday, February 5, 2015 5:35 PM
    Moderator
  • Hello ,

    I have upload the issue and icon is reflecting in the project center, however some site show the document icon some are not.

    Question is then it not suppose see the icon for any of the site. Please find the screen shot for the same.


    

    Thursday, February 5, 2015 6:22 PM
  • Was this system upgraded from Project Server 2010? Or was this document added before you patched Project Server 2013 with Service Pack 1? I believe this kind of worked but not properly between RTM and SP1 but I believe it was turned of altogether in Project Server 2013 with SP1.

    Paul


    Paul Mather | Twitter | http://pwmather.wordpress.com | CPS | MVP | Downloads

    Thursday, February 5, 2015 8:24 PM
    Moderator
  • Hello Paul,

    Yes you are correct, the Project server upgrade form 2010 to 2013. we have implement the Public update and SP1 and July CU.

    Please suggest how to resolve the issue.

    Thanks

    Thursday, February 5, 2015 9:52 PM
  • Hello, there isn't an issue to resolve? It is a feature that is no longer available in Project Server 2013. Paul

    Paul Mather | Twitter | http://pwmather.wordpress.com | CPS | MVP | Downloads

    Thursday, February 5, 2015 10:17 PM
    Moderator
  • Hello Paul,

    Thanks for your response, do we any workaround solution for the same.

    Thanks,

    Monday, February 9, 2015 5:17 PM
  • Hello,

    There is no workaround, the feature just is not available anymore. You could look at creating a custom report if needed to quickly see what projects have documents etc. but that wouldn't create the document icon in the project center.

    Paul


    Paul Mather | Twitter | http://pwmather.wordpress.com | CPS | MVP | Downloads

    Monday, February 9, 2015 8:38 PM
    Moderator
  • Hello Paul,

    Today I have seen the strange issue, in QA environment when i have created the new project and upload some document to Project Document list.  

    The document ICON appears, however your statement state that PS 2013 not supported this functionality.

    Then how it works in QA environment.

    Please find the screen shot for the same.

    Monday, February 9, 2015 9:12 PM
  • What patch level is the QA farm?

    Paul


    Paul Mather | Twitter | http://pwmather.wordpress.com | CPS | MVP | Downloads

    Monday, February 9, 2015 9:14 PM
    Moderator
  • Monday, February 9, 2015 10:20 PM
  • Do you have exactly the same patches applied to both farms? Check in central admin in the upgrade section to confirm. Paul

    Paul Mather | Twitter | http://pwmather.wordpress.com | CPS | MVP | Downloads

    Monday, February 9, 2015 10:38 PM
    Moderator
  • Thanks Paul,

    Yes we have same patch in PRD environment.

    Tuesday, February 10, 2015 3:36 PM
  • it is possible to add docs, issues and risks at project or task level. Brian wrote a very compelling blog post about it. see here: http://blogs.technet.com/b/projectsupport/archive/2014/05/23/project-server-2013-links-to-issues-risks-and-documents.aspx

    actually in 2013 it is a bit more complex, but once you get it, it is easy to do. the tricks is to use "add related item" on the synced tasks on the sharepoint task list of your project site. it will then show the document icon under the indicator column in project center.

    Tuesday, February 10, 2015 6:56 PM
  • Is that issue appears on all the Projects? Only on migrated projects?

    Sometimes the icon will appear after a successfull project publish and Project Site syn job.

    If its a migrated project, removing and re-linking the site with the respective project plan can resolve this issue.

    If you are able to reproduce the issue always, advisable to open a support ticket with Microsoft.


    Cheers. Happy troubleshooting !!! Sriram E - MSFT Enterprise Project Management

    Tuesday, February 10, 2015 11:11 PM
    Moderator
  • Hello EPMAdmin,

    What have you found from testing, I still believe the functionality to display document icons in the project center has been removed. Also see Brian's comment from 23rd Dec that backs this up:

    http://blogs.technet.com/b/projectsupport/archive/2014/05/23/project-server-2013-links-to-issues-risks-and-documents.aspx

    Paul


    Paul Mather | Twitter | http://pwmather.wordpress.com | CPS | MVP | Downloads

    Monday, February 23, 2015 5:19 PM
    Moderator
  • Paul,

    I think the 'issue' that Brian is talking about is that, the icon does not take you to the specific document library in which the document is uploaded in. It just takes you to the Project Site Home page.

    This also means that there will be no icon at the "Task" level.

    However, the icon will show up at the Project Center level, regardless of which doc library the document is uploaded into. I have confirmed this on my installation, with Dec 2014 CU.

    So, I think the issue here is different.


    Cheers,

    Prasanna Adavi, Project MVP

    Blog:   Podcast:    Twitter:    LinkedIn:   

    Monday, February 23, 2015 5:29 PM
    Moderator
  • Thanks Prasanna,

    I have just tested again on my VM (on prem) and it doesn't work but just tested on Project Online and it does work. My On prem VM is only at SP1 so maybe there is a fix in between SP1 and Dec 2014 CU then? :)

    I will deploy the Feb 2015 update later and retest and post back!

    Paul


    Paul Mather | Twitter | http://pwmather.wordpress.com | CPS | MVP | Downloads

    Monday, February 23, 2015 5:51 PM
    Moderator
  • All,

    To confirm, after patching my Project Server 2013 environment with a later patch the document icon does in fact appear as expected.

    It appears for my server with only SP1 the document icon functionality didn't work but after applying the February 2015 server roll up package (http://support.microsoft.com/kb/2920796) this functionality does work after using the Upload Document functionality on the document library. It might be fixed in a patch between SP1 and the February 2015 CU but I am not sure which one - unless the issue was isolated to my Project Server SP1 environment only!

    EPMadmin, it might be worth looking to apply a later patch to resolve this issue. Fully test any patch on a replica test / non production environment first and have a roll back plan in place should you need to revert the system back to the previous state.

    Paul


    Paul Mather | Twitter | http://pwmather.wordpress.com | CPS | MVP | Downloads

    Monday, February 23, 2015 9:33 PM
    Moderator
  • Thanks paul,

    I have updated the Oct CU in Project server farm, still it not working in one of my development environment, even I have seen one more issue that you were not able to associated any document with Task.

    I am not sure why MS have remove this functionality in 2013 that is available in earlier Version.

    Please let me know, however we can have any workaround solution.

    Thanks..

    Friday, February 27, 2015 9:52 PM
  • All,

    To confirm, after patching my Project Server 2013 environment with a later patch the document icon does in fact appear as expected.

    It appears for my server with only SP1 the document icon functionality didn't work but after applying the February 2015 server roll up package (http://support.microsoft.com/kb/2920796) this functionality does work after using the Upload Document functionality on the document library. It might be fixed in a patch between SP1 and the February 2015 CU but I am not sure which one - unless the issue was isolated to my Project Server SP1 environment only!

    EPMadmin, it might be worth looking to apply a later patch to resolve this issue. Fully test any patch on a replica test / non production environment first and have a roll back plan in place should you need to revert the system back to the previous state.

    Paul


    Paul Mather | Twitter | http://pwmather.wordpress.com | CPS | MVP | Downloads

    hello, this problem NOT Fixed! 

    I install Project server 2013 SP1 and CU 15.0.4805.1000

    This problem is present and  documents icon not show !

    how fix this problem?

    Friday, March 25, 2016 8:34 AM