none
Adding Enterprise Project Types to New Project menu RRS feed

  • Question

  • I've added two additional Enterprise Project Types and indicated where I want them placed in the "New" menu of the Project ribbon (before the default SP Task List and Enterprise Project) but they are not showing up - only the default SharePoint Task List and Enterprise Project show up.

    What am I missing?

    Thanks.

    Monday, July 22, 2019 2:30 PM

Answers

  • BBertlin --

    Pardon me for bumping into this conversation.  The simplest solution to your problem would be to remove the Departments value you set for each Enterprise Project Type you created.  Your problem is caused by setting a Departments value for the EPT, but not having a Project Department value set for your user account.  Even though you are a member of the Administrators security group, the mismatch on Department values is preventing you from seeing the new EPTs in the Project Center page.  Hope this helps.


    Dale A. Howard [MVP]

    • Marked as answer by BBertlin Tuesday, July 23, 2019 7:58 PM
    Tuesday, July 23, 2019 4:34 PM
    Moderator

All replies

  • Hi,

    I've never seen such an issue. When you go to PWA server setting, do you see your 2 new EPT? Are you admin of your PWA tenant? Do you have departments configured?

    Note also that you cannot choose the EPT in MS Project (desktop client), but only from the project center in PWA.


    Hope this helps,


    Guillaume Rouyre, MBA, MVP, P-Seller


    Monday, July 22, 2019 2:42 PM
    Moderator
  • Yes - I see my two EPT plus the default types.  I am admin and I have departments configured with an entry for each new project type (to help me categorize these two EPTs).

    

    Monday, July 22, 2019 4:34 PM
  • It might be due to the departments. Try to add your account to all departments.

    Hope this helps,


    Guillaume Rouyre, MBA, MVP, P-Seller

    Monday, July 22, 2019 5:14 PM
    Moderator
  • Thanks for the response but I don't understand how to accomplish "add your account to all departments".  I have created a lookup table that is used within a custom field I created called "Project Department".

    Could you give me the step by step please?

    Thanks.

    Monday, July 22, 2019 6:27 PM
  • BBertlin --

    Pardon me for bumping into this conversation.  The simplest solution to your problem would be to remove the Departments value you set for each Enterprise Project Type you created.  Your problem is caused by setting a Departments value for the EPT, but not having a Project Department value set for your user account.  Even though you are a member of the Administrators security group, the mismatch on Department values is preventing you from seeing the new EPTs in the Project Center page.  Hope this helps.


    Dale A. Howard [MVP]

    • Marked as answer by BBertlin Tuesday, July 23, 2019 7:58 PM
    Tuesday, July 23, 2019 4:34 PM
    Moderator
  • Dale - THANK YOU for bumping in - you nailed it.  I removed the department selection in my EPTs and they miraculously now appear in the New menu.

    Thanks a bunch.

    Brian

    Tuesday, July 23, 2019 7:59 PM