Testing MS Project Professional 2013 RRS feed

  • Question

  • I downloaded MS Project 2013 and have been using it since a couple of weeks. I found so far two points which will make our potential transition to 2013 difficult:

    - Resource pool files saved in 2013 do not seem to agree with previous MS Project 2010. Is the 2013 backward compatible to 2010?

    - In a Resource pool file, if I want to break the link to a project using the pool - via Resource->Resource pool->Share resources - nothing is going to happen and the link still persist.

    Can anybody clarify those two points?

    Thanks in advance.


    Tuesday, June 11, 2013 1:26 PM


  • Ah, you didn't state the original sharer files were gone.  You need to rebuild the pool file (as you did) or risk significant corruption issues.  Never move, delete, or rename files connected to a pool without disconnecting.
    Wednesday, October 30, 2013 9:05 PM

All replies

  • Hello Francesco,

    What specific issues are you seeing with the Resource Pool files from Project 2013 being used in Project 2010?  What is 'not seem to agree' mean?

    The issue about breaking the link between sharer files and resource pool files has been around for quite awhile.  Often the link needs to be broken both from the Pool file and the sharer file.

    Open the Pool file with the second option "Open the resource pool read-write so you can make changes......"

    In the pool file, Resources tab > Resource Pool > Share resources and select the file you wish to stop sharing to in the list and select, "Break link".

    Wednesday, June 12, 2013 2:41 PM
  • I'm having the same problem with Project 2013.  I am doing the correct steps.

    I open the resource pool read-write.

    In the pool file, I click Resources tab > Resource Pool > Share resources and select the file I wish to stop sharing to in the list and select, "Break link".

    I then save the file, but when I open it again, the link is still there.  I have tried this over and over with different links that I want to break, but they never save.  

    Has anyone else seen and solved this issue?


    Thanks, Rich

    Tuesday, October 29, 2013 4:11 PM
  • From the pool file, Resource Sharing window, select the file you wish to break the link with and open it.  From the Sharer file select Resource Pool > Use Own resources.  Save.  Does that remove the sharer file from the pool file?
    Tuesday, October 29, 2013 6:19 PM
  • The problem is that the Sharer file does not exist anymore.  I tried recreating a file with the same name so it existed again, but then when I pick "Use Own Resources", Project crashes.  I ended up just copying the resources out of the pool and into a new resource pool with the same name and then doing an "Update Resource Pool" and it worked.


    Thanks, Rich

    Wednesday, October 30, 2013 7:45 PM
  • Ah, you didn't state the original sharer files were gone.  You need to rebuild the pool file (as you did) or risk significant corruption issues.  Never move, delete, or rename files connected to a pool without disconnecting.
    Wednesday, October 30, 2013 9:05 PM
  • Thanks.  I learned my lesson the hard way :-(


    Thanks, Rich

    Wednesday, October 30, 2013 9:12 PM
  • Thanks for the answer, I asked the same thing earlier today (albeit in the wrong forum section - oops): http://social.technet.microsoft.com/Forums/en-US/projectonline/thread/6f08958a-8a2c-46d4-a953-e93fed788800/#6f08958a-8a2c-46d4-a953-e93fed788800

    Seems pretty wide-spread, is there a way we can log a bug report?

    Thursday, October 31, 2013 12:47 AM
  • Not a bug.  If you delete, move, or rename a file connected to the pool you are asking for a problem with file corruption.
    Thursday, October 31, 2013 2:38 PM
  • I guess it's not a "bug" per se, but why won't the "break link" function work when editing the resource pool?  I would think the resource pool shouldn't care if the sharer file exists or not.  If I tell it to break the link, just remove the info about that file from the pool.


    Thanks, Rich

    Thursday, October 31, 2013 2:42 PM
  • Of course the pool file "cares" about the sharer file's existence -- it is the pool file that is keeping track of all assignments for each resource and must know where all the assignments are coming from.  Using pool files without strong controls is a recipe for disaster.

    I agree it shouldn't be necessary to open the sharer file as well to break the link - but a bug do to sharer files being deleted - no.

    Thursday, October 31, 2013 2:48 PM
  • Re: bug, I mean specifically the ability to remove a linked .MPP (via the 'Break Link' button in the Resource Pool dialog) doesn't work and instead creates a crash to desktop.

    The 'Break Link' button behaviour is broken because it causes a crash rather than doing a force de-link. Also, I can't unlink a 'valid' shared file either (i.e. one that is connected to the pool and still exists).

    Certainly since we noticed the problem, we have adopted standard naming and file formats - prevention is better than cure!

    Friday, November 1, 2013 12:58 AM
  • I'm not seeing the crash on unlinking a valid file.  Do you have any cumulative updates installed to Project 2013?
    Friday, November 1, 2013 1:08 PM
  • It works in Project 2010 from just the resource pool without disconnecting in the sharerfile. For me it is a bug. Some of my customers claimed that Project 2013 does not have the same function as 2010.
    Thursday, March 27, 2014 2:04 PM
  • jek_b,

    If I may interject. With ALL versions of Project a link between two files has two parts, a source tag and a destination tag. If both are not broken and the files saved then a link fragment will remain and that is the seed for corruption. If it seemed to work previously by only breaking one end of the link and saving you are simply lucky. No bug, it's just the way it works.


    Thursday, March 27, 2014 2:54 PM
  • In previous version was possible drop broken links from resource pool for subproject which  no longer exists. 

    You say, it isn´t bug. Ok. But it is stupid, if there is no posibility to clear pool sharing now.

    Friday, March 28, 2014 12:59 PM
  • what difference does it make because  "it has been around for quite awhile."
    Sunday, March 30, 2014 12:25 AM
  • I Export  my resourcepool to XML file  and then, open xml and save it back to its original location as mpp.Resource and calendar information persists in pool,  tasks reconects when opening sharers Mpp files  (consolidated project)

    Private Function RepairResourcepool(MPPFileName As String) As Boolean
        Dim xmlfilename As String
        xmlfilename = Strings.Replace(Strings.LCase(MPPFileName), ".mpp", ".xml")
        If Application.FileOpenEx(name:=MPPFileName, openpool:=pjPoolReadOnly) Then

                FileSaveAs name:=xmlfilename, FormatID:="MSProject.XML"

                FileCloseAll Save:=pjDoNotSave ''
                Call Kill(MPPFileName)
                FileOpenEx name:=xmlfilename, FormatID:="MSProject.XML"
                FileSaveAs name:=MPPFileName, FormatID:="MSProject.mpp", ReadOnly:=False
                FileCloseAll Save:=pjDoNotSave
                Call Kill(xmlfilename)
                RepairResourcepool = True
                RepairResourcepool = False
        End If
    End Function

    Tuesday, April 1, 2014 11:29 AM
  • Hello all, 

    I realize that this is an old thread, but here is the simplest way to fix a resource pool link when you have already deleted a project file that the pool is still linked to:

    1.  Go to the resource pool file, open the "Shared Resources" list and note the name and location of the deleted file.  Leave the resource pool open.

    2.  Open an existing file that is currently connected to the resource pool and "Save As" the name of the deleted file in the location of the deleted file.  The open resource pool will then think that this is the original file.

    3.  In your new file, select "Use own Resources" as other people have described doing on this thread.  Save the file.

    4.  Go to your resource pool and note that the file is no longer listed in the "shared resources" list.  Save the resource pool.

    That is it!


    Thursday, August 14, 2014 5:26 PM
  • I had the same problem 

    FIX:  the resource pool master document (I.e. the project which holds the master resource pool) must be opened and remain opened or otherwise when you click on resource pool>share resources then the resource pool location will be greyed out and when you try to change to "Use own resources" it will NOT hold onto change.

    So yes the IMPORTANT thing is to make sure the resource pool document is also open when making changes to the Resource pool in other documents. 

    Wednesday, December 31, 2014 2:38 PM