none
Can't edit Enterprise Projects nor Enterprise Calendar in Project Online

    Question

  • Hi,

    For an unknown reason, I can't edit Enterprise Projects nor Enterprise Calendars in Project Online via Project Professional 2016 (desktop application).  I get the following error message...

    "Sorry, we were unable to open your project.  Please try again.  If this happens again, contact your administrator."

    I'm the administrator of the the site "Project Online" (PWA) and do have administrative rights for PWA.  I though it might have been an issue with the permission sharing mode (SharePoint Permission Mode or Project Permission Mode), but tried both modes and always get the same results.

    The thing is that I can create projects or new calendars, but once they are saved (published), I can no longer edit them.

    What shall I do?
    I have tried deleting the Project Web App site (https://MyCompany.sharepoint.com/sites/pwa) as it's a new one and I have no data yet in it, but I still encounter the same problem.

    Please advise.

    Thanks.


    Monday, February 12, 2018 6:55 PM

Answers

  • Hello Guillaume and Julian,

    It looks like Chrome (the browser I typically use) is the one in fault.  I have tried with IE, and was able to open/edit the Standard Enterprise Calendar which I couldn't.

    Do know what setting could be in fault in Chrome?
    It used to work two weeks ago.

    Regards,

    Patrick.

    Have also run into this issue on several PC's in the office. Using Edge to open PWA has worked fine. Chrome is a no go. Updated to latest version of Chrome and still having issues. My unaffected users seem to be on Chrome 63, affected users are Chrome 64.

    There are a few usable workarounds, but my users are used to opening from Chrome. Would love to figure this one out!

    I do not believe it is a chrome setting etc., as I have several users affected, from laptops imaged in 2016 to a brand spanking new Surface Pro i7 with a fresh install of Windows 10 & Chrome on default settings.

    Followed a blog post about removing all Windows Credentials related to PWA, re-installed, etc. all to no avail.

    I'm toast today but will dig deeper tomorrow.

    Hi there, 

    I am IT help desk admin at my company and this first appeared with one of our Project managers last week and now has since happened with 2 others. After over 45min troubleshooting, this IS indeed a Chrome issue and hopefully Google will become aware of it and fix it in an upcoming release.

    Thursday, February 15, 2018 2:53 PM

All replies

  • Hi, are you assigned to a security group? It is not enough being the site collection administrator. Did you put the pwa into the trusted sites in IE? Also did you try to delete the cache of the client?


    Best regards,

    Julian, PMP, MCP, MCSA, MCSE

    Blog: https://project-brain.com

    Note: Posts are provided “AS IS” without warranty of any kind, either expressed or implied, including but not limited to the implied warranties of merchantability and/or fitness for a particular purpose.


    Tuesday, February 13, 2018 6:58 AM
  • Hi Patrick,

    In addition to Julian's excellent advice, be sure to open MS Project connected to your PWA instance before trying to open the enterprise calendar. You could also try with another browser.

    It could also be related to the Windows credential manager. Check this blog to see if it helps:

    https://ppm4all.com/2017/02/16/solved-cannot-connect-to-project-online-could-not-load-project-job-failed-retrieve-enterprise-global-template-internal-error-unable-to-open-your-project/


    Hope this helps,


    Guillaume Rouyre, MBA, MVP, P-Seller

    Tuesday, February 13, 2018 7:50 AM
    Moderator
  • Hello Guillaume and Julian,

    It looks like Chrome (the browser I typically use) is the one in fault.  I have tried with IE, and was able to open/edit the Standard Enterprise Calendar which I couldn't.

    Do know what setting could be in fault in Chrome?
    It used to work two weeks ago.

    Regards,

    Patrick.

    Tuesday, February 13, 2018 2:53 PM
  • I second Patrick.

    It works fine at Firefox too. Not just with Chrome.

    Tuesday, February 13, 2018 4:22 PM
  • Hello Guillaume and Julian,

    It looks like Chrome (the browser I typically use) is the one in fault.  I have tried with IE, and was able to open/edit the Standard Enterprise Calendar which I couldn't.

    Do know what setting could be in fault in Chrome?
    It used to work two weeks ago.

    Regards,

    Patrick.

    Have also run into this issue on several PC's in the office. Using Edge to open PWA has worked fine. Chrome is a no go. Updated to latest version of Chrome and still having issues. My unaffected users seem to be on Chrome 63, affected users are Chrome 64.

    There are a few usable workarounds, but my users are used to opening from Chrome. Would love to figure this one out!

    I do not believe it is a chrome setting etc., as I have several users affected, from laptops imaged in 2016 to a brand spanking new Surface Pro i7 with a fresh install of Windows 10 & Chrome on default settings.

    Followed a blog post about removing all Windows Credentials related to PWA, re-installed, etc. all to no avail.

    I'm toast today but will dig deeper tomorrow.

    Wednesday, February 14, 2018 12:10 AM
  • Hello Guillaume and Julian,

    It looks like Chrome (the browser I typically use) is the one in fault.  I have tried with IE, and was able to open/edit the Standard Enterprise Calendar which I couldn't.

    Do know what setting could be in fault in Chrome?
    It used to work two weeks ago.

    Regards,

    Patrick.

    Have also run into this issue on several PC's in the office. Using Edge to open PWA has worked fine. Chrome is a no go. Updated to latest version of Chrome and still having issues. My unaffected users seem to be on Chrome 63, affected users are Chrome 64.

    There are a few usable workarounds, but my users are used to opening from Chrome. Would love to figure this one out!

    I do not believe it is a chrome setting etc., as I have several users affected, from laptops imaged in 2016 to a brand spanking new Surface Pro i7 with a fresh install of Windows 10 & Chrome on default settings.

    Followed a blog post about removing all Windows Credentials related to PWA, re-installed, etc. all to no avail.

    I'm toast today but will dig deeper tomorrow.

    Hi there, 

    I am IT help desk admin at my company and this first appeared with one of our Project managers last week and now has since happened with 2 others. After over 45min troubleshooting, this IS indeed a Chrome issue and hopefully Google will become aware of it and fix it in an upcoming release.

    Thursday, February 15, 2018 2:53 PM
  • This started happening this week, it is not only Chrome, it is also happening when using IE. I am the PWA administrator for a large organization. So far I have 4 Project Managers with this problem, they cannot open their project schedules from PWA using IE or Chrome. They can open them from Microsoft Project Professional directly. The common issue is that these users are on Windows 7. I have not heard reports of anyone having this issue in Windows 10 yet. If someone has a solution please share.
    • Edited by Ameythal Friday, February 23, 2018 4:16 PM
    Friday, February 23, 2018 4:16 PM
  • Just want to reply and say I'm seeing the same issue with Chrome and have been since early February with multiple users. 

    Other browsers continue to work fine, I had a separate thread opened up here as well.

    https://partnersupport.microsoft.com/en-us/par_onlserv/forum/par_shareon/projects-not-opening-up-through-chrome-still-work/f26618e4-cc64-4b66-be9d-a0578da956a9

    Friday, February 23, 2018 10:24 PM
  • We're seeing the same issue in Chrome v64, having just upgraded from v62.

    We're also seeing issues in IE, but understand that there is a known issue specific to users running Internet Explorer 11 version 11.0.49 or later on Windows 7 which MS are working on. They recommend we try using a different browser or opening directly from Project as a workaround.

    If desperate to use IE you can also;

    a) From the Internet Explorer Tools menu, click F12 Developer Tools. You can also select the F12 key.

    b) Click the Emulation tab.

    c) Set the Document Mode to 10.

    d) Edit your resources or your calendars.

    e) Close the developer tools pane.

    Pete

    Friday, March 2, 2018 2:12 PM
  • Noticed an update to Chrome 65 today, no change in the issue, Project links still unable to open. Quite disappointed this is still occurring.
    Wednesday, March 7, 2018 2:46 PM
  • Hello,

    The edition of enterprise Calendars only works in IE, but you necesary must add your PWA in Trusted sites list in your IE, 

    You can see other details for the solution in 

    https://letrasandnumeros.com/2019/01/08/open-enterprise-calendars/

    Regards,


    Thursday, January 10, 2019 2:09 PM
  • Hi All,

    Since we moved from Server 2013 to Server 2016 back in mid 2017 on-prem we could only edit the Enterprise Calendar if connected via a company machine to the internet with our firewall turned off (with that pc being dis-connected from the rest of the network obs but the SSO allowed me a connection to Server).

    Today, after 2 years I have found a solution without this work around...

    Using the F12 option in IE 11 I changed the Emulation Document Mode from 10 (default) to 11. In the Enterprise Calendar PWA settings I highlighted our calendar and clicked Edit and shazam !  I can't believe this worked :-)

    You're welcome.

    Steve D
    Monday, May 20, 2019 3:00 AM
  • I had to use Mode 11 on Win 10

    SteveD01

    Monday, May 20, 2019 3:19 AM