none
Rollup to summary levels no longer working in MS Project 2016 Standard

    General discussion

  • I have existing custom calculations set up in MS Project 2016 to calculate % Planned using duration as one of the parameters. I use PROJDURVALUE ([duration]) to calculate the task durations in a custom number field and set Rollup SUM as the task and group summary row rollup for the custom field.

    Since I have the new patch version of MS Project 2016 Standard, namely 16.0.4266.1001 of 2018/01/07, the rollup to the summary levels does not work, as it just has zeros in the summary rows for this custom number field. I am using ROLLUP, SUM as the summary calculation method for the custom calc.

    This must be a bug, seeing as it used to work last year and the calc has not been changed at all.

    Please help.

    Monday, January 22, 2018 11:50 AM

All replies

  • Have you tried using the other custom number fields ?

    By the way, the build number for the January update is 16.0.4639.1001.

    Ref: https://blogs.technet.microsoft.com/projectsupport/project-2016-public-updates/


    Monday, January 22, 2018 12:01 PM
  • All the custom number fields work fine for the actual calculations, just the rollups to summary levels do not work. Strangely, a few of the summary levels have values calculated but most of them show zeros, despite the child tasks under the summary levels all having values in them.
    Monday, January 22, 2018 12:27 PM
  • Colin,

    It may not be a good one but my only suggestion would be uninstalling the last update from <Programs and Features> and test again. Please post back on your progress.

    Regards. 


    Ismet Kocaman | eBook on Formulas

    Monday, January 22, 2018 12:43 PM
  • Yes, That's what I also thought of trying and I did uninstall the update received on 7th January 2018. It now calculates correctly! So there is definitely a bug in the patch received on 7 January. How can Microsoft be made aware of this so that they can fix it?

    In the meantime I have turned off automatic updates in Windows 10 to prevent further problems.

    Thanks for your suggestions.

    Regards

    Colin

    Monday, January 22, 2018 1:22 PM
  • Colin,

    Thank you for the feedback.

    This is a Microsoft forum. I think you have already let them know about the issue by posting it here.

    Hopefully, it will be fixed by the next public update, along with the following one:

    https://social.technet.microsoft.com/Forums/projectserver/en-US/93943ccc-556d-42d6-8609-0c44423deae8/group-by-not-calculating-formulae?forum=projectprofessional2010general#6a51aa98-d0e0-4882-98ee-5696925275e7

    Regards. 


    Ismet Kocaman | eBook on Formulas

    Monday, January 22, 2018 2:16 PM
  • Ismet,

    Yes this forum is owned by Microsoft but my experience is that Microsoft does not actively monitor this forum for issues. Unfortunately I don't have Project 2016 so I can't verify either issue (Colin's or yours) but I can notify a Microsoft contact and ask him to look into both issues. I will do so and feed back to this thread if I get a response.

    John

    Monday, January 22, 2018 5:31 PM
  • Thank you John.
    Monday, January 22, 2018 7:01 PM
  • To those who may be following this thread,

    I received a response from Microsoft on these issues.

    Microsoft is aware of both problems. An update to fix the Project 2016 rollup to summary level issue exposed a different problem that apparently was there for some time. There is an active request to fix the issue and the projected update release is March or April 2018.

    The issue discovered by Ismet concerning group by rollup, (ref: https://social.technet.microsoft.com/Forums/projectserver/en-US/93943ccc-556d-42d6-8609-0c44423deae8/group-by-not-calculating-formulae?forum=projectprofessional2010general#6a51aa98-d0e0-4882-98ee-5696925275e7), is related to the above problem and should be resolved with the same fix.

    John

    Tuesday, January 23, 2018 7:54 PM
  • John, Thank you very much...
    Tuesday, January 23, 2018 8:00 PM
  • //
    March 6, 2018, update for Project 2016 (KB4011734)
    https://support.microsoft.com/en-us/help/4011734/march-6-2018-update-for-project-2016-kb4011734

    When a task custom field formula is applied and it also uses the formula for summary and group rows, 
    the summary row displays “#ERROR”.  In addition, the grouping row displays incorrect values.
    //

    Not tested it yet, but hopefully the latest public update above will fix it. 
    Friday, March 16, 2018 5:42 AM
  • Hello, 

    I am facing the same issue; In MS Project 2016 while grouping the tasks the custom column values are not shown for the summary tasks,. Is there any update/fix on the issue ?

    Thanks in advance.

    Regards

    Mayank

    Friday, September 14, 2018 10:02 AM
  • Mayank,

    As noted by Ismet, this issue was fixed in the March 2018 update. Is your version of Project 2016 fully updated? It should be version Winproj.exe 16.0.4732.1000. If not, run Windows Update.

    This may seem obvious but did you actually select the appropriate option for calculation for task and group summary rows in the Custom Fields window?

    John

    Friday, September 14, 2018 3:22 PM
  • Hello John,

    Thanks for the reply and the solution; I installed the patch and it fixed 50% of the problem. I can see the values of custom fields on group by. - In task view sheet.

    The issue which still remains is that I have graph in the report which is using this group by column (custom field). when i create the graph from scratch the values are shown as required. but when I save the report and the whole mpp file and next time I open it the values are not shown in the graph. For the work around I go to chart data and then select some other field and deselect it the value pops up in the graph ( as required.) but this manual work has to be done every time I open the mpp file.

    In addition I have put in the page setup of the report " footer" which is also not coming once the file is saved and opened again. Have to manually enter footer details everytime before taking out print out of the report.

    Is there any fix for this?

    Regards,

    Mayank

    Friday, September 21, 2018 7:36 AM
  • Mayank,

    If you only installed the patch of KB4011734 (March 2018) then I strongly suggest you run Windows Update to pick up all the updates since then. That will give you the version number I cited in my previous reply (see:https://blogs.technet.microsoft.com/projectsupport/project-2016-public-updates).

    If you are fully updated but still have the save/print issue, try saving the file to XML. Then re-open the XML file in Project. Note, you will lose any custom formatting with this process.

    John

    Friday, September 21, 2018 2:59 PM
  • The issue which still remains is that I have graph in the report which is using this group by column (custom field). when i create the graph from scratch the values are shown as required. but when I save the report and the whole mpp file and next time I open it the values are not shown in the graph. For the work around I go to chart data and then select some other field and deselect it the value pops up in the graph ( as required.) but this manual work has to be done every time I open the mpp file.

    Mayank,

    Regarding the issue above; IMO, it is not a bug. You need to do some action to trigger MS Project to recalculate the group data and then accordingly populate the related fields on the report.

    I do not have information on the footer issue. This user voice entry may be related to it: https://microsoftproject.uservoice.com/forums/218133-microsoft-project/suggestions/17613028-problem-with-project-professional-2016-not-display

    Regards.


    Ismet Kocaman | eBook on Formulas

    Sunday, September 30, 2018 9:57 PM