[Project Pro 2013] User Custom Field w/ Formula does not calculates on Group Tasks


  • This issue happens only on Project 2013. When I make a formula (using Duration, Cost, Number, etc...) on a custom field and set "Use formula" option in "Calculation for task and group summary rows",
    works fine without groups, on resume tasks. But when I Group the tasks, the group tasks values disappear.

    When I open the same file on Project 2010, it works correctly.

    Thanks in advance.

    Saturday, July 20, 2013 3:38 PM

All replies

  • Hello,

    In quick testing I am unable to reproduce this error.  Please give us some more details - a field you are using and a formula that is not working correctly.  Then tell us which group you are applying and we'll see if we can reproduce the error.

    Sunday, July 21, 2013 2:06 PM
  • Hello Julie, Thanks for the quick reply.

    I tested the fields "duration" and "number", and grouped them by creating a user custom "text1" field (but the issue occurs on any group). I wish i could put an image or a file here...

    The formula is quite simple, like dividing two durations, or two numbers. Then verify the resume tasks without group working correctly, while in any grouping the group task values are not calculated.

    I hope it helps. Thanks again.

    Sunday, July 21, 2013 2:21 PM
  • Can you tell me what you mean by resume tasks?
    Monday, July 22, 2013 1:04 PM
  • Summary tasks. Sorry.
    Monday, July 22, 2013 7:19 PM
  • Have you coded your summary tasks with the value in the "Text1" field?  Here is what I have done and it appears to work correctly:

    1. Created a custom calendar named 7Days where every day of the week was working.
    2. Added the Duration1 field to the Entry table.
    3. In the Duration1 field created the formula ProjDateDiff([Start],[Finish],"7Days") to calculate the duration of the tasks based upon a 7 day work week.
    4. Set the summary tasks to "use formula". All is calculated correctly.
    5. Coded the detail tasks (NOT summary) in the text1 field with a,b,c.
    6. Created a group to group the tasks by Text1.  The Summary tasks were excluded from the group by default.
    7. Returned to the group and selected the option in the Group drop down to "Maintain hierarchy in current group."  The summary tasks were added back in over the subtasks and the values showing in the summary line are correct for the subtasks appearing in the group.

    Now, can you please tell us with as much detail as I have just provided what you are doing?  It is impossible for anyone to troubleshoot the issue given the vague descriptions of the issue you are providing.

    Monday, July 22, 2013 9:24 PM
  • Thank you for the effort. This problem is a bit tricky and hard to explain without images or files.

    I'll try to explain using your example:

    - I do not coded my summary tasks with the value in the "Text1" field and

    - I do not want to maintain hierarchy on groups like you show.

    1. On "No Group" mode, the summary tasks works fine. All summary tasks shows the values calculated by the formula. Summary tasks are not the problem.

    2. However, when you group the tasks by Text1, the Group Tasks (the colored ones that appear on group mode: Group: a, b and c) do not show the values calculated by the formula, even if you set to "use formula" on summary and group tasks.

    3. When you open the same file on Project 2010 (default configs), group tasks values appears (values calculated for the groups of the detail tasks: a, b, c). If your Duration1 field stays the same or disappear, change some values and refresh the field to check the formula is working.

    4. If you see that everything are working correctly so far, try this on your file:

    4.1. Maintain your tasks grouped by Text1.

    4.2. Add three Fields: "Duration2", "Duration3" and "Duration4".

    4.3. On every detail tasks, enter 2 days for Duration2, 3 days for Duration3.

    4.4 Set Duration2 and Duration3 to "show Average" value on the resume and group tasks. Set the Duration4 to "use formula".

    4.5. Create on Duration4 field a simple formula, like [Duration2]+[Duration3], or [Duration2]/[Duration3].

    4.6. See that the formula works fine the detail tasks (Duration4 = 5 days).

    4.7. Now the problem: The group tasks shows nothing. Duration4 should be calculated (average duration2: 2 days + avg duration3: 3 days = 5 days).

    4.8. Save the file and open on Project 2010. If the resume tasks on Duration4 continues to show nothing. Refresh the field by clicking right button on field and going to "Custom field" and pressing OK.

    See that Duration4 are calculated on Project 2010 correctly, but not on 2013 version. That is the problem

    Thanks again. I hope it helps.

    Tuesday, July 23, 2013 8:19 PM
  • Thanks for the very detailed information.  Here's what I see:

    Duration 2 and Duration 3 calculate correctly.

    Duration 4 does not - it remains blank.  However, if I switch Duration4 to one of the summary calculations (Sum, Average) it works.

    I initially thought it may have been too many calculated fields in the view, but I was able to disprove that by doing other calculations in additional fields.  However, all of the other calculations were only using one other additional calculated field. 

    I do see that it works in Project 2010.  I'm not sure what got changed.  I'll share your last post with some other folks internally and see if they have any ideas.

    Tuesday, July 23, 2013 9:08 PM
  • I have also encountered this problem before with MS-Project 2007.

    I have project files in 2000-2003 which do these group by calculations, but found that 2007 did not calculate them. Then I discovered that 2010 worked, so I bought a copy of 2013 and finally moved away from 2000 only to find that the problem is back again.

    So Microsoft may find the answer in what changed between 2003 and 2007 and 2010 and 2013.

    We really need this fixed.



    I recommend not buying MS-Project 2013. Stay with 2010 (or 2003). It seems I have to pay to tell Microsoft Technical Support that there is a problem with the product.

    I have just found another one. I have a formula date field that calculates LastSunday, then I have a filter that filters tasks to those which finish date is greater than this field. It works on the 2003 file I have opened and saved in 2013 format, until I go to edit the filter and it won't let me save the changes claiming the field is the wrong type for this comparison. MS-2013 is not good. Stay away from it!

    Tuesday, August 27, 2013 7:03 AM
  • Hi Julie,

    Any answer or workaround about this problem ?

    Have been migrating from 2010 to 2013 a few weeks ago and I get the same problem.

    It gives me problems for reporting purposes.

    A little bit amazing that something that worked fine in 2010 doesn't work any more in the next release...

    Thanks for feedback or solution.


    Wednesday, January 15, 2014 7:55 AM
  • Vincent,

    Do you have any cumulative updates installed to Project 2013?  Can you please explain specifically what you are seeing?  I have several CUs installed to my installation of Project 2013 and I can test to see if they are fixed in my installation.

    Wednesday, January 15, 2014 3:27 PM
  • Julie,

    Please test again my example above with your CUs and give us a feedback.

    Thursday, April 17, 2014 7:03 PM
  • I'm going to suggest that you get Service Pack 1 installed to project 2013 and test again. 

    The other option is to email me the file and I'll see if I can reproduce the issue with SP-1 installed.

    Thursday, April 17, 2014 10:18 PM
  • Julie, I have Project 2013 32-bit Service Pack 1 and able to reproduce the same behavior for task and group summary rows, "Use Formula" doesn't work but this works in Project 2010.

    Screenshot of Project 2013 where Duration1 and Duration2 task and group summary task is based on rollup, and Duration3 is use Formula

    Sai PMP, PMI-SP, MCTS Project, MVP Project

    Thursday, April 17, 2014 10:57 PM
  • Julie,

    I have just installed the SP1 and the available CUs and, as Sai demonstrates, the issue remains.

    Thursday, April 24, 2014 7:39 PM
  • Yes, that picture explains the same issue I have with trying to make a custom text formula.  This is an old thread but the problem still isn't fixed, long after SP1!
    Friday, March 11, 2016 5:25 PM
  • Picture would be here but the site will not let me...stupid.

    This thread is old, so maybe you all have figured it out, but I found a setting on Custom Fields selection for formula that applies the calculation to the summary task. The section is labeled "calculation for task and group summary rows". Select "Use Formula" and it applies to summary rows. 

    • Proposed as answer by Giz_MS Friday, March 11, 2016 5:43 PM
    Friday, March 11, 2016 5:43 PM
  • This still does not fix the issue.  I just discovered this thread while trying to figure out why this works in 2010 but not in 2013 with SP1.  I checked the formula and the summary and group flag is turned on.  So I'm not sure how this worked for you.
    Saturday, February 25, 2017 2:02 PM
  • Project 2013 has been updated numerous times since SP-1.  Please make sure you have all updates applied:

    Test again and let us know.

    Sunday, February 26, 2017 5:40 PM