ERROR_INTERNET_SEC_CERT_REVOKED with Remote web access RRS feed

  • Question

  • I have a Windows Server 2012 Essentials home server. I could use the server from outside my local home network through Remote Web Access ( Also om my tablet and laptop I could connect to the server using the standard VPN function of Windows Server 2012 Essentials remote access. I have checked the servers remote access configuration but no problems are reported so it seems to be working normal.

    Since a couple of weeks however I get ERROR_INTERNET_SEC_CERT_REVOKED when connecting to remote web access (https). Also I can no longer use the VPN.

    Does anyone have any idea why this certificate seems to be revoked?

    Wednesday, August 8, 2018 9:32 AM

All replies

  • hi,
     on client side
    1.Open Internet Explorer.
    2.In the Tools menu select Internet Options.
    3.Pick the Advanced tab and then scroll down to the Security section.
    4.Then turn off or uncheck Check for server certificate revocation.
    5.Click OK at the bottom of the window.
    If  the problem is still exist , you can do setting on server side.
    1 you can click “repair “ in anywhere access setting panel.
    2 Verify if client and server clocks are synchronized
    3 Verify if certificate is expiration. You can find it in iis manager ---server certificates
    4 If certificate is expiration or problem, you need to import the new certificate getting form vendor.

    Andy YOU
    Please remember to
    mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact
    Thursday, August 9, 2018 10:33 AM
  • This has been an issue for years, GoDaddy randomly revokes the certificates for the domain

    I would just run the repair of Anywhere Access to have it issue a new certificate.

    Robert Pearman @titlerequired Windows Server

    Thursday, August 9, 2018 10:50 AM
  • Is there anything to help  you?
    Tuesday, August 14, 2018 7:40 AM
  • A repair did not work. I had to completely remove the website and recreate it again. Now I can connect using Edge. The VPN still doesn't work. I will dig into that later this week.

    Tuesday, August 14, 2018 12:37 PM
  • Thanks for your feedback.
    You can refer this document to try to fix your problem.

    Wednesday, August 15, 2018 6:52 AM
  • If the site is publicly accessible, please check the certificate served by your web server via SSL Checker.

    Compare the certificate serial number and expiration date with the data of the certificate you installed in your web server or hosting control panel. In many cases, I saw that the server uses an old or invalid certificate.


    If you are sure that the correct certificate is served, clear the CRL and OCSP cache:

    certutil -urlcache CRL delete
    certutil -urlcache OCSP delete 

    You can also try disabling certificate revocation in browsers. It fixes ERROR_INTERNET_SEC_CERT_REVOKED on the client side

    Saturday, February 9, 2019 11:00 PM
  • It worked , thanks alot for sharing the support.
    Sunday, September 29, 2019 12:55 PM