none
BACKUP failed to complete the command BACKUP DATABASE. Check the backup application log for detailed messages. RRS feed

  • Question

  • Hi,

    We have a back up that is failing.

    The error is "BACKUP failed to complete the command BACKUP DATABASE RPS. Check the backup application log for detailed messages.".

    As I understand it the backup application log is at C:\Program Files\Microsoft SQL Server\MSSQL.2\MSSQL\LOG. From that all I get is

    2014-03-05 14:49:29.41 Backup      Error: 3041, Severity: 16, State: 1.
    2014-03-05 14:49:29.41 Backup      BACKUP failed to complete the command BACKUP DATABASE myDb. Check the backup application log for detailed messages.

    The command I am using is

    BACKUP DATABASE [MyDb]
    TO  DISK = N'D:\Domains\SQL_Backup\DB\myDb\Mydb_FullBackup_20140305_1100.bak'
    WITH NOFORMAT, NOINIT,  NAME = N'mydb-Full Database Backup', SKIP, NOREWIND, NOUNLOAD,  STATS = 10
    GO

    The database is Microsoft SQL Server Standard Edition (64-bit) Version 9.00.1399.06.

    The computer is Windows server 2003 R2 Standard Edition SP2

    The Db is 191 Gb and there is 227 Gb available on the D drive where it's being backed up to.

    Any thoughts as to how I can track down the problem.

    Is the 227Gb of spare disk space big enough to back up a 191 Gb database?

    If not how much is needed?

    Thanks

    Wednesday, March 5, 2014 3:30 PM

Answers

  • You are on an unsupported service pack level for SQL 2005.  9.00.1399.06 is the RTM version!

    I have no idea if it will fix your problem, but you really need to upgrade to SP 4. http://www.microsoft.com/en-us/download/details.aspx?id=7218

    David


    David http://blogs.msdn.com/b/dbrowne/

    Wednesday, March 5, 2014 3:40 PM
    Moderator
  • Hello,

    Can you apply latest service pack .I dont know but guess that can be issue.Once faced ,not quite sure.Also can you just make your command like

    BACKUP DATABASE [MyDb] 
    TO  DISK = 'D:\Domains\SQL_Backup\DB\myDb\Mydb_FullBackup_20140305_1100.bak' 
    WITH NOFORMAT, NOINIT,  STATS = 10
    GO
    Just a simple one .Is backup failing immediately or after some time .Error is not so helpful as it does not shows any information

    Please mark this reply as the answer or vote as helpful, as appropriate, to make it useful for other readers



    Wednesday, March 5, 2014 3:44 PM
    Moderator
  • Thanks all for the advice.

    I think I have found the issue.

    I believe it is to do with settings which terminate the process after a fixed period.

    Thursday, March 6, 2014 2:32 PM

All replies

  • You are on an unsupported service pack level for SQL 2005.  9.00.1399.06 is the RTM version!

    I have no idea if it will fix your problem, but you really need to upgrade to SP 4. http://www.microsoft.com/en-us/download/details.aspx?id=7218

    David


    David http://blogs.msdn.com/b/dbrowne/

    Wednesday, March 5, 2014 3:40 PM
    Moderator
  • Hello,

    Can you apply latest service pack .I dont know but guess that can be issue.Once faced ,not quite sure.Also can you just make your command like

    BACKUP DATABASE [MyDb] 
    TO  DISK = 'D:\Domains\SQL_Backup\DB\myDb\Mydb_FullBackup_20140305_1100.bak' 
    WITH NOFORMAT, NOINIT,  STATS = 10
    GO
    Just a simple one .Is backup failing immediately or after some time .Error is not so helpful as it does not shows any information

    Please mark this reply as the answer or vote as helpful, as appropriate, to make it useful for other readers



    Wednesday, March 5, 2014 3:44 PM
    Moderator
  • All the error say is that the backup failed. SQL Server doesn't know why. You need to check for errors at a lower level (OS) if you can find the actual reason. Oh, and try to get to a higher build level, of course.

    Tibor Karaszi, SQL Server MVP | web | blog

    Wednesday, March 5, 2014 3:53 PM
    Moderator
  • Thanks all for the advice.

    I think I have found the issue.

    I believe it is to do with settings which terminate the process after a fixed period.

    Thursday, March 6, 2014 2:32 PM
  • Hi Kevin,

    I have encountered the same issue, could you please tell me the settings that needs to be altered. 

    Regards,

    Prathap M Eranna

    Wednesday, September 18, 2019 3:04 PM