none
Submit button grayed out in Project server 2013 WorkFlow RRS feed

  • Question

  • We published the Workflow in project server'13 through SharePoint desginer 2013 and we used the Microsoft sample workflow. after saving the project information Submit button is in disable mode. So can any body clarify this issue ?

    we tried  the re provisioned the PWA through the above article but still submit button is in grayed out mode.

    Please clarify me where i am wrong?

    Thanks in advance.

    Monday, April 28, 2014 8:08 AM

Answers

  • Dear Sir,

    we figured out the solution, it's the "user profile synchronization issue".

    Running a full sync fixed it.

    Now my WF submit button is working.

    Thanks and regards,

    Venkat.

    Wednesday, April 30, 2014 8:36 AM

All replies

  • Hi

    Please do an IISRESET and check the behaviour

    Monday, April 28, 2014 2:32 PM
  • What is the workflow status webpart showing, is there any error that you see, does it happens when you first create project ? or in between stages i.e. after progressing to a certain stage

    Most likely it happens when your workflow is broken and errors out at any point or there is no further submit required in the workflow(which i doubt to be the case)

    Would also suggest to check the workflow additional data >> link appears on right bottom corner on workflow status page

    Workflow error and button greyed out something like this

     

    Thanks | Sunil Kr Singh | http://epmxperts.wordpress.com



    Monday, April 28, 2014 6:34 PM
    Moderator
  • we already tried reset also but the error is still the same.


    Tuesday, April 29, 2014 7:47 AM
  • Hi sir,

    We are facing only submit button (disable mode) issue.

    We are running Microsoft sample WF, it has taken the project info we saved and went to next page to submit the details but Submit button is in disable mode.

    can you give some solutions to solve this?

    We tried IISRESET and we reprovisioned but submti button is the same.

    Thanks,

    Venkat.


    Tuesday, April 29, 2014 8:04 AM
  • Hi,

    In the past I had some similar problems and found that the Workflow Service was not running correctly. Or gace the appearance of running. Re-installing / Re-registering eventually resolved the problem.

    Good Luck

    Mark

    Tuesday, April 29, 2014 9:30 AM
  • Dear sir,

    we tried both re installing and re-registering but submit button is still the same.

    So please show me any solution ?

    Thanks,

    Venkat.

    Tuesday, April 29, 2014 10:20 AM
  • Hi,
    1. Open your site in SharePoint Designer
    2. Expand the "Workflows" folder, and the folder containing the workflow you want to fix
    3. Right-click on the file that ends in "xoml.wfconfig.xml"
    4. Choose Open With -> SharePoint Designer (Open as XML)”
    5. Look for the “RulesVersion” attribute
    6. Change its value to “V1.0”
    7. Save the xml file

    If you modify the workflow again, you’ll have to change the “RulesVersion” attribute again before saving as an STP as changing the workflow increments this attribute value which has to be reset to "V1.0".

    Source: http://suguk.org/forums/thread/3942.aspx

    Hope this will help you.

     


    Jalal Blali MCTS, MCITP

    Tuesday, April 29, 2014 6:17 PM
  • Dear Sir,

    we figured out the solution, it's the "user profile synchronization issue".

    Running a full sync fixed it.

    Now my WF submit button is working.

    Thanks and regards,

    Venkat.

    Wednesday, April 30, 2014 8:36 AM
  • Can you please explain all steps here. I am also struggling with same issues.
    Monday, June 3, 2019 9:32 AM