none
WSUS E-Mail Notifications SMTP Relay Office 365? RRS feed

All replies

  • Hi,
      

    Thank you for posting here.
    I may need to do some research on your questions, so this may take some time. I will respond promptly if there is any progress, and you can wait patiently for advice from other experts.
      

    Regards,
    Yic

    Please remember to mark as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, September 10, 2019 3:33 AM
  • Hi,
      

    Combine the articles you provided, as well as my actual tests, when I configure through the following steps, the test mail will be sent normally. Please refer to the comparison of what you have done:
       

    1. First add the STMP server function on the WSUS server, the steps are the same as mentioned in the article.
        
    2. To adjust the virtual SMTP server properties, start with "Access". The fifth step in the screenshot is the IP address of this server.


          
    3. Then adjust "Delivery" - "Outbound Security". The third step in the screenshot is the email address used to send the WSUS report email.
         

          
    4. Then adjust "Delivery" - "Outbound Comnections". The second step in the screenshot is the port number of the SMTP server.
         

          
    5. Then adjust "Delivery" - "Advanced". The second step in the screenshot is the address of the SMTP server.
         

         
    6. Restart the SMTP service.
         

         
    7. In the "Email Notifications" of the WSUS console, please fill in the "General" section as required. The "E-Mail Server" is shown below. The address filled in the first step is the WSUS server IP and port filled in the second part above. The second step is to fill in the email information used to send the email.
         

         
      After the configuration is completed through the above steps, the test email can be sent normally.
        

    Please check your operation and test if this applies to your environment.
    Reply back with the results would be happy to help.
       

    Regards,
    Yic

    Please remember to mark as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Proposed as answer by AJTek.caMVP Wednesday, September 11, 2019 12:58 AM
    Tuesday, September 10, 2019 9:23 AM
  • Hi,
      

    Combine the articles you provided, as well as my actual tests, when I configure through the following steps, the test mail will be sent normally. Please refer to the comparison of what you have done:
       

    1. First add the STMP server function on the WSUS server, the steps are the same as mentioned in the article.
        
    2. To adjust the virtual SMTP server properties, start with "Access". The fifth step in the screenshot is the IP address of this server.


          
    3. Then adjust "Delivery" - "Outbound Security". The third step in the screenshot is the email address used to send the WSUS report email.
         

          
    4. Then adjust "Delivery" - "Outbound Comnections". The second step in the screenshot is the port number of the SMTP server.
         

          
    5. Then adjust "Delivery" - "Advanced". The second step in the screenshot is the address of the SMTP server.
         

         
    6. Restart the SMTP service.
         

         
    7. In the "Email Notifications" of the WSUS console, please fill in the "General" section as required. The "E-Mail Server" is shown below. The address filled in the first step is the WSUS server IP and port filled in the second part above. The second step is to fill in the email information used to send the email.
         

         
      After the configuration is completed through the above steps, the test email can be sent normally.
        

    Please check your operation and test if this applies to your environment.
    Reply back with the results would be happy to help.
       

    Regards,
    Yic

    Please remember to mark as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Yes, this did work, however I have a separate server that has the SMTP role installed on it. In your description you had both roles installed on the same server (WSUS & SMTP). Anyways, same concept I just had to point to the SMTP server from WSUS. 

    Thanks you soooo much dude!

    Tuesday, September 10, 2019 12:34 PM
  • Hi,
      

    If the SMTP and WSUS servers are not on the same server, in my environment, I do the following:
      

    1. Go back to the properties of the virtual SMTP server.
      In "General", delete (All Unassigned) in "IP Address" and add the IP address and port number of this machine.
         

         
    2. In "Access" - "Relay", add the loop IP 127.0.0.1 and the IP of the other WSUS server.
         

         
    3. Other options are like what was in the previous reply.
        

    Again, this works in my environment, please refer to whether this applies to your environment.
    Hope the above can help you.
       

    Regards,
    Yic

    Please remember to mark as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, September 11, 2019 2:54 AM
  • Hi,
     

    Any update is welcome here.
    If the issue is resolved, share your solution or find the helpful response "Mark as Answer" to help other community members find the answer.
     

    Thank you for your cooperation, as always.
     

    Regards,
    Yic

    Please remember to mark as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, September 18, 2019 2:24 AM