none
hyper-v e placa de rede RRS feed

  • Pergunta

  • Ola pessoal ... é o chato de novo ... bem ...  to c um servidor com  windows 2008 e instalei o hyper-v ... depois de instalado criei uma maquina virtual com o 2003 ... e ai vem a pergunta ... a placa de rede nao rolou ... no 2008 aparece (alem das duas placas fisicas) mais uma ... so que la no 2003 da maquina virtual nao aparece placa nenhuma ... o que eu to fazendo de errado ??? andei lendo que nao da pra fazer isso com placa de rede broadcom ... ???
    sexta-feira, 31 de julho de 2009 02:40

Respostas

  • Bom dia Cristiano,

    O que vc tem que fazer é configurar as redes virtuais no Hyper-V. Cria no mínino três redes virtuais, uma conectada a placa de rede física, uma Interna e outra Privada. Depois nas configurações da VM vc deve informar a qual rede virtual ela será conectada.

    Mas tem um detalhe importante para que a placa de rede funcione nas VMs, vc terá que instalar o Integration Services do Hyper-V que pode ser encontrado no menu Ação e depois em "Inserir Disco de instalação dos serviços de Integração". Após a instalação do Integration Services basta reiniciar a VM para a placa de rede funcione.

    Abraços e boa sorte.
    Att, Daniel Schaeffer
    • Marcado como Resposta Cri$TiaN0 sexta-feira, 31 de julho de 2009 15:59
    sexta-feira, 31 de julho de 2009 11:22

Todas as Respostas

  • Bom dia Cristiano,

    O que vc tem que fazer é configurar as redes virtuais no Hyper-V. Cria no mínino três redes virtuais, uma conectada a placa de rede física, uma Interna e outra Privada. Depois nas configurações da VM vc deve informar a qual rede virtual ela será conectada.

    Mas tem um detalhe importante para que a placa de rede funcione nas VMs, vc terá que instalar o Integration Services do Hyper-V que pode ser encontrado no menu Ação e depois em "Inserir Disco de instalação dos serviços de Integração". Após a instalação do Integration Services basta reiniciar a VM para a placa de rede funcione.

    Abraços e boa sorte.
    Att, Daniel Schaeffer
    • Marcado como Resposta Cri$TiaN0 sexta-feira, 31 de julho de 2009 15:59
    sexta-feira, 31 de julho de 2009 11:22
  • Olá amigo.

    Cristiano o procedimento passado pelo Daniel está corretissimo, só gostaria de colocar um adendo.
    Provavelmente você dever te lido em uma resposta minha que a placa de rede Broadcomm não funciona no Hyper-V!!!  Errado funciona sim e muito bem, a unica orientação é a atualização do Driver para melhor desempenho e adquadação.
    Veja em outra resposta aonde menseionei abaixo e claro dando um explicação correta.
    http://social.technet.microsoft.com/Forums/pt-BR/hypervpt/thread/05aba0c4-7b45-480c-bd5b-41d4e8a0fa0d

    Abraços amigo.
    IT-Pro Levi Bertolino ( Virtualization ) Blog- http://studytech.spaces.live.com Mail|MSN – suporte.studytech@live.com
    sexta-feira, 31 de julho de 2009 15:48
  • Fala Daniel ... tudo bem ?

    Bom ... mais uma vez gostaria de agradecer a todos (em especial vc) pela ajuda ... consegui resolver e ja estou implementando o que eu queria ...

    Valeu mesmo ...

    Abracos

    sexta-feira, 31 de julho de 2009 16:00
  • Opa Cristiano,

    Que bom que funcionou! Não deixe de perguntar caso tenha novas dúvidas. Abraço e sucesso.
    Att, Daniel Schaeffer
    segunda-feira, 3 de agosto de 2009 20:22
  • Ae daniel,
    Cara realmente esse processo qual vc citou lá em cima funciona em VM Microsoft, e em linux tem outro esquema?
    Pq quando clico em "Inserir Disco de instalação dos serviços de Integração" o linucão não consegue instalar pq os arquivos são tudo .exe


    O sábio nunca diz tudo o que pensa, mas pensa sempre tudo o que diz.
    quarta-feira, 2 de setembro de 2009 14:36
  • Opa Maik,

    Para Linux vc terá que usar o Linux Integration Components. Basicamente existem duas versões, uma para Hyper-V RC1 e outra para o Hyper-V RC2. Os links para download são esses:

    http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=c299d675-bb9f-41cf-b5eb-74d0595ccc5c
    http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=ab7f4983-93c5-4a70-8c79-0642f0d59ec2

    Lembrando que atualmente a unica distribuição Linux suportada "oficialmente" é o Suse conforme o KB http://support.microsoft.com/default.aspx/kb/954958/en-us . Se não me engano o Red Het em breve será suportado e tem relatos que outras distribuições foram instaladas com sucesso e o IC funcionou normalmente.

    Estes dois links também tem informação a respeito que serão úteis:

    http://technet.microsoft.com/en-us/library/cc742460.aspx
    http://www.virtualizationteam.com/microsoft/hyper-v/install-suse-linux-enterprise-10-sp1-component-integration-for-linux-on-hyper-v.html
    Att, Daniel Schaeffer
    quarta-feira, 2 de setembro de 2009 14:58
  • Ae daniel mando bem novamente!!!
    Pena que não consegui resolver o meu problema com um server ubuntu !!!
    Tentei segui os passos do link que vc me passou mas o ubuntu ainda não é suportado =x
    Pena ....
    vlw
    O sábio nunca diz tudo o que pensa, mas pensa sempre tudo o que diz.
    quarta-feira, 2 de setembro de 2009 18:33
  • Opa,

    Blz, pelo que sei algumas distribuições Linux mesmo sem ser suportadas oficialmente funcionam no Hyper-V. O problema é que sem o Linux Integration Components o desempenho não fica bom. Mas no teu caso não reconheceu nem a placa de rede?

    Att, Daniel Schaeffer
    quarta-feira, 2 de setembro de 2009 18:52
  • Olá Amigos, não queria criar outro tópico, estou aproveitando esse para tirar uma dúvida com vocês:

    Estou com o Hyper-V no 2008, só que as maquinas virtuais não encherdam a placa de rede, e está configurada corretamente conforme essa documentação:

    To allow Hyper-V to use a VLAN
    1. Open Hyper-V Manager.

    2. From the Actions menu, click Virtual Network Manager .

    3. Select the virtual network you want to edit, and, in the right pane, check to select Enable virtual LAN identification .

    4. Enter a number for the VLAN ID. All traffic for the management operating system that goes through the network adapter will be tagged with the VLAN ID you set.

    To allow a virtual machine to use a VLAN
    1. Open Hyper-V Manager.

    2. In the results pane, under Virtual Machines , select the virtual machine that you want to configure to use a VLAN.

    3. In the Action pane, under the virtual machine name, click Settings .

    4. Under Hardware , select the virtual network adapter connected to the external virtual network.

    5. In the right pane, select Enable virtual LAN identification , and then enter the VLAN ID you plan to use.

    Chequei tbm esses links

    http://www.virtualizationadmin.com/articles-tutorials/microsoft-hyper-v-articles/networking/introduction-vlan.html

    http://blogs.msdn.com/adamfazio/default.aspx

    Abraços!!
    segunda-feira, 19 de outubro de 2009 13:48
  • Olá amigo.

    Você já configurou a placa de rede? no Hyper-V manager?

    Qual o modelo da sua placa amigo, se for broadcom verifique as atualizações mais recentes dessa placa.
    Veja nesse artigo amigo, aonde explico o como funciona a rede virtual no Hyper-V
    Levi Bertolino. Virtualization blog: http://studytech.spaces.live.com
    segunda-feira, 19 de outubro de 2009 15:52
  • Olá amigo, eu vi seu post, com as informações abaixo:

    Acho que não fui muito exclarecedor, ou não sobe me expressar adquadamente.
    Bom o que eu quiz dizer foi que em alguns casos, as placas broadcomm ( No início do Hyper-V ) não funcionavam adquadamente, e o problema era resolvido após atualizar o Driver mais recente da placa de rede ( O que é normal, quando se trata de desenvolvimento ).
    Para explicar melhor vou listar abaixo alguns casos que foram apresentado aqui mesmo no forum.

    http://social.technet.microsoft.com/Forums/en-US/winserverhyperv/thread/2cdd5476-0bdd-456d-b0db-25dec4eadada

    http://social.technet.microsoft.com/Forums/pt-BR/hypervpt/thread/6b9f7ba4-14d4-4f18-a59f-d18b38ae334a

    http://social.technet.microsoft.com/Forums/pt-BR/hypervpt/thread/dda600a8-853f-470c-a567-e8c9296b49f4

    http://social.technet.microsoft.com/forums/pt-BR/winsrv2008pt/thread/c978fa68-b73c-4eb1-8567-9f5bed01399f/

    http://social.technet.microsoft.com/Forums/pt-BR/winserverhyperv/thread/edbdd447-40a5-4fe3-a14b-b285304b8022

    Sorry, eu não quiz dizer que não funciona, o que eu quiz dizer é que algumas precissa atualizar o driver para funcionar adquadamente.
    Abraços amigos.

    A placa está na ultima atualização :(
    segunda-feira, 19 de outubro de 2009 15:59
  • Olá amigo.

    Bom recomendo que instale uma nova placa de rede e utilize-a para as VMs, caso não seja possível uma instalação de uma nova placa, me passa o modelo da sua placa de rede para eu verificar a compatibilidade com o hyper-V.

    Uma outra possível solução de reconhecimento após a instalação do driver mais atual da sua placa, seria remover e reinstalar a role de Hyper-V, se opitar por esse faça backup das suas vms.

    Abraços.
    Levi Bertolino. Virtualization blog: http://studytech.spaces.live.com
    segunda-feira, 19 de outubro de 2009 16:31
  • Olá Amigo,

    Pois é, consegui na Dell agora o ultimo update da placa, é uma broadcom BCM 5716c,  só que em funcionou subindo como Legacy Network Adapter e não como network adapter

    Obrigado mais uma vez pela ajuda.
    segunda-feira, 19 de outubro de 2009 16:57
  • Olá amigão.

    é cara Broadcom tem um sério problema com isso, apesar de eu não entender o proque já que os desenvolvedores deles trabalham em conjunto com a Microsoft para desenvolver a melhor placa.

    De qualquer forma tenta verifica se no Windows UPDATE não dispoe de nenhuma atualização.

    Abraços.
    Levi Bertolino. Virtualization blog: http://studytech.spaces.live.com
    segunda-feira, 19 de outubro de 2009 17:41