none
[PSAPI.DLL] Ajuda RRS feed

  • Pergunta

  • Quando tento executar alguns programas (exemplo msn).
    Aparece esse erro

    "Não foi possivel localizar o ponto de entrada do procedimento GetProcessImageFilaNameW na biblioteca de vínculo dinâmico PSAPI.DLL.

    Se prefirir tirei uma Screen   http://img522.imageshack.us/img522/897/semttulo2hl1.gif

    Como fasso para resolvelo ?


    Obrigado.
    quinta-feira, 5 de julho de 2007 22:04

Todas as Respostas

  • Fala Willian tudo blz?

     

    Uma pergunta... Você fez instalação ou atualização do internet Explorer?

    Pois essa Dll, se não me engano, tem referências agregrada ao internet explorer

    Me responde os ultimos procedimentos que tu fez, para podermos ajuda-lo

    Abraço fico no Aguardo

    quinta-feira, 5 de julho de 2007 23:01
  • Relacionado ao internet explorer nada.
    Mais instalei varias coisas antis de ver esse problema
    Como o modem da minha banda larga que chego hoje, Anti-Virus... entre outros.
    quinta-feira, 5 de julho de 2007 23:12
  •  William s2ss2 wrote:
    Relacionado ao internet explorer nada.
    Mais instalei varias coisas antis de ver esse problema
    Como o modem da minha banda larga que chego hoje, Anti-Virus... entre outros.


    William,

    Verificou a thread abaixo?

    http://forums.microsoft.com/Technet-BR/ShowPost.aspx?PostID=1206049&SiteID=29
    sexta-feira, 6 de julho de 2007 00:09
  • Sim ja fiz os procedimentos citados ali...
    Os que achei era so nu system32 mesmo..
    Ainda persiste o problema....
    E eu seleciono pra aparecer arquivos ocultos. etc
    E nada.
    sexta-feira, 6 de julho de 2007 00:20
  •  William s2ss2 wrote:
    Sim ja fiz os procedimentos citados ali...
    Os que achei era so nu system32 mesmo..
    Ainda persiste o problema....
    E eu seleciono pra aparecer arquivos ocultos. etc
    E nada.


    Veja este BLOG!

    http://www.hanselman.com/blog/TheProcedureEntryPointGetProcessImageFileNameWCouldNotBeLocatedInTheDynamicLinkLibraryPSAPIDLLAfterIE7.aspx
    sexta-feira, 6 de julho de 2007 01:05
  • Fala Willian tudo bem?

     

    Eu tive um problema parecido com o seu, após ter instalado o Internet Explorer 7 e o Windows Media Player 11

    Faça o seguinte:

     

    ''Use a pesquisa do Windows XP (F3) e procure pelo o arquivo "psapi.dll",

    sem as aspas, em seguida, renomeie o mesmo para "psapiold.dll" exceto o que se encontra no diretorio C:\WINDOWS\System32

     

    Espero ter ajudado

    Fico no Aguardo

    Se útil, Marque como resposta

    Abraço Fera

    segunda-feira, 9 de julho de 2007 14:43
  • Eu já fiz isso e não consigo abrir o Nero, aparece uma msg dizendo:

    Fatal error: installation corrupted! please reinstall NERO
    quarta-feira, 29 de agosto de 2007 17:18
  • Olá Diego tudo bem?:

     

    Faça o seguinte, abra o prompt de comando, e digita sfc /scannow (talvez será solicitado o cd do windows) atualize as dlls e vê se resolve,

     

    Espero ter ajudado

    Abraço

     

    quinta-feira, 30 de agosto de 2007 01:37
  • domingo, 1 de junho de 2008 07:25
  •  

    Olá,

     

    Uma observação:

     

    Tudo o que foi postado até agora pelos outros colaboradores do fórum, muito embora, de teor bastante técnico e com muita propriedade, eu, por outro lado, quando pego esses casos, eu nivelo o problema por baixo, ou seja, vou do mais simples ao mais complexo...

    Exatamente pelo desconhecimento do problema procuro sempre deixar o windows o mais próximo possível do seu estado original de instalação (instalação limpa).

    Removo todos os programas, aplicativos, games, drivers,etc...(que estão em adicionar e remover programas).

    Abro o windows explorer e vou removendo qualquer pasta ou arquivo que não seja do Windows.

    Vou reiniciando a máquina à medida que a limpeza for sendo feita.

    Agora sim, vou utilizando vários programas, utilitários, dicas técnicas, e tudo mais...
    À medida que eu vou realizando todos estes procedimentos, vou verificando se o problema persiste, e, na maioria dos casos, o problema (mensagens de erros diversas) é resolvido.
    À partir daí então, eu vou instalando o programas e drivers aos poucos, e vou testando o sistema a cada nova instalação.
    Posso dizer que na maioria dos casos (desde que não seja problemas relacionados ao kernel do sistema) este procedimento é bem sucedido. pode demorar algumas horas ou o dia inteiro...

    Tudo isto é feito sem precisar fazer backup, reinstalação, ficar horas na inernet procurando soluções, etc.

    E, como último recurso, e apesar de tudo que feito, o problema ainda persistir, neste caso faço uma instalação paralela, utilizando uma pasta \windows_temp (por exemplo).

    Gostaria de dizer mais, mas o tempo não permite.

     

    Espero ter colaborado com a minha sugestão.

     

    Boa sorte.

    domingo, 1 de junho de 2008 22:07