none
Script de logon para mapear unidade RRS feed

  • Pergunta

  • Galera Bom Dia,

    Gostaria de saber como crio um script para mapear uma unidade de rede que está fora do domínio.

    Pois estou com alguns problemas estranhos aqui na empresa, do nada os mapeamentos somem das máquinas dos usuários e tenho alguns aplicativos na rede que todo dia tenho que ficar mapeando as unidades.

    Enfim queria deixar essa tarefa automática, alguém poderia me auxiliar?

    Obrigado.

    terça-feira, 14 de junho de 2011 12:54

Respostas

Todas as Respostas

  • Olá!

    Possui uma forma sim, porém a senha de rede ficará exposta.

    Em batch file(*.bat)

    NET USE J: \\seuservidor\pasta /USER:dominio\usuario senha

    Ex: NET USE J: \\CONTOSO\PUBLICA /USER:CONTOSO\USER S3NH@123

    ou

    NET USE J: \\CONTOSO\PUBLICA /USER:USER@CONTOSO S3NH@123

    Teste e poste os resultados!


    " Qm tem boca vai a roma, meu fogão tem 6 e não saiu da cozinha ainda"
    • Marcado como Resposta Richard Juhasz sexta-feira, 17 de junho de 2011 19:29
    terça-feira, 14 de junho de 2011 14:46
  • Marcellus,

    Obrigado funcionou perfeitamente, já aproveitando sua boa vontade se fosse em um domínio como eu faria?

    Só tive um probleminha no Windows 7 não funcionou.

    Abraços.

    terça-feira, 14 de junho de 2011 17:59
  • É realmente no windows 7 não funcionou msm não
    sexta-feira, 7 de fevereiro de 2014 11:46
  • OLA, GOSTARIA DE SABER COMO SERIA ENTAO EM UMA REDE LOCAL POIS TIVE QUE RETIRAR O EXPLORER E FUNCIONANDO SOMENTE O PROGRAMA DA LOJA, SO QUE VEM O PROBLEMA QUE QUANDO COLOCO O SCRIPT PARA RODAR O PROGRAMA ELE DA ERRO POR CONTA DO LOGIN QUE SE FAZ NO SERVIDOR DEMORA UM POUCO ATE FAZELO, ESTOU PESANDO EM FAZER ESTE SCRIPT PARA RODAR ANTES DO BAT DO PROGRAMA FAZENDO FUNCIONAR POIS ESTOU TENDO QUE RODAR MANUALMENTE ATRAVEZ DO EXECUTAR POIS O EXPLORER ESTOU DEIXANDO BLOQUEADO PARA OS USUARIOS NAO ALTERAREM NADA NO SISTEMA "XP"
    sexta-feira, 25 de abril de 2014 13:38
  • Boa noite.

    Se for local, assim eu uso aqui na empresa vc coloca da seguinte forma

    ".\nome_do_usuário_local" sem as aspas!

    Veja como ficou o meu, funciona perfeitamente;

    @ECHO OFF

    @NET USE k: \\IPdoServidor\PASTA_Compartilhada**/USER:local\Nome_de_usuário**suasenha

    OBs: Onde tiver os asteriscos, vc coloca espaço!




    • Editado Hubuntu sábado, 30 de maio de 2015 00:06
    sábado, 30 de maio de 2015 00:04
  • Aqui no Windows 7 da empresa funciono de boas.

    Se fosse em dominio, voce nao precisaria criar script só se voce quizesse, em dominio existe uma GPO pra mapeamento, porem pode ser feito por script tambem, adicionando na parte de inicializar.

    Abraço

    quinta-feira, 15 de outubro de 2015 15:36
  • Marcellus e Spook, bom dia,

    Como citou o Vinicius Lopez, o ideal é que não se use mais scripts para mapeamentos de pastas e impressoras, ambos os compartilhamentos hoje são possíveis via GPO através dos recursos de "Preferences".

    Abraços!

    FABIANO GUIMARÃES DE MELLO

    Microsoft Certified IT Professional

    terça-feira, 20 de outubro de 2015 12:31
  • Boa tarde

    E quando os mapeamentos desaparecem aleatoriamente?

    Estou com um problema usando GPO onde os mapeamentos hora aparecem e hora não. Quando não aparecem eu abro o explorer e a unidade mapeada está lá porém com um X sobre ela, clica-se nela ela solicita senha de acesso ao compartilhamento. Mesmo colocando no GPO o usuário e senha pro compartilhamento, nem sempre funciona.

    sábado, 22 de outubro de 2016 18:01
  • Boa tarde

    E quando os mapeamentos desaparecem aleatoriamente?

    Estou com um problema usando GPO onde os mapeamentos hora aparecem e hora não. Quando não aparecem eu abro o explorer e a unidade mapeada está lá porém com um X sobre ela, clica-se nela ela solicita senha de acesso ao compartilhamento. Mesmo colocando no GPO o usuário e senha pro compartilhamento, nem sempre funciona.

    Estou com o mesmo problema.

    No meu caso o mapeamento das pastas é de um servidor de dados em linux SAMBA.

    No primeiro login deu certo, porém nos próximos ficou com um X e quando você tenta acessar pede as credenciais. 

    Será que ta faltando alguma configuração?
    domingo, 8 de janeiro de 2017 15:26
  • Quem tem boca vaia Roma, isso mesmo (vaia) do verbo vaiar

    segunda-feira, 30 de janeiro de 2017 12:39
  • Olá, como faço um delay no mapeamento, pois acontece que o script que fiz roda o mapeamento antes mesmo do windows reconhecer a rede quando inicio a máquina. E no caso precisava que o script rodasse depois de reconhecer a rede ou como já vi, criar um delay no script.
    quarta-feira, 14 de março de 2018 17:20
  • Ocorre o mesmo problema comigo. Conseguiu resolver?
    segunda-feira, 15 de outubro de 2018 13:54
  • Marcellus,

    Obrigado funcionou perfeitamente, já aproveitando sua boa vontade se fosse em um domínio como eu faria?

    Só tive um probleminha no Windows 7 não funcionou.

    Abraços.

    BOA TARDE, UTILIZO ASSIM NO WINDOWS 7

    NET USE J: \\CONTOSO\UNIDADE SENHA /USER:NOMEUSUARIO

    FAÇO ISSO QUANDO PRECISO ACESSAR UNIDADE RESTRITA PRA ALGUNS USUARIOS NO SERVIDOR.


    quarta-feira, 17 de outubro de 2018 17:12
  • Olá, como faço um delay no mapeamento, pois acontece que o script que fiz roda o mapeamento antes mesmo do windows reconhecer a rede quando inicio a máquina. E no caso precisava que o script rodasse depois de reconhecer a rede ou como já vi, criar um delay no script.

    Boa tarde, utilizo o comando abaixo pra dar um delay no meus script bat peguei em um forum e funciona bem.

    ping -n 2 -w 1000 0.0.0.1 > nul

    só alterar o numero 2 que é o tempo que ele espera antes de executar o próximo script.

    quarta-feira, 17 de outubro de 2018 17:14