locked
Erro ao realizar migração da base de dados do SQL Server 2008 express para 2008 enteprise RRS feed

  • Pergunta


  • Baixei uma licença do Sql Server 2008 enteprise, para realizar um upgrade de SGBD em um cliente que já atingiu 10Gb de banco de dados, mas estou tento problemas para atanchar ao banco do cliente, resumindo, o SQL responde dizendo:

    O banco de dados 'xxx' não pode ser aberto proque sua versão é a 661. Este servidor suporta a versão 665 e anteriores. (erro: 948).

    Como resolver isso? Preciso de uma versão do SQL que possa me atender.

    segunda-feira, 15 de julho de 2013 20:27

Todas as Respostas

  • Felipe,

    Verifique novamente a edição de seus servidores. Acredito que você tinha um SQL Server Express 2008 R2 e sua versão nova é SQL Server 2008. Sendo assim a express uma geração a frente, se for o caso você não conseguirá realizar o attach, pois seria uma operação de downgrade. Você teria que realizar um export/import para uma base do 2008.

    select @@VERSION

    Abs.

    segunda-feira, 15 de julho de 2013 20:44
  • Preciso de uma versão do SQL 2008 que suporte esse banco, você poderia sugerir alguma?
    segunda-feira, 15 de julho de 2013 21:18
  • Crie os os objetos (todos) por script ou use o DTSx (Import/Export) entre as instancias para migrar os objetos.

    segunda-feira, 15 de julho de 2013 21:23
  • Você precisará da licença/instancia de um SQL Server 2008 R2.
    terça-feira, 16 de julho de 2013 12:13