none
Excel - Consulta com retorno de dados RRS feed

  • Pergunta

  • Amigos, boa tarde

    Gostaria de saber, como é possível buscar um registro numa coluna e caso o mesmo exista, retornar o valor de sua célula a frente. Ex:

    PLANILHA 1

    Nome Cor
    João Azul
    Maria Vermelho
    Pedro Verde
    Joaquim Marrom
    Luiza Roxo
    José Amarelo

    PLANILHA DOIS

    Nome Cor que mais gosta
    Artur  
    João  
    Joaquim  
    José  
    Luiza  
    Marcio  
    Maria
    Pedro
    Vanessa

    Ou seja, precisamos consultar se existe o nome Artur na planilha 1, e caso exista, retorne a cor correspondente a ele.

    A principio, pensei na formula SE, porém não consegui dar prosseguimento na hora do resultado "se verdadeiro".

    Alguém poderia me ajudar por favor?

    .

    sexta-feira, 25 de julho de 2014 18:37

Respostas

  • Olá! Para fazer este tipo de busca o mais comum é utilizar a função PROCV.

    Supondo que os dados estão começando na célula A1 de cada planilha, a fórmula na célula B2 da planilha dois ficaria:

    =SEERRO(PROCV(A2;'planilha Um'!A:B;2;FALSO);"Nome não localizado")

    Outra alternativa seria usar a função ÍNDICE junto com CORRESP, mas no seu caso o PROCV já resolve bem, e o SEERRO é só para trazer um valor caso não localize o nome. Qualquer dúvida pergunte.


    Rafael Kamimura


    • Editado Rafael Kamimura segunda-feira, 28 de julho de 2014 16:28
    • Sugerido como Resposta Rafael Kamimura segunda-feira, 28 de julho de 2014 16:28
    • Marcado como Resposta Cometti quinta-feira, 13 de novembro de 2014 12:18
    segunda-feira, 28 de julho de 2014 01:08

Todas as Respostas

  • Alguém?
    sábado, 26 de julho de 2014 20:38
  • Olá! Para fazer este tipo de busca o mais comum é utilizar a função PROCV.

    Supondo que os dados estão começando na célula A1 de cada planilha, a fórmula na célula B2 da planilha dois ficaria:

    =SEERRO(PROCV(A2;'planilha Um'!A:B;2;FALSO);"Nome não localizado")

    Outra alternativa seria usar a função ÍNDICE junto com CORRESP, mas no seu caso o PROCV já resolve bem, e o SEERRO é só para trazer um valor caso não localize o nome. Qualquer dúvida pergunte.


    Rafael Kamimura


    • Editado Rafael Kamimura segunda-feira, 28 de julho de 2014 16:28
    • Sugerido como Resposta Rafael Kamimura segunda-feira, 28 de julho de 2014 16:28
    • Marcado como Resposta Cometti quinta-feira, 13 de novembro de 2014 12:18
    segunda-feira, 28 de julho de 2014 01:08