none
Alertas por e-mail com dados errados RRS feed

  • Pergunta

  • Caros,

     

    É com muito gosto que vejo uma comunidade (muito activa) do SharePoint em lingua Portuguesa!

     

    Sou um recente analista/programador em SharePoint, mas tenho uma dúvida que me parece pertinente.

     

    Passo a relatar o sucedido:

    Criei uma SiteColumn num website principal do tipo Lookup, procurando numa lista desse mesmo website.

    De seguida, criei uma lista num sub-site (do website principal) com a SiteColumn criada anteriormente - isto permite-me usar listas do website principal para preencher campos de listas criadas em sub-sites.

    Criei um alerta nesta lista do sub-site para ser notificado cada vez que exista alguma alteração.

     

    Problema:

    O alerta que recebo por e-mail mostra-me as alterações efectuadas, mas nos campos do tipo lookup mostra-me alterações que eu nunca fiz!

     

    Obrigado desde já pela ajuda...

     

    Cumprimentos.

    Sérgio Alves Silva

    sexta-feira, 18 de julho de 2008 09:45

Todas as Respostas

  • Olá Sérgio,

    Tudo bem?

    Cara, não entendi muito bem seu caso, como assim mostra informações que você nunca fez... O e-mail apresenta o campo com informações que não existem? Ou não aparece nada no campo?

    Abraços.

    Wagner M. Amorim

    --

    SharePoint Professional

    MCTS: .NET  | WSS 3.0 | MOSS 2007

    MCPD: Web Developer

    Microsoft Profissional 5 Estrelas

    MSF & SCRUM Practitioner

    --

    wa.amorim@hotmail.com

    http://waamorim.spaces.live.com/

    sexta-feira, 18 de julho de 2008 13:08
  • Simplesmente aparecem alterações que eu não fiz.

     

    Vou explicar melhor... imagina este cenário:

     

    Website principal com:

    Lista: Clientes - Campos: Codigo Cliente, Nome Cliente

    Site Column: NomeCliente (pesquisa neste site, na lista de clientes pelo nome do cliente)

     

    No sub-site tenho:

    Lista: Encomendas - Campos: Nº Encomenda, Estado, NomeCliente (SiteColumn do site principal)

     

    Imagina que altero o estado da encomenda de Pendente para Processado. Recebo um e-mail com a seguinte informação:

     

    Cliente: AAA(riscado), BBB(riscado), AAA

    (como se tivesse alterado do AAA para o BBB e de seguida novamente para o AAA)

    Estado: Pendente(riscado), Processado

    (correcto: já que tinha alterado o estado de pendente para processado)

     

    Penso que seja um bug da Microsoft...

     

    Obrigado pela ajuda!

     

    Abraço,

    Sérgio Alves Silva

    sexta-feira, 18 de julho de 2008 13:19