locked
Aparentemente, Erros de consulta LDAP. RRS feed

  • Pergunta

  • Olá Pessoal,

    Tenho o seguinte cenário: tenho uma organização Exchange 2003, com diversos sites. Em um dos sites, tenho um Exchange 2003 em cluster. No site onde está este servidor, existem 2 DCs, ambos GC.

    Nas propriedades do servidor, em Directory Access, verifico que ele encontrou corretamente os domain controllers.

    Bom, o erro que estou tendo é que tenho um grupo "Todos" com todas as pessoas da empresa e alguns contatos externos. Esse grupo deve ter mais ou menos uns 6 mil usuários. (Grupo de Distribuição Universal (???))

    Um usuário tentou enviar um e-mail para o grupo e percebeu que o e-mail não foi enviado. Ao utilizar o Message Tracking, verifiquei que os últimos status são: SMTP: Message Scheduled to Retry Categorization. Por conta disso, a mensagem fica na fila dentro de Messages Awating Directory Lookup.

    Ao verificar o Event Viewer, verifiquei alguns erros, como por exemplo:

    - Type: Error
    - EventID: 6003
    - Source: MSExchangeTransport
    - Descriptinon: SMTP was unable to connect to an LDAP server.

    - Type: Error
    - EventID: 2114
    - Source: MSExchangeDSAccess
    - Descriptinon: Process INETINFO.EXE (PID=1480). Topology Discovery failed, error 0x80040952.

    - Type: Warning
    - EventID: 6021
    - Source: MSExchangeTransport
    - Descriptinon: The LDAP host server.dominio.xxx:3268 has been marked down.

    - Type: Warning
    - EventID: 6004
    - Source: MSExchangeTransport
    - Descriptinon: The categorizer is unable to categorize messages due to a retryable error.

    Já estou com o Diagnostic Loggin habilitado no máximo em Topology e Categorizer.

    Sei que são erros que não necessariamente tem relação entre eles, mas neste caso, achei importante colocar aqui.

    Já verifiquei aqui no Forum inclusive, algumas informações sobre permissões herdadas no servidor, alterar o Domain Controller e etc. Já tentei tudo isso... mas até agora nada... já faz mais de 24h que a msg está parada aguardando o Categorizer...

    Alguém já passou por isso?
    Abraços!


    Vinícius Ramos Apolinário | http://blogadmderedes.spaces.live.com
    quinta-feira, 30 de setembro de 2010 16:06

Respostas

  • Mas isso é muito relativo,

    se ele tá em outro site, no mesmo domínio ele usa o DC local que á preferência dele.

    Pode não ser muito grande pro servidor de lá, mas pode ser que o servidor que está dando problema não esteja suportando o expand de tantos itens.


    JATOBA - MCSA-M Exchange 2003 / MCTS Network Infrastructure 2008 / MCTS Microsoft Exchange Server 2010
    quinta-feira, 30 de setembro de 2010 18:04
    Moderador

Todas as Respostas

  • Vinicius,

    esse erro pode ser por conta do grande número de recipientes na lista, o tempo para expandir todos os recipientes deve ser enorme, uma boa prática seria vc tem dentro do grupo TODOS, não todos os usuários, mas subgrupos por departamento, OU, ou qualquer outro identificador, assim o expansion vai ser menor.


    JATOBA - MCSA-M Exchange 2003 / MCTS Network Infrastructure 2008 / MCTS Microsoft Exchange Server 2010
    quinta-feira, 30 de setembro de 2010 17:16
    Moderador
  • Olá Filipe,

    Estou estudando a possibilidade, mas não sou eu quem gerencia o AD. Imaginei que o tempo seria realmente grande para categorizar, mas se um usuário de outro servidor Exchange (outro site, inclusive) envia e-mails para o mesmo grupo, o tempo não é tão grande.

    Além disso, o erro EventID 6004 (The categorizer is unable to categorize messages due to a retryable error.) informa que realmente há um erro...

    De qualquer forma, Valeu!


    Vinícius Ramos Apolinário | http://blogadmderedes.spaces.live.com
    quinta-feira, 30 de setembro de 2010 17:32
  • Mas isso é muito relativo,

    se ele tá em outro site, no mesmo domínio ele usa o DC local que á preferência dele.

    Pode não ser muito grande pro servidor de lá, mas pode ser que o servidor que está dando problema não esteja suportando o expand de tantos itens.


    JATOBA - MCSA-M Exchange 2003 / MCTS Network Infrastructure 2008 / MCTS Microsoft Exchange Server 2010
    quinta-feira, 30 de setembro de 2010 18:04
    Moderador
  • Olá Filipe,

    A mailbox que faz envio de e-mails para este grupo não é de usuário... É uma mailbox compartilhada. Portanto não há problemas em movê-la para outro servidor em outro site. Ao movê-la para outro site, percebi que os e-mails enviados para o grupo chegam na hora...

    No Cluster, para tentar resolver os outros problemas, reiniciei o nó passivo, movi o recurso para este nó que reiniciou e reiniciei o outro nó. Aparentemente resolveu o problema pois tinham diversas outras mensagens na fila que agora sairam...

    De qualquer forma, muito obrigado pela ajuda!
    Abraços!


    Vinícius Ramos Apolinário | http://blogadmderedes.spaces.live.com
    sexta-feira, 1 de outubro de 2010 12:26