locked
Warning WMI pós Instalação do SP3 RRS feed

  • Pergunta

  •  

    Pessoal,

     

    Instalei o SP3 no SMS 2003 e começou de 5 em 5 minutos no Event Viewer a aparecer as mensagens abaixo:

     

    Warning 1

    A provider, PolicyAgentInstanceProvider, has been registered in the WMI namespace,
    root\ccm\Policy\Machine, to use the LocalSystem account.  This account is privileged
    and the provider may cause a security violation if it does not correctly impersonate user requests.

     

    Warning 2

    A provider, PolicyAgentInstanceProvider, has been registered in the WMI namespace,
    root\ccm\Policy\Machine, to use the LocalSystem account.  This account is privileged and the provider
    may cause a security violation if it does not correctly impersonate user requests.

     

    Warning 3

    A provider, PolicyAgentInstanceProvider, has been registered in the WMI namespace, root\ccm\Policy\S_1_5_21_1097491160_730207712_1318725885_110987, to use the LocalSystem account. 
    This account is privileged and the provider may cause a security violation if it does not correctly impersonate user requests.

     

    Alguém ja viu isso?

    Pode ser um problema?

     

     

    Ambiente

    Site Central + Site Primário ambos com SMS 2003 SP3 e Windows Standard 2003 SP1 EN

     

    Obrigado

    quarta-feira, 8 de agosto de 2007 12:51

Respostas

  • Rodrigo, você terá de anunciar para todas as estações que estiverem com o cliente atualizado para a nova versão e não apenas para o servidor. O pacote já é criado com a instalação do Hotfix, você só precisará criar o Advertisement e a Collection para distribuir, você pode utilizar esta query para montar sua Collection:

    select SMS_R_System.ResourceID,SMS_R_System.ResourceType,SMS_R_System.Name,SMS_R_System.SMSUniqueIdentifier,SMS_R_System.ResourceDomainORWorkgroup,SMS_R_System.Client from SMS_R_System where ClientVersion = "2.50.4253.3000"


    Algo muito bem lembrado pelo João é que os clientes não são automaticamente atualizados para o SP3 portanto você deve utilizar o
    Client Push Installation Wizard para esta tarefa.

    Existe um WebCast em Inglês falando sobre a atualização para o SP3, vale à pena conferir:

    http://msevents.microsoft.com/CUI/WebCastEventDetails.aspx?EventID=1032341248&EventCategory=5&culture=en-US&CountryCode=US


    Até mais
    quinta-feira, 9 de agosto de 2007 00:42
  • Pessoal,

     

    Novidades no meu caso !!!

    Descobri que o meu seridor estava com problemas no Management Point, por isso estava derrubando o Serviço do Cliente no Server outra característica também é que não estava conseguindo atualizar os clientes.

     

    Solução

    Após verificar o WMI do server que estava legal.

    Encontrei problemas com o meu Windows Installer

     

    Executei os seguintes passos para a resolução no servidor com problema:

     

    1) Desinstalei o Management Point

     

    2) Executei os comandos no prompt do dos:

    msiexec /unreg

    msiexec /reg

     

    3) Instalei novamente o Management Point

     

     

    Este problema estava gerando Warnings relacionados a MSI (winmgmt) nos clientes que ja tinham sido migrados.

     

     

    quinta-feira, 9 de agosto de 2007 18:41

Todas as Respostas

  • Olá João, pode ficar tranquilo, na verdade este alerta signifca que novas caracterísitcas foram inseridas no WMI para que o Inventoy Hardware e Invetory Software mais poderosos possa trazer as informações dos novos Reports  do SMS .

    http://www.microsoft.com/technet/sms/2003/downloads/servicepacks/sp3.mspx

     

    Agora o que pode ocorrer e que ocorreu comigo é um problema de lentidão nas máquinas por conta do serviço WMIPRVSE.EXE que ocupa 100% de CPU, caso não tenha feito ainda, instale o Hotfix abaixo listado e crie um advertisement para executar em todas as máquinas COM o Cliente atualizado(OBS: é preciso criar a Collection para cliente Version)

     

    http://support.microsoft.com/kb/937882/en-us

     

    Essa query pode ser usada:

     

    select SMS_R_System.ResourceID,SMS_R_System.ResourceType,SMS_R_System.Name,SMS_R_System.SMSUniqueIdentifier,SMS_R_System.ResourceDomainORWorkgroup,SMS_R_System.Client from SMS_R_System where ClientVersion = "2.50.4253.3000"

     

     

    Siga também os passos deste outro link que desabilita no SMS_DEF.MOF o AutoStart Software.

     

    [ dynamic, provider("AAInstProv"),

    SMS_Report     (FALSE),

    SMS_Group_Name ("AutoStart Software"),

    SMS_Namespace  (TRUE),

    SMS_Class_ID   ("MICROSOFT|AUTOSTART_SOFTWARE|1.0") ]

    class SMS_AutoStartSoftware : SMS_Class_Template

     
    http://mssmsfaq.spaces.live.com/Blog/cns!ED21429C2C20B1B2!204.entry
     
    Faça isso o mais urgente possível pois isso pode impactar muito no seu ambiente.
     
    Grande abraço.
     
     

     

    quarta-feira, 8 de agosto de 2007 14:04
  • Cara,

    Obrigado pelas informações estarei executando e dando o resultado.

     

    Agora uma dúvida conceitual. Se eu inclui novas entradas no repositório do WMI do servidor e das estações com o cliente novo não entendo a necessidade de uma divulgação ou coisa parecida no servidor!?

     

    Outra coisa que é importante lembrar é que diferente das outras versões o cliente NÃO é atualizado automaticamente.

    http://www.microsoft.com/technet/prodtechnol/sms/sms2003/upgradecheck/61facc2f-b0ac-4f73-95be-e3cf776023bf.mspx?mfr=true

     

    Obrigado

     

    quarta-feira, 8 de agosto de 2007 17:20
  • Wemali.

     

     

    Gostaria de confirmar uma informação.

     

     

    O hotfix eu preciso instalar realmente em todas as estações ou somente no servidor?

     

     

    Obrigado.

     

    quarta-feira, 8 de agosto de 2007 19:47
  • Rodrigo, você terá de anunciar para todas as estações que estiverem com o cliente atualizado para a nova versão e não apenas para o servidor. O pacote já é criado com a instalação do Hotfix, você só precisará criar o Advertisement e a Collection para distribuir, você pode utilizar esta query para montar sua Collection:

    select SMS_R_System.ResourceID,SMS_R_System.ResourceType,SMS_R_System.Name,SMS_R_System.SMSUniqueIdentifier,SMS_R_System.ResourceDomainORWorkgroup,SMS_R_System.Client from SMS_R_System where ClientVersion = "2.50.4253.3000"


    Algo muito bem lembrado pelo João é que os clientes não são automaticamente atualizados para o SP3 portanto você deve utilizar o
    Client Push Installation Wizard para esta tarefa.

    Existe um WebCast em Inglês falando sobre a atualização para o SP3, vale à pena conferir:

    http://msevents.microsoft.com/CUI/WebCastEventDetails.aspx?EventID=1032341248&EventCategory=5&culture=en-US&CountryCode=US


    Até mais
    quinta-feira, 9 de agosto de 2007 00:42
  •  

    Wemali.

     

    Muito obrigado por sua resposta.

     

    Agora então descobri um erro que aconteceu comigo apos eu instalar o SP3.

     

    Todas as minhas Collections estavam zeradas, somente apos eu instalar novamente o client do SMS que resolveu o problema.

     

    Já estou colocando em meu ambiente de testes a distribuição do HotFix.

     

    Obrigado por essa ajuda.

     

    Abraços.

    quinta-feira, 9 de agosto de 2007 13:52
  • Pessoal,

     

    Novidades no meu caso !!!

    Descobri que o meu seridor estava com problemas no Management Point, por isso estava derrubando o Serviço do Cliente no Server outra característica também é que não estava conseguindo atualizar os clientes.

     

    Solução

    Após verificar o WMI do server que estava legal.

    Encontrei problemas com o meu Windows Installer

     

    Executei os seguintes passos para a resolução no servidor com problema:

     

    1) Desinstalei o Management Point

     

    2) Executei os comandos no prompt do dos:

    msiexec /unreg

    msiexec /reg

     

    3) Instalei novamente o Management Point

     

     

    Este problema estava gerando Warnings relacionados a MSI (winmgmt) nos clientes que ja tinham sido migrados.

     

     

    quinta-feira, 9 de agosto de 2007 18:41
  • Senhores.

     

     

    tem como eu criar uma collection para saber as maquinas que ainda não tem o patch instalado?

     

    Tentei de diversas formas e não consegui.

     

     

    Obrigado.

     

    sexta-feira, 10 de agosto de 2007 17:51
  • Tem que procurar no Adicionar e remover programas ex:

    v_GS_ADD_REMOVE_PROGRAMS.Displayname0 not like '%937882%

     

    quinta-feira, 17 de janeiro de 2008 18:56