locked
RDS Configuração RRS feed

  • Pergunta

  • Boa tarde.

    Estou em um ambiente com AD instalado e gerenciando o ambiente corretamente. Estou com dificuldades para fazer acesso remoto externamente.

    No momento consigo fazer a conexão externa apenas com o usuário administrator os demais não acessa, ao tentar a parece a tela de logon ela começa carregar e na hora H ela é desconectada.

    Verifiquei também que os usuários estão conseguindo abrir apenas uma sessão, anteriormente quando usávamos o winsrv2008R2 nos conseguíamos abrir mais de uma seção simultânea.

    Quando inicio a maquina aparece um balãozinho falando que o remote desktop services deve ser configurado em ate X dias (no meu caso 99) ou ira parar de funcionar.

    Todas as maquinas são windows server 2012 standard. agradeço quem possa me dar uma luz ou me encaminhar algum artigo a respeito pois achei varias coisas na internet porem a grande maioria se trata de usuários locais e não domínio do AD

    So a titulo de informação, na rede interna esta tudo funcionando, todos os usuarios estao fazendo seus acessos remotos ao serviços corretamente.


    terça-feira, 11 de outubro de 2016 17:23

Respostas

  • Resolvi incluindo o grupo "domain users" no grupo local "direct access" da maquina.

    ATT

    • Marcado como Resposta ThiagoSilvaCDN sexta-feira, 4 de novembro de 2016 13:46
    sexta-feira, 4 de novembro de 2016 13:46

Todas as Respostas

  • Ninguem para poder ajudar ?
    quinta-feira, 13 de outubro de 2016 20:16
  • Boa Tarde 

    Você efetuou a instalação das licenças de usuário do terminal server (Call) para acesso remoto, pois enquanto não fizer esse procedimento o acesso remoto ficará limitado para apenas 2 usuários 

    Pesquise no blog da TechNet o assunto; RD Licensing Configuration on Windows Server 2012

    Neste artigo tem o procedimento para efetuar esta configuração


    Abraços

    Aguardo sua resposta




    Rodrigo Correia
    MCP + MCSA
    quinta-feira, 13 de outubro de 2016 20:58
  • Acho que não veio o link Rodrigo !

    Obrigado por enquanto.

    sexta-feira, 14 de outubro de 2016 16:07
  • Olá segue o link com o conteúdo que falei,

    https://blogs.technet.microsoft.com/askperf/2013/09/20/rd-licensing-configuration-on-windows-server-2012/

    Até logo 

     
    segunda-feira, 17 de outubro de 2016 11:25
  • Tenho mais uma duvida. No meu domínio temos mais de uma maquina que é acessada remotamente.

    Neste caso configurei a maquina para tal e configurei o RDS em outro servidor e configurei o RDS para domínio ... é necessária alguma configuração para que as licenças funcionem em todos os servidores que requerem o acesso remoto ou é automático ?

    Obs:. A minha falta de habilidade com o RDS acontece pois anteriormente nos utilizávamos o citrix fundamentals que possuíam junto com seu licenciamento as CAL de acesso portanto a configuração do RDS era dispensável, agora mudamos para o Citrix xendesktop e as licenças destes não acompanham as CAL de acesso.

    ATT


    terça-feira, 18 de outubro de 2016 12:05
  • Bom dia ThiagoSilvaCDN,

    Tudo bem?

    Sugiro que dê uma lida no Brief contido no link abaixo, você irá esclarecer todas as suas dúvidas!

    Licensing Windows Server 2012 R2 Remote Desktop Services and Microsoft desktop applications for use with RDS

    Abraço.


    Thales F Quintas

    Esse conteúdo é fornecido sem garantias de qualquer tipo, seja expressa ou implícita

    TechNet Community Support

    Por favor, lembre-se de Marcar como Resposta as postagens que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    terça-feira, 18 de outubro de 2016 13:33
  • Boa tarde ! Thiago

    Você conseguiu fazer a instalação das licenças no Servidor RDS?

    Não entendi muito bem seu cenário, você tem dois servidores com Windows Server 2012 R2 Standard ?

    Abraços

    Aguardo sua resposta

    terça-feira, 18 de outubro de 2016 19:31
  • Sim, eu consegui colocar as licenças e efetiva-las, porem so consigo o acesso remoto via internet com o usuario de admin, os usuarios do dominio nao estao conseguindo acesso.

    Partindo do principio de que o administrador consegue acesso remoto externo, posso dizer que nao tenho nada bloqueando, partindo para a área das permissões ja fiz o seguinte:

    Fui em "System > Advanced system settings > remote > e autorizei o acesso remoto e também adicionei os grupos de usuários que quero que acessem, como não deu certo fui la e coloquei usuário por usuário e ainda não consigo acesso.

    Inclui estes usuários como "remote desktop users" e nada tbm.

    O engraçado é que para o acesso interno não é necessário definir os usuários que vão acessar a maquina como citei acima.

    ATT



    quarta-feira, 19 de outubro de 2016 19:32
  • Boa tarde ThiagoSilvaCDN,

    Você configurou corretamente o ambiente?

    Veja no link abaixo um tutorial de instalação e configuração do RDS no Windows Server 2012:

    Installing and Configuring Remote Desktop Services (RDS) on Windows Server 2012

    Abraço.


    Thales F Quintas

    Esse conteúdo é fornecido sem garantias de qualquer tipo, seja expressa ou implícita

    TechNet Community Support

    Por favor, lembre-se de Marcar como Resposta as postagens que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    • Marcado como Resposta ThiagoSilvaCDN quinta-feira, 20 de outubro de 2016 15:28
    • Não Marcado como Resposta ThiagoSilvaCDN quinta-feira, 20 de outubro de 2016 15:29
    quarta-feira, 19 de outubro de 2016 19:46
  • Seguindo o tutorial eu travo na hora de configurar o CAP quando vou inserir o grupo de usuarios ele da um erro BEX vou tentar fixar ! ... e na hora de incluir o HOST na farm ele nao acha o server que e ele próprio ....


    mas ate então eu não sabia que tinha que instalar a role do gateway ... já e um avanço !

    quarta-feira, 19 de outubro de 2016 23:32
  • Bom dia ThiagoSilvaCDN,

    Qual é o erro apresentado?


    Thales F Quintas

    Esse conteúdo é fornecido sem garantias de qualquer tipo, seja expressa ou implícita

    TechNet Community Support

    Por favor, lembre-se de Marcar como Resposta as postagens que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    quinta-feira, 20 de outubro de 2016 12:26
  • quinta-feira, 20 de outubro de 2016 14:51
  • ThiagoSilvaCDN,

    Isso já está relacionado a um crash do Management Console, pra verificar o porque isso aconteceu, você pode utilizado o Debug Diag, criar uma regra e depois analisar os logs, segue link de download da ferramenta:

    Debug Diagnostic Tool v1.2

    Abraço.


    Thales F Quintas

    Esse conteúdo é fornecido sem garantias de qualquer tipo, seja expressa ou implícita

    TechNet Community Support

    Por favor, lembre-se de Marcar como Resposta as postagens que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    quinta-feira, 20 de outubro de 2016 15:29
  • Boa Tarde ! Thiago

    Verifiquei em seu AD se existe alguma restrição de logon para os usuários 

    Em propriedades do usuários , guia Account em seguida opção Log On To

    Selecionar a opção All Computers

    Rodrigo Silva

    • Sugerido como Resposta Thales F Quintas quinta-feira, 20 de outubro de 2016 19:01
    • Não Sugerido como Resposta Thales F Quintas quinta-feira, 20 de outubro de 2016 19:02
    quinta-feira, 20 de outubro de 2016 18:56
  • quinta-feira, 20 de outubro de 2016 19:02
  • Boa Tarde ! Thiago

    Verifiquei em seu AD se existe alguma restrição de logon para os usuários 

    Em propriedades do usuários , guia Account em seguida opção Log On To

    Selecionar a opção All Computers

    Rodrigo Silva

    desculpe, nao havia visto sua sugestao, obrigado.

    Porem ja esta assim a config.

    sexta-feira, 21 de outubro de 2016 01:41
  • Olá Thiago,

    O último print que você mandou é do erro do MMC correto?

    Poderia por favor verificar os logs do Event Viewer?

    Event Viewer path

    Para definir o que auditar/monitorar siga este procedimento :

    https://technet.microsoft.com/en-us/library/cc772215(v=ws.11).aspx

    Nesta página Mike Crowley disponibilizou um script PowerShell para criar um relatório em CSV para conexões do Remote Desktop:

    https://gallery.technet.microsoft.com/Remote-Desktop-Connection-3fe225cd

    Veja se com esses recursos consegue obter mais detalhes para seu problema.

    Obrigado.

    sábado, 22 de outubro de 2016 07:58
  • Bom dia ... eu executei o script e ele mostra apenas logins e logoffs dos meus usuarios ... nada demais ... o erro que estou tendo e para configurar o gateway ... o acesso dos meus usuarios na minha rede local funciona corretamente, somente o acesso externo e que so esta deixando meu usuario de ADMIN acessar ... o erro do MMC ocorre na hora de inserir os grupos de usuarios autorizados para acessar o gateway ... 

    Eu fiz os updates do windows que estavam disponiveis ... tentei ate mesmo desistalar a role e instalar novamente  ... mas percebi que ao desinstalar e instalar novamente a role ja fica com a configuração que eu fiz anteriormente ou seja se algum bug esta ocorrendo por conta da instalação ela nao e removida com a desinstalação ... ta dificil to pensando seriamente inclusive em mudar a versao do windows deste server pro R2 que temos uma licença ... mas o server ja ta todo configurado com os apps e bancos de dados dos programas da empresa.

    sábado, 22 de outubro de 2016 12:31
  • Olá Thiago,

     

    O problema no MMC está relacionado ao .NET 4.6x:

     

    Remova os KB' : KB 3102467, e o KB 3045563 se mesmo depois de remover o KB3102467 ainda não funcione.

    e/ou Instale o Update rollup abaixo, embora seja para Windows 2012 R2 deve corrigir o problema no seu MMC:

    Falha no console do Gerenciador de Gateway de área de trabalho remota com a atualização mais recente do.NET Framework 4.6.1 no Windows Server 2012 R2

    https://support.microsoft.com/pt-br/kb/3162871

     

    Outra alternativa, configure o RDS via powershell:

    https://blogs.technet.microsoft.com/manojnair/2011/12/02/rds-powershell-tfm-part-v-configuring-a-rd-gateway-using-powershell/

     

    Espero ter ajudado


    domingo, 23 de outubro de 2016 07:25
  • Bom dia. As atualizações não estão presentes no sistema. Já verifiquei. com relação ao powershell estou pesquisando de como operar pois no tutorial não é para leigos no assunto e para quem ja tem uma base.

    ATT

    terça-feira, 25 de outubro de 2016 12:19
  • ThiagoSilvaCDN,

    Isso já está relacionado a um crash do Management Console, pra verificar o porque isso aconteceu, você pode utilizado o Debug Diag, criar uma regra e depois analisar os logs, segue link de download da ferramenta:

    Debug Diagnostic Tool v1.2

    Abraço.


    Thales F Quintas

    Esse conteúdo é fornecido sem garantias de qualquer tipo, seja expressa ou implícita

    TechNet Community Support

    Por favor, lembre-se de Marcar como Resposta as postagens que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    Bom dia. Poderia me ajudar a fixar o erro a partir deste relatorio ?

    ATT

    quarta-feira, 26 de outubro de 2016 11:12
  • Olá Thiago,

    Você já entrou nesta máquina com um outro perfil administrador? Se não, crie um outro perfil administrador e logue. Verifique se o erro do MMC persiste.

    Aproveite e apague o perfil que está dando erro e ele será recriado.

    Mais dicas aqui:

    https://support.microsoft.com/pt-br/kb/156826

    Abraço,

    • Sugerido como Resposta Thales F Quintas sexta-feira, 28 de outubro de 2016 11:40
    sexta-feira, 28 de outubro de 2016 09:53
  • Olá Thiago,

    Você já entrou nesta máquina com um outro perfil administrador? Se não, crie um outro perfil administrador e logue. Verifique se o erro do MMC persiste.

    Aproveite e apague o perfil que está dando erro e ele será recriado.

    Mais dicas aqui:

    https://support.microsoft.com/pt-br/kb/156826

    Abraço,

    Nao deu certo ... mas vou verificar o artigo. obrigado.

    Edit: vi que é para criar e remover perfils ... nao tive sucesso usando outro perfil de usuario.

    ATT

    sexta-feira, 28 de outubro de 2016 15:41
  • Olá Thiago,

    Após criar o novo perfil administrador Tente remover / recriar o seu perfil principal.

    Se isso não der certo realmente só vejo opção para utilizar o powershell que recomendei antes para configurar ou fazer um in place na sua máquina (uma reinstalação sem remover os dados) antes de uma re-instalação completa.

    sábado, 29 de outubro de 2016 02:37
  • Ja fiz a tentativa com outro perfil de admin, não deu certo. com relação ao powershell não consegui seguir o artigo que mandaste anteriormente ... não consegui adentrar ao contêiner do RDgateway para executar os comandos que dizem no passo a passo ... poderia me enviar o comando para configurar o RD CAP para os domain users ?
    segunda-feira, 31 de outubro de 2016 11:01
  • Fiz uma coisa interessante para resolver o problema do MMC. instalei o RDgateway em outro servidor do domínio e através deste gerenciei o gateway da maquina principal.

    Porem voltei ao primeiro problema.

    continuo sem conseguir acesso com os usuários.

    RD Gateway esta instalado e configurado de acordo com o explicado acima.

    Remote desktop Licensing instalado 

    Licenças instaladas

    AD configurado para direcionar para o servidor de licença que defini (no caso vamos dar nome aos bois "XASRV")

    Usuários inseridos no grupo "remote desktop users"

    Configuração local do servidor permitindo o acesso dos usuários do grupo "Domain users" para acesso remoto

    não sei mais o que posso fazer !!!!

    Alguem mais quer tentar um palpite ?



    terça-feira, 1 de novembro de 2016 19:59
  • Resolvi incluindo o grupo "domain users" no grupo local "direct access" da maquina.

    ATT

    • Marcado como Resposta ThiagoSilvaCDN sexta-feira, 4 de novembro de 2016 13:46
    sexta-feira, 4 de novembro de 2016 13:46
  • Perfeito, obrigado pelo retorno.
    sábado, 5 de novembro de 2016 03:53