none
Migrar SharePoint 3.0 para SP 2010 Foundation RRS feed

  • Pergunta

  • Pessoal,

    Eu segui todos os passos e informações deixa no TechNet para migrar o Sharepoint 3.0 para Foundation. Porem no meu casso estou com o seguinte problema. Tive que fazer a atualização do SP2 do Sharepoint, no meio do processo ocorreu um erro de atualização da tecnologia do SharePoint. Procurando pela internet identifiquei que efetuar uma atualização forçada resolveria o problema. Bom fiz isto e realmente deu certo.

    Depois destes problemas por fim executei o pre-upgrade check que retornou a seguinte informação que segue abaixo.

    

    Como podem ver apenas a parte do sistema operacional não passou, mas isto não é problema pois meu objetivo é anexar o banco de dados de conteúdo no novo Farm. Mediante a está situação eu fiz um backup do SQL 2005 atual, restaurei no SQL 2012 onde está o novo FARM. Tudo bem até aqui.

    O problema agora é que não consigo anexar este banco de dados no novo Farm. Ele fica dizendo que a versão do banco de dados é inferior a exigência minima, veja abaixo. O que me intigra é que o pre-upgrade diz que está ok mas dentro do banco a versão não foi atualizada. Como eu posso resolver pois não consigo anexar o banco no novo Farm.

    Fico no aguardo.

    Abraço.


    Dux GP - Soluções em TI Londrina-PR

    sexta-feira, 28 de dezembro de 2012 04:56

Respostas

  • Olá Fernando!

    Curiosamente a thread que você citou é a mesma que eu havia comentado anteriormente ;p

    Nela são propostas várias soluções, no entanto alterações nas bases do SharePoint passam longe de qualquer best practice.

    Me recordo de uma documentação do SharePoint 2007 que menciona sobre a perda de garantia/ suporte técnico no caso de modificações diretas no banco de dados. Afinal isso poderia ser afetado com aplicações de patches, updates, entre outros.

    Em casos como estes é altamente recomendando utilizar Powershell ou Stsadm, pois desta forma a própria plataforma irá gerenciar todas as tarefas necessárias (como alterações no banco, arquivos, registro, e qualquer outra).

    Isso não necessariamente significa que irá encontrar algum problema, no entanto é bom pelo menos deixar registrada essa alteração ;p

    Fazendo uma rápida pesquisa, verifiquei que este ID pode ser de um dos 40 Templates de site para SharePoint:

    http://social.technet.microsoft.com/Forums/ta/sharepointadminprevious/thread/89fd7f08-cb06-416e-bba1-366f7ce3e718

    http://technet.microsoft.com/en-us/sharepoint/bb407286.aspx

    Se realmente for um desses IDs dos 40 site templates, o que pode acontecer é que os sites criados à partir deles poderão deixar de funcionar, e os templates não estarão disponíveis para criação de novos sites.

    Para confirmar realmente o ID das features, utilize a ferramenta "WssAnalyzeFeatures" que citei no post anterior :)

    Quando puder, nos informe se tudo isso deu certo ;p

    []'s


    Tarcísio Gambin | MCP, MCT, MCTS, MCITP, ITILv3
    www.tarcisiogambin.net


    terça-feira, 8 de janeiro de 2013 01:32

Todas as Respostas

  • Olá Fernando,

    Certifique-se que o sistema operacional utilizado nos Front-Ends e Applications servers do SharePoint seja o Windows Server 2008 x64.

    Maiores detalhes sobre requisitos mínimos no seguinte link:

    http://technet.microsoft.com/en-us/library/cc262485(v=office.14).aspx#section4

    []'s


    Tarcísio Gambin | MCP, MCT, MCTS, MCITP, ITILv3
    www.tarcisiogambin.net

    sexta-feira, 28 de dezembro de 2012 10:47
  • Tarcisio,

    Com relação aos requisitos eu creio que esteja tudo ok. Pois já tenho o novo FARM instalado com windows 2008 R2 + SQL 2012 e o SP 2010 Foundation rodando tudo normal. O que eu não estou conseguindo fazer e anexar o banco de dados de conteudo da versão 3.0 do sharepoint após os procedimentos de upgrade no meu farm novo. Pois toda vez que tento fazer isto usando o comando Mount-SP.... para subir o banco no FARM da erro dizendo que versão do banco está com a build 12.0.04518 e precisaria no minimo a versão 12.0.0.6421 ou superior. Creio eu que está atualização deveria ocorrer quando eu fiz o upgrade do SP2 do SharePoint 3.0 + stsadm.exe -o preupgradecheck.

    Estou correto?

    Ou tem mais coisa para fazer? Como atualizar o banco de conteudo para versão minima exigida para subir no meu novo Farm.

    Como corrigir este problema de versão do banco de dados de Conteudo?

    Abraço.


    Dux GP - Soluções em TI Londrina-PR

    sexta-feira, 28 de dezembro de 2012 11:51
  • Fernando,

    Será que a instalação do SP2 foi bem sucedida mesmo?

    Que erro você teve na hora da atualização?

    Como você fez essa atualização forçada?


    Atenciosamente, Rafael Fausto

    sexta-feira, 28 de dezembro de 2012 12:27
  • Rafael,

    Isto eu não sei.

    Eu poderia tentar rodar SP2 novamente?

    Quando eu inicie o SP2 no passo 8 de 9 deu erro que não conseguia reiniciar o serviço de Pesquisa do SharePoint e que era para fazer isto após a conclusão. Analisando os logs do Update eu consegui identificar que o update não atualizou todos os banco de dados do sharepoint tanto é que o site de conteudo parou de funcionar e somente fiquei com acesso no site administrativo do sharepoint. Correndo para resolver o problema eu utilizei o comando que força a atualização por linha de comando como passa o paramentro upgrade b2b force e etc... não me lembro ao certo mas peguei NO SITE DA MICROSOFT. Depois de rodar o comando ele executou 4 etapas de atualizações da tecnologia do sharepoit. quando finalizou o meu site voltou a funcionar. como o site voltou a funcionar eu rodei o upgrade check novamente e como os erros não apareceram mais eu fiz o procedimento conforme já coloquei e estou tentando adicionar o banco de conteudo no novo farm sem sucesso.

    " O erro que iniciou foi que ao apresentar problema no sp2 a versão do schema ficou diferente da versão corrente e pedia para voltar a correta, mas não achei como executar isto e partir para a opção de reatualizar forçando com comando que eu encontrei."

    O ESTRANHO É QUE SE O PREUPGRADE-CHECK PASSOU teoricamente o versão do bando não teria que estar atualizada?

    Espero que tenha ajudado com os dados.

    Estou com o processo parada.

    Abraço.

    ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

    segue erro na aplicação do SP2 no primeiro processo.

    Falhou : This server machine in the farm does not have Windows Server 2008 or higher 64 bit edition installed. 
    Upgrading to Windows SharePoint Services 4.0 requires Windows Server 2008 or higher 64 bit edition.
    Please upgrade the server machines in your farm to Windows Server 2008 64 bit edition, or create a new farm and attach the content from this farm. For more information about this rule, see KB article 954770 in the rule article list at http://go.microsoft.com/fwlink/?LinkID=120257.


    Falhou : Banco de dados de conteúdo com esquemas de banco de dados modificados 
    Modificações do usuário no banco de dados de conteúdo do SharePoint, incluindo, mas não se limitando a esquemas de tabelas, índices, procedimentos armazenados, não têm suporte e podem causar falhas na atualização de futuras versões do SharePoint.Os bancos de dados da lista a seguir parecem ter sido modificados a partir do esquema original:
    Data Source=srvinfra;Initial Catalog=WSS_Content;Integrated Security=True;Enlist=False;Connect Timeout=15

    Reverta o esquema do banco de dados modificado para o estado original. Se necessário, entre em contato com o fornecedor do software que pode ter feito essa alteração, pois essa reversão pode ter causado a perda de dados. Para obter mais informações sobre essa regra, consulte o artigo 954772 da Base de Dados de Conhecimento na lista de artigos de regra em http://go.microsoft.com/fwlink/?LinkID=120257.


    Falhou : Pending upgrade operation detected in this farm 
    Pending upgrade is detected on this farm. Either upgrade has not been run, or has failed after a recent update of the SharePoint software.
    Run the SharePoint Products and Technologies Configuration Wizard to finish the pending upgrade. For more information about this rule, see KB article 954775 in the rule article list at http://go.microsoft.com/fwlink/?LinkID=120257.

    ERRO DO LOG UPDATE DO SP2

    [SPManager] [INFO] [27/12/2012 17:32:11]: Inplace Upgrade session finishes. root object = SPFarm Name=SharePoint_Config, recursive = True. 3 errors and 0 warnings encountered.
    [SPManager] [DEBUG] [27/12/2012 17:32:11]: Removing exclusive upgrade regkey by setting the mode to none
    [SPManager] [DEBUG] [27/12/2012 17:32:13]: SyncUpgradeTimerJob: Upgrade timer job failed. Return -1.
    [SPManager] [DEBUG] [27/12/2012 18:31:57]: Logging enabled quinta-feira, 27 de dezembro de 2012 at 1

    [SPManager] [ERROR] [27/12/2012 17:32:11]: Upgrade [SPSearchDatabase Name=WSS_Search_SRVEPM Parent=SPDatabaseServiceInstance] failed.
    [SPManager] [ERROR] [27/12/2012 17:32:11]: Não foi possível iniciar o serviço devido a uma falha de logon
    [SPManager] [ERROR] [27/12/2012 17:32:11]: Cannot start service SPSearch on computer '.'.
    [SPManager] [ERROR] [27/12/2012 17:32:11]:

    [SPManager] [ERROR] [27/12/2012 17:32:11]: ReflexiveUpgrade [SPSearchDatabase Name=WSS_Search_SRVEPM Parent=SPDatabaseServiceInstance] failed.
    [SPManager] [ERROR] [27/12/2012 17:32:11]: Não foi possível iniciar o serviço devido a uma falha de logon
    [SPManager] [ERROR] [27/12/2012 17:32:11]: Cannot start service SPSearch on computer '.'.
    [SPManager] [ERROR] [27/12/2012 17:32:11]:


    Dux GP - Soluções em TI Londrina-PR



    sexta-feira, 28 de dezembro de 2012 18:04
  • A mensagem de erro do stsadm -o preupgradecheck certamente está relacionada com o SO utilizado, no entanto se você já está utilizando as versões mínimas recomendadas (W2K8 x64) entendo que este problema já foi corrigido.

    Sobre o problema de versão do SharePoint (build), este pode estar relacionado com a instalação que requer  a execução do setup do SharePoint SP2 + execução do SharePoint Products and Technologies Configuration Wizard (psconfig), que é recomendando logo no final da instalação.

    Sobre dúvidas de versões, estes links poderão ajudá-lo:

    http://todd-carter.com/sharepoint-versions/

    http://social.technet.microsoft.com/Forums/pt-BR/wsspt/thread/f9052521-dd75-4b75-9bd9-3c43dea4cd25

    []'s


    Tarcísio Gambin | MCP, MCT, MCTS, MCITP, ITILv3
    www.tarcisiogambin.net

    sexta-feira, 28 de dezembro de 2012 18:15
  • Tarcisio,

    Tem como reaplicar o SP2 + execução do SharePoint Products etc.... ?

    É possível remover o SP2 aplicado?

    Sinceramente não sei como contornar o  problema pois vendo o que você me passou a versão do banco de dados que tem + sharepoint o sistema diz que é a RTM do produto... mas estranho que quando eu fiz a instalação fiz os updade de SP e tudo mais.

    O que você daria como sugestão para tentar resolver o problema e atualizar o sharepoint. Efetuar uma instalação nova do zero e tentar o processo 1 por 1 de update e tudo mais.

    Preciso do banco de dados de conteudo no SharePoint Foundation o quanto antes.

    Aquele abraço.


    Dux GP - Soluções em TI Londrina-PR

    sábado, 29 de dezembro de 2012 02:53
  • Tarcisio,

    Fiz o seguinte procedimento. Apliquei o hotfix  abaixo o mesmo atualizou com sucesso no meu SP 3.0.

    April 2009 CU 12.0.6504.5000 968850

    Depois disto, fiz um backup do WSS_Contente do SQL 2005 e restaure no SQL 2012 e usei o comando Mount-SPContenteDatabase no meu site http://srvportal consegui carregar o banco de conteudo 100% porem ele está com 7 erros e 2 warning para verificar. Da uma analisada nas informações abaixo e me da uma força para eu saber quais os passos devo executar agora pois com muita busca consegui subir as informações.

     

    Os erros e avisos do arquivo de log que foi gerado.

    [powershell] [SPUpgradeSession] [INFO] [29/12/2012 01:39:09]: ======================================================================================
    [powershell] [SPUpgradeSession] [INFO] [29/12/2012 01:39:09]: Upgrade session failed. 7 errors and 2 warnings encountered.
    [powershell] [SPUpgradeSession] [INFO] [29/12/2012 01:39:09]: Procure as possíveis causas de problemas de atualização pesquisando as cadeias de caracteres [ERROR] e [WARNING] no arquivo de log de atualização. Consulte "http://go.microsoft.com/fwlink/?LinkId=157732" para obter mais informações sobre como resolver falhas de atualização.
    [powershell] [SPUpgradeSession] [INFO] [29/12/2012 01:39:09]: ======================================================================================
    [powershell] [SPUpgradeSession] [DEBUG] [29/12/2012 01:39:09]: Stop the session maintenance thread.
    [powershell] [SPUpgradeSession] [DEBUG] [29/12/2012 01:39:13]: Setting upgrade session object to offline in configuration database
    [powershell] [SPUpgradeSession] [DEBUG] [29/12/2012 01:39:13]: UPGRADE PERCENTAGE: 100.00000000% done, Total Elapsed Time 00:07:59.1611698.
    [powershell] [SPUpgradeSession] [DEBUG] [29/12/2012 01:39:13]: Releasing upgrade lock from configuration database

    ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
    [powershell] [SPContentDatabaseSequence] [ERROR] [29/12/2012 01:31:18]: Found a missing feature ID = [75a0fea7-cd50-401e-af0e-782f3662a299]
    [powershell] [SPContentDatabaseSequence] [ERROR] [29/12/2012 01:31:18]: O recurso com a ID 75a0fea7-cd50-401e-af0e-782f3662a299 é referenciado no banco de dados [WSS_Content], mas não está instalado no farm atual. O recurso ausente pode provocar falha na atualização. Instale qualquer solução que contenha esse recurso e reinicie a atualização, se necessário.
    [powershell] [SPContentDatabaseSequence] [ERROR] [29/12/2012 01:31:19]: Found a missing feature ID = [75a0fea7-0017-4993-85fe-c37971507bbc]
    [powershell] [SPContentDatabaseSequence] [ERROR] [29/12/2012 01:31:19]: O recurso com a ID 75a0fea7-0017-4993-85fe-c37971507bbc é referenciado no banco de dados [WSS_Content], mas não está instalado no farm atual. O recurso ausente pode provocar falha na atualização. Instale qualquer solução que contenha esse recurso e reinicie a atualização, se necessário.


    [powershell] [SPContentDatabaseSequence] [ERROR] [29/12/2012 01:31:19]: O banco de dados [WSS_Content] contém um site (ID = [47fc44d2-8515-4503-a85b-97968dba08ae], URL = [/]) não encontrado no mapa do site. Tente desanexar e anexar novamente o banco de dados.
    [powershell] [SPContentDatabaseSequence] [WARNING] [29/12/2012 01:31:19]: Os sites órfãos podem provocar falhas na atualização. Tente desanexar e reanexar o banco de dados que contém os sites órfãos. Reinicie a atualização, se necessário.
    [powershell] [SPContentDatabaseSequence] [ERROR] [29/12/2012 01:31:19]: O banco de dados [WSS_Content] contém um site (ID = [47fc44d2-8515-4503-a85b-97968dba08ae], URL = [/]) cuja URL já está em uso por outro site, no banco de dados (ID = [4562408c-d560-4dba-b7a3-f263aecffa88], nome = [WSS_Content_a3bfd63a6720414f9fb08aad34a5af51]), no mesmo aplicativo Web. Considere a possibilidade de excluir um dos sites que tenham URLs conflitantes.
    [powershell] [SPContentDatabaseSequence] [WARNING] [29/12/2012 01:31:19]: Os sites órfãos podem provocar falhas na atualização. Tente desanexar e reanexar o banco de dados que contém os sites órfãos. Reinicie a atualização, se necessário.

    [powershell] [SPWebTemplateSequence] [ERROR] [29/12/2012 01:39:08]: Template MPS#0: SPSite Id=47fc44d2-8515-4503-a85b-97968dba08ae could not be accessed due to exception. Skipping SPWeb Id=e7018a0a-94d5-4c46-8d53-c03d2b7c6cd1 for template upgrade. Exception: System.IO.FileNotFoundException: O site com a id 47fc44d2-8515-4503-a85b-97968dba08ae não pôde ser encontrado.

    Obrigado pela força.


    Dux GP - Soluções em TI Londrina-PR

    sábado, 29 de dezembro de 2012 04:05
  • Olá Fernando,

    Acho que precisamos entender um pouco mais teu cenário e qual sua abordagem durante migração do WSS3 para o SPFoundation.

    Se puder, disponibilize a topologia do seu cenário atual e como está sendo estruturada sua nova Farm. Para mim não ficou tão claro qual tipo de upgrade você está fazendo: in-place ou via database attach.

    Tenho a impressão que você tentou realizar um upgrade in-place (executando o setup do SPFoundation nos atuais servidores do WSS3), o que pode ter causado as primeiras mensagens de erro ou demais problemas, já que essa abordagem é um pouco mais 'delicada'.

    Mas como você comentou de um novo ambiente com SQL 2012 e anexar o banco na nova Farm, acredito que esteja tentando realizar um upgrade via database attach neste momento.

    Segue abaixo alguns links interessantes sobre os tipos de upgrade e melhores práticas:

    http://technet.microsoft.com/en-us/library/cc263447(v=office.14).aspx

    http://technet.microsoft.com/library/cc261992(office.14).aspx

    Sobre o pre-upgradecheck, ele apenas verifica as configurações da Farm atual, e se ela atende os requisitos mínimos e/ou best-practices para o update. Maiores detalhes neste link:

    http://technet.microsoft.com/en-us/library/cc262231(v=office.14).aspx

    Em todo caso, para upgrade via attach database (cenário mais seguro), basicamente este é o procedimento:

    - Certifique-se que o atual ambiente do WSS3 esteja funcional com pelo menos o Service Pack 2 e o October 2009 Cumulative Update ou superior;

    - Execute o stsadm -o preupgradecheck para verificar a compatibilidade da farm atual e caso haja algum problema;

    - Na nova Farm com SPFoundation configure todas as customizações, language packs e serviços necessários;

    - No SQL do WSS3, de um read-only no(s) content database(s) da web application desejada;

    - Realize um backup e restaure a(s) content database(s) da webapplication no banco da nova farm;

    - Crie uma nova Web Application na nova Farm com o SPFoundation;

    - Utilize o stsadm -o deletecontentdb ou o Central Admin para dar um dettach na base recém criada com a nova WebApplication. Execute o comando na nova Farm;

    - Utilize o stsadm -o addcontentdatabase ou o Central Admin para dar um attach nas bases da Farm anterior restauradas no banco da nova farm. Execute também na nova Farm;

    - Pronto!

    Basicamente este é o processo de upgrade. Verifique se consegue as bases da farm anterior e restaurar na nova farm desta forma.

    Qualquer novidade, mantenha a thread atualizada ;p

    []'s


    Tarcísio Gambin | MCP, MCT, MCTS, MCITP, ITILv3
    www.tarcisiogambin.net


    quinta-feira, 3 de janeiro de 2013 02:42
  • Tarcisio,

    Boa tarde.

    Primeiro obrigado pela força. No meu caso estou utilizando a opção de upgrade database attach para a versão SPFoundation 2010. Fiz os procedimentos conforme você colocou e depois de attach Wss_Content no novo Farm está ocorrendo erro de integridade. Verifique a imagem abaixo que eu tenho na Adm. Central do SPF 2010. Eu não consigo identificar o que seria este erros e link orfão e outros. Como identifico isto ou resolvo a questão. Tem como resolver isto ou eu refaço novamente todo o procedimento.


    Dux GP - Soluções em TI Londrina-PR

    quinta-feira, 3 de janeiro de 2013 18:49
  • Fernando,

    Você tem alguma solução customizada instalada no wss?
    Por exemplo, um wsp.

    Caso você tenha uma solução customizada instalada no wss, você deverá instalar a mesma na nova farm.


    Atenciosamente, Rafael Fausto

    quinta-feira, 3 de janeiro de 2013 18:58
  • Acho que agora falta pouco hein Fernando :D

    Bom, aparentemente o content database está ok e você já conseguiu fazer o attach no SQL 2012. Precisamos tratar agora este erro durante o upgrade.

    Esta mensagem trata-se de um recurso que:

    - Precisa ser instalado no SPFoudantion antes do restore OU

    - Precisa ser removido do WSS3 antes do backup.

    Qualquer uma das soluções é válida, depende o que é mais viável pra você neste momento.

    Para exportar qualquer solution (pacote utilizado para distribuir features) do seu WSS3, poderá utilizar a seguinte ferramenta:

    http://www.kemalkaradag.com/post/2009/12/22/SharePoint-Solution-Exporter.aspx

    * não há garantias que as features sejam compatíveis com o SPFoundation *

    Ou se preferir, a seguinte thread poderá ajudá-lo com alternativas sobre como remover a feature na farm anterior com o WSS3 antes do backup/ restore:

    http://social.technet.microsoft.com/forums/en-US/sharepointadminprevious/thread/61601201-c4e6-4a3e-bfe1-8ef1cfc1d44d/

    []'s


    Tarcísio Gambin | MCP, MCT, MCTS, MCITP, ITILv3
    www.tarcisiogambin.net


    quinta-feira, 3 de janeiro de 2013 23:04
  • Tarcisio,

    Estamos quase lá sim... Falta pouco.

    Em relação ao recurso ausente: ID = [75a0fea......] que não está presente no novo Farm eu não consigo indentificar ou licalizar ele no FARM antigo para saber o que é e como instalar no novo ou remover no antigo para migração. Execute o comando stsadm -o enumsolutions e outros comando para achar o ID = [75a0fea......], porem sem sucesso. Abaixo veja o que tenho instalado no meu FARM antigo do WSS 3.0.

    NÃO ACHO O RECURSOS ID 75a0fea...... no meu farm antigo.

    OS RECURSOS DO MEU FARM ANTIGO INSTALADOS SÃO:

    • UMA COISA QUE TENHO CUSTOMIZADA SÃO PAGINAS ASPX QUE FIZ COM SHAREPOINT DESIGNER PARA MOSTRAR CONTEUDO DE LISTA DE UMA FORMA CUSTOMIZADA. Será que pode ser isto? ESTAS PAGINAS FICAM DENTRO DE BIBLIOTECAS DE DOCUMENTOS.

    PORQUE NÃO ACHO MAIS NADA E O ID QUE DA ERRO NO NOVO FARM EU NÃO ACHO ELE NO ANTIGO.

    O QUE VOCÊ ACHA QUE POSSO FAZER?

    ABRAÇO.


    Dux GP - Soluções em TI Londrina-PR

    sábado, 5 de janeiro de 2013 15:01
  • Olá Fernando!

    Infelizmente o comando stsadm -o enumsolutions lista apenas as solutions (não as features).

    O SharePoint 2010 já possui alguns comandos em PowerShell para esta tarefa (listar features), como os citados no seguinte link:

    http://www.glynblogs.com/2010/08/powershell-commands-to-list-sharepoint-features.html

    Como no SharePoint 2007 não temos este curso, poderá utilizar a seguinte ferramenta do Stefan Gossner:

    http://archive.msdn.microsoft.com/WssAnalyzeFeatures

    Faça o download e disponibilize-a no servidor do WSS3

    Acesse o caminho via prompt e digite o seguinte comando:

    WssAnalyzeFeatures -url http://url-do-site-collection:porta

    Serão gerados dois arquivos.

    Abra o ContentDeploymentFeatures.txt para ver as features disponibilizadas no site.

    Verifique o que está instalado e o que está utilizando.

    Antecipadamente, gostaria de que verificasse no seguinte link uma lista de features (do qual possui a features que você mencionou):

    http://blogs.msdn.com/b/ketaanhs/archive/2009/06/29/sharepoint-2007-wss-3-0-feature-list-with-guid.aspx

    Cuidado para não remover uma feature que seu site ou aplicação seja dependente! Isto poderá deixá-los inacessíveis ou causar qualquer outra ação inesperada!

    Para remover uma feature, utilize os seguintes comandos:

    deactivatefeature/ uninstallfeature

    http://technet.microsoft.com/en-us/library/cc262680(v=office.12).aspx

    http://technet.microsoft.com/en-us/library/cc262976(v=office.12).aspx

    Este post poderá ajudá-lo sobre a melhor maneira de removê-las:

    http://blogs.msdn.com/b/kaevans/archive/2011/02/02/sharepoint-don-t-forget-to-uninstall-the-feature.aspx

    E fique tranquilo! Customizações nas páginas via SharePoint Designer não alteram/ criam novas features.

    []'s


    Tarcísio Gambin | MCP, MCT, MCTS, MCITP, ITILv3
    www.tarcisiogambin.net

    segunda-feira, 7 de janeiro de 2013 00:24
  • Tarcisio,

    Eu estive analisando uns post americano e encontrei uma situação identica a minha. onde ocorria o mesmo erro de Recurso não encontrado no site e etc... Seguindo as orientações eu fiz uma exclusão direta no banco de dados conforme comando que peguei no post. Depois deste procedimento meu site abriu 100%. Dei uma navegada por cima, acessei as lista e está tudo ok.

    Vou liberar o servidor para o pessoal trabalhar e acompanhar.

    Quero agradecer você pelo empenho e ajuda prestada.

    Um grande abraço.

    Só para saber o comando usado no SQL foi:

    SELECT * FROM WSS_Content_2007.dbo.Features WHERE FeatureId = '75a0fea7-cd50-401e-af0e-782f3662a299'

    O post que peguei foi este:

    http://social.technet.microsoft.com/forums/en-US/sharepointadminprevious/thread/61601201-c4e6-4a3e-bfe1-8ef1cfc1d44d/

    Removi este registro do banco de dados de conteudo. O site abriu.

    A Feature que descobri que foram removidas são estas... Para que server? Será que vou ter problema com o procedimento que eu fiz?

    75a0fea7-cd50-401e-af0e-782f3662a299 Site TSATypes 0273f170-f34b
    75a0fea7-0017-4993-85fe-c37971507bbc Web ProjMilestones 0273f170

    Obrigado.


    Dux GP - Soluções em TI Londrina-PR

    segunda-feira, 7 de janeiro de 2013 02:07
  • Olá Fernando!

    Curiosamente a thread que você citou é a mesma que eu havia comentado anteriormente ;p

    Nela são propostas várias soluções, no entanto alterações nas bases do SharePoint passam longe de qualquer best practice.

    Me recordo de uma documentação do SharePoint 2007 que menciona sobre a perda de garantia/ suporte técnico no caso de modificações diretas no banco de dados. Afinal isso poderia ser afetado com aplicações de patches, updates, entre outros.

    Em casos como estes é altamente recomendando utilizar Powershell ou Stsadm, pois desta forma a própria plataforma irá gerenciar todas as tarefas necessárias (como alterações no banco, arquivos, registro, e qualquer outra).

    Isso não necessariamente significa que irá encontrar algum problema, no entanto é bom pelo menos deixar registrada essa alteração ;p

    Fazendo uma rápida pesquisa, verifiquei que este ID pode ser de um dos 40 Templates de site para SharePoint:

    http://social.technet.microsoft.com/Forums/ta/sharepointadminprevious/thread/89fd7f08-cb06-416e-bba1-366f7ce3e718

    http://technet.microsoft.com/en-us/sharepoint/bb407286.aspx

    Se realmente for um desses IDs dos 40 site templates, o que pode acontecer é que os sites criados à partir deles poderão deixar de funcionar, e os templates não estarão disponíveis para criação de novos sites.

    Para confirmar realmente o ID das features, utilize a ferramenta "WssAnalyzeFeatures" que citei no post anterior :)

    Quando puder, nos informe se tudo isso deu certo ;p

    []'s


    Tarcísio Gambin | MCP, MCT, MCTS, MCITP, ITILv3
    www.tarcisiogambin.net


    terça-feira, 8 de janeiro de 2013 01:32
  • Tarcisio,

    Fiz todos os testes e coloquei o site para produção. Está tudo certo.

    Muito obrigado pela força neste problema.

    Vou abrir uma nova pergunta de como fazer o upgrade visual.


    Dux GP - Soluções em TI Londrina-PR

    quinta-feira, 10 de janeiro de 2013 01:30
  • ola tambem fiz este passos so que quando vou abrir a minha pagina inicial do meu site aparece esta mensagem

    O nome do arquivo ou da pasta contém caracteres que não são permitidos. Use outro nome. 

    pode me ajudar

    sábado, 26 de janeiro de 2013 21:45