none
(SOMASE) Somar valores entre datas no Excel 2013 com referência em outra célula RRS feed

  • Pergunta

  • Olá amigos.

    Tenho a seguinte tabela:

    Data da Venda Valor Período: 04/01/2010         à 08/01/2010
    01/01/2010 150,00 Total:  R$ 995,00    
    02/01/2010 300,00
    03/01/2010 100,00
    04/01/2010 50,00
    05/01/2010 35,00
    06/01/2010 170,00
    07/01/2010 290,00
    08/01/2010 450,00
    09/01/2010 300,00
    10/01/2010 120,00


    Supondo que a "DATA DA VENDA" está na Coluna A, e que o "VALOR" está na Coluna B, preciso que o campo "TOTAL" some os valores entre o período informado no campo "PERÍODO".

    Estou utilizando a fórmula abaixo para executar esta operação, porém ela retorna "0" como resultado.

    =SOMASES(D4:D13;C4:C13;">=G3";C4:C13;"<=I3")

    No entanto, quando informo uma data nos critérios 1 e 2, a fórmula retorna a soma do intervalo, conforme fórmula abaixo:

    =SOMASES(D4:D13;C4:C13;">=04/01/2010";C4:C13;"<=08/01/2010")

    Contudo preciso que o resultado seja exibido com base nas datas que informo dentro das células "G3" e "I3".

    Alguém poderia me orientar em relação a este assunto?

    Obrigado.

    Fernando

    sexta-feira, 27 de junho de 2014 21:26

Todas as Respostas

  • Olá Fernando!

    É necessário fazer um pequeno ajuste na sua fórmula, pois a referencia das células de critérios das datas dentro de parentesis será interpretada pelo Excel como texto e não como data. Portanto, sua fórmula ficará assim:

    =SOMASES(D4:D13;C4:C13;">="&G3;C4:C13;"<="&I3)

    O sinal "&" funciona para concatenar os valores e transformar os dois critérios da fórmula no formato adequado para a sua necessidade.

    Abraços!


    Rafael Kamimura

    • Sugerido como Resposta Rafael Kamimura segunda-feira, 30 de junho de 2014 14:22
    segunda-feira, 30 de junho de 2014 14:22
  • =SOMASES(D4:D13;C4:C13;">="&G3;C4:C13;"<="&I3) segui a sugestão e funcionou a fórmula, porém tive que fazer em outra planilha e agora não funciona com esta opção e sem ela.

    Usei o & para ler a data e realmente leu. Só que quando fui usar a mesma fórmula em outra planilha não funcionou -> =SOMASES(D4:D13;C4:C13;">="&G3;C4:C13;"<="&I3).

    1ª semana   2ª semana  
    14/01/17 01/01/17 07/01/17 08/01/17 14/01/17
    Peso ton. diário Peso ton. Semanal Peso ton. Semanal
    28,59  -  -
    2.385,32  -  -

    Nesta funcionou

    =SOMASES(Disp!M:M;Disp!B:B;B17;Disp!H:H;">="&G17;Disp!H:H;"<="&H17)

    OBRA MEDIÇÃO TOTAL VIAGEM 30/11/2016 DATA APURAÇÃO
    420 - ROMA L3 AG SERVENG               205                20 21/10/2016 20/11/2016

    terça-feira, 17 de janeiro de 2017 12:35
  • Muito Obrigado. Me ajudou bastante

    quinta-feira, 28 de dezembro de 2017 15:27
  • Olá amigos.

    Tenho a seguinte tabela:

    Data da Venda Valor Período: 04/01/2010         à 08/01/2010
    01/01/2010 150,00 Total:  R$ 995,00    
    02/01/2010 300,00
    03/01/2010 100,00
    04/01/2010 50,00
    05/01/2010 35,00
    06/01/2010 170,00
    07/01/2010 290,00
    08/01/2010 450,00
    09/01/2010 300,00
    10/01/2010 120,00

    Tenho uma dúvida acrescentar a sua questão, me ajudem por favor. e se eu inserir mai uma coluna com nomes de vendedores. e eu precisa se somar tudo que um vendedor especifico vendeu em um intervalo de tempo? como ficaria a formula?

    terça-feira, 18 de setembro de 2018 02:25
  • Boa tarde Amigo, 

    Você provavelmente utilizará da função SOMASES, que possui a seguinte sintaxe:

    =SOMASES(intervalo_soma; intervalo_criterios1; criterios1; intervalo_criterios2; criterios2 ...)

    no seu caso, o intervalo de soma seria a coluna de valor, criterio 1 seria a data, criterio 2 seria nome... e assim por diante.

    Espero ter ajudado.

    segunda-feira, 24 de setembro de 2018 19:06
  • Rafael, apesar que não fiz a pergunta olhei sua dica e foi ótima, aprendi sobre a formula que por sinal será muito útil.

    Aproveito para perguntar se poderia indicar cursos que trabalham com essas formulas? fiz excel avançado mas devido a turma não fomos tão longe, com várias formulas e até mesmo juntando formulas com formulas.

    Preciso ter uma melhor leitura do que a formula esta dizendo o que ela faz e ate mesmo para juntar duas formulas.

    Obrigado!!!

    segunda-feira, 29 de outubro de 2018 15:03
  • Prezados, boa tarde

    Gostaria de uma ajuda, estou tentando montar a formula "SOMASES" conforme elucidado aqui neste tópico, porém os dados de onde quero buscar a soma e intervalo dos critérios estão na Aba Plan1 e não puxou quando montei para teste na mesma aba foi normal.

    Estranhei uma formula não funcionar com dados em outra aba.

    Podem me ajudar. VLW

    segunda-feira, 5 de novembro de 2018 15:57
  • Prezados, boa tarde

    Gostaria de uma ajuda, estou tentando montar a formula "SOMASES" conforme elucidado aqui neste tópico, porém os dados de onde quero buscar a soma e intervalo dos critérios estão na Aba Plan1 e não puxou quando montei para teste na mesma aba foi normal.

    Estranhei uma formula não funcionar com dados em outra aba.

    Podem me ajudar. VLW

    Gui, a fórmula abaixo funciona normalmente para fazer a busca na plan 1

    =SOMASES(Plan1!$B:$B;Plan1!$A:$A;">="&A1;Plan1!$A:$A;"<="&B1)

    Para boas práticas no fórum, por favor leia o artigo abaixo:

    https://social.technet.microsoft.com/Forums/pt-BR/2af4d391-86fe-43b8-9dc8-c957bda19396/leia-isto-antes-de-postar-boas-prticas-no-frum-?forum=officept

    Att.


    segunda-feira, 5 de novembro de 2018 16:59