none
Erro ao iniciar o Failover Cluster Manager RRS feed

  • Pergunta

  • Prezados, bom dia!

    Gostaria de uma ajuda quando ao erro abaixo: 

    O Cluster está funcionando normalmente, porém não estou conseguindo gerenciar os nodes pelo console.

    Já removi o arquivo "Cluadmin" (diretório MMC) que existia no meu Profile, porem não resolveu.

    O erro que estou recebendo no log está na imagem abaixo:


    Erro no server Manager:


    • Editado Oswaldo Santos quarta-feira, 22 de março de 2017 03:48 Nova imagem
    quarta-feira, 22 de março de 2017 03:44

Respostas

  • bom dia Oswaldo,

    eu tive isso uma vez e resolvi usando este procedimento para validar o repositorio WMI:

    Trouble Connecting to Cluster Nodes? Check WMI!

    Outro ponto q eu recomendo é validar este este kb esta aplicado pois ele corrige uma falha na console do cluster:

    Failover Cluster Management snap-in crashes after you install update 2750149 on a Windows Server 2012-based failover cluster

    E, se mesmo assim nao funcionar, tente fazer o rebuild do repositorio wmi usando este bat:

    ================

    Rebuild WMI Script

    ================

    @echo off

    sc config winmgmt start= disabled

    net stop winmgmt /y

    %systemdrive%

    cd %windir%\system32\wbem

    for /f %%s in ('dir /b *.dll') do regsvr32 /s %%s

    wmiprvse /regserver

    winmgmt /regserver

    sc config winmgmt start= auto

    net start winmgmt

    for /f %%s in ('dir /s /b *.mof *.mfl') do mofcomp %%s

     

    ========================

    Server manager mof rebuilded

    ========================

    C:\Windows\System32\wbem

    mofcomp mgmtprovider.mof

    Crie um arquivo bat com o "Rebuild WMI Script" e execute ele. Depois, execute o comando,

    C:\Windows\System32\wbem

    mofcomp mgmtprovider.mof

    para que a console do server manager remova aquelas "flags" vermelhas que podem aparecer após o rebuild do wmi.

    Depois disso, reboot no node e veja o resultado.

    PS.: antes de fazer estas etapas, coloque o node em pausa e remova todos os recursos deste node.

    Nos reporte o resultado;

    • Marcado como Resposta Oswaldo Santos sexta-feira, 24 de março de 2017 12:39
    quinta-feira, 23 de março de 2017 13:14

Todas as Respostas

  • Bom dia Oswaldo Santos

    Tudo bem contigo?

    Grato pela participação no Fórum Microsoft Technet.

    Veja se esta thread que é similar pode lhe auxiliar.

    ID 2051 FailoverClustering Errors

    https://social.technet.microsoft.com/Forums/ie/en-US/3b3a8b02-af45-427a-a1cf-4ec0074e7a2d/id-2051-failoverclustering-errors?forum=winserverClustering

    Atenciosamente,


    Guilherme Macedo S

    Esse conteúdo é fornecido sem garantias de qualquer tipo, seja expressa ou implícita

    TechNet Community Support

    Por favor, lembre-se de Marcar como Resposta as postagens que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    quarta-feira, 22 de março de 2017 13:11
  • Primeiramente obrigado pelo retorno, pesquisei no link e fui direcionados para outros até chegar na verificações a seguir:

    Depois de uma verificação no wmi e em um dos nodes (que no meu caso são apenas dois) estou recebendo erro.

    O Sistema operacional é Windows Server 2012.

    Node 1 - Ativo

    Node 2 - Passivo

    quarta-feira, 22 de março de 2017 18:54
  • bom dia Oswaldo,

    eu tive isso uma vez e resolvi usando este procedimento para validar o repositorio WMI:

    Trouble Connecting to Cluster Nodes? Check WMI!

    Outro ponto q eu recomendo é validar este este kb esta aplicado pois ele corrige uma falha na console do cluster:

    Failover Cluster Management snap-in crashes after you install update 2750149 on a Windows Server 2012-based failover cluster

    E, se mesmo assim nao funcionar, tente fazer o rebuild do repositorio wmi usando este bat:

    ================

    Rebuild WMI Script

    ================

    @echo off

    sc config winmgmt start= disabled

    net stop winmgmt /y

    %systemdrive%

    cd %windir%\system32\wbem

    for /f %%s in ('dir /b *.dll') do regsvr32 /s %%s

    wmiprvse /regserver

    winmgmt /regserver

    sc config winmgmt start= auto

    net start winmgmt

    for /f %%s in ('dir /s /b *.mof *.mfl') do mofcomp %%s

     

    ========================

    Server manager mof rebuilded

    ========================

    C:\Windows\System32\wbem

    mofcomp mgmtprovider.mof

    Crie um arquivo bat com o "Rebuild WMI Script" e execute ele. Depois, execute o comando,

    C:\Windows\System32\wbem

    mofcomp mgmtprovider.mof

    para que a console do server manager remova aquelas "flags" vermelhas que podem aparecer após o rebuild do wmi.

    Depois disso, reboot no node e veja o resultado.

    PS.: antes de fazer estas etapas, coloque o node em pausa e remova todos os recursos deste node.

    Nos reporte o resultado;

    • Marcado como Resposta Oswaldo Santos sexta-feira, 24 de março de 2017 12:39
    quinta-feira, 23 de março de 2017 13:14
  • Oswaldo Santos

    Veja se esta documentação pode lhe auxiliar:

    FIX: DCOM Application Fails with RPC_E_DISCONNECTED

    https://support.microsoft.com/en-us/help/293631/fix-dcom-application-fails-with-rpc-e-disconnected

    Atenciosamente,


    Guilherme Macedo S

    Esse conteúdo é fornecido sem garantias de qualquer tipo, seja expressa ou implícita

    TechNet Community Support

    Por favor, lembre-se de Marcar como Resposta as postagens que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    quinta-feira, 23 de março de 2017 13:23
  • Muito obrigado por me ajudar, executei o Rebuild do WMI e reiniciei o Node que apresentava falha. Apos isso o console do Failover Cluster Manager iniciou sem problemas e wmi estava consistente novamente (comando "winmgmt /verifyrepository").


    sexta-feira, 24 de março de 2017 12:43
  • Mais uma vez muito obrigado Guilherme, consegui resolver fazendo o rebuild do wmi no node que apresentava inconsistência.
    sexta-feira, 24 de março de 2017 12:45
  • Bom dia Oswaldo,

    obrigado pelo retorno. Muito bom saber que foi resolvido o seu problema. Final de semana salvo !!! :)

    Abraço.

    sexta-feira, 24 de março de 2017 13:37