none
Excel 2010 - Contar quantidade de números em sequência RRS feed

  • Pergunta

  • Pessoal, um desafio a quem gosta e manja de fórmulas, já me quebrei e não consegui.

    Tenho uma linha com um número em cada célula em cada coluna, conforme abaixo.

    A B C D E F G H I J K L M N O
    1 2 3 5 7 8 9 10 11 12 13 15 16 19 21

    Preciso saber qual a quantidade maior de números sequências desta linha, vejam, se contar manualmente, vemos que a sequência maior é "7 8 9 10 11 12 13", que são 7 números ok? Preciso de uma fórmula que me traga em outra célula que nesta linha toda, a quantidade de números sequênciais maior é 7.

    Obrigado

    terça-feira, 21 de agosto de 2012 21:39

Respostas

  • Na planilha exemplificada acima,

    Na célula A2, digite 1

    Na célula B2, digite =SE(B1=A1+1;A2+1;1)

    Copie a fórmula de B2 e cole no intervalo C2:O2.

    Na célula A3, escreva a fórmula =MÁXIMO(2:2)


    Felipe Costa Gualberto - http://www.ambienteoffice.com.br

    • Sugerido como Resposta FilipeMagno quarta-feira, 22 de agosto de 2012 00:05
    • Marcado como Resposta Marco_AM quarta-feira, 22 de agosto de 2012 13:40
    terça-feira, 21 de agosto de 2012 21:50

Todas as Respostas

  • Na planilha exemplificada acima,

    Na célula A2, digite 1

    Na célula B2, digite =SE(B1=A1+1;A2+1;1)

    Copie a fórmula de B2 e cole no intervalo C2:O2.

    Na célula A3, escreva a fórmula =MÁXIMO(2:2)


    Felipe Costa Gualberto - http://www.ambienteoffice.com.br

    • Sugerido como Resposta FilipeMagno quarta-feira, 22 de agosto de 2012 00:05
    • Marcado como Resposta Marco_AM quarta-feira, 22 de agosto de 2012 13:40
    terça-feira, 21 de agosto de 2012 21:50
  • Show, deu certo!!! Obrigado
    quarta-feira, 22 de agosto de 2012 13:40