none
Revisão da Fórmula RRS feed

  • Pergunta

  • Bom dia dia!

    Solicito a sua ajuda para revisar a fórmula.

    Na célula A1, tenho o valor 46,00 com duas casas decimais.

    Na célula A2, tenho o valor 1.014,00 com duas casas decimais.

    Na célula tenho a fórmula  ="O Total da soma "&"é"&SOMA(A1:A2), que apresenta o resultado O Total da soma é 1060

    Gostaria que apresentasse o Resultado -  O Total da soma é 1.060,00

    Com as casas decimais.

    Grato - GENECI.

    segunda-feira, 19 de dezembro de 2016 13:21

Respostas

  • Como o valor final é convertido para Texto, só fazendo alguns "truques". Veja:

    =SE((SOMA(A1:A2) - INT(SOMA(A1:A2))) > 0;("O Total da soma "&"é: ")&SOMA(A1:A2);("O Total da soma "&"é: ")&SOMA(A1:A2)&",00")

    É mais simples você usar duas células, uma para o texto e outra para a soma, formatando essa célula como moeda.


    https://inframicrosoft.wordpress.com/


    segunda-feira, 19 de dezembro de 2016 14:17

Todas as Respostas