none
Ajuda Sharepoint Workflow com SPD RRS feed

  • Pergunta

  • Ola amigos,

    Necessito a vossa ajuda relativamente a um workflow que criei no SPD 2007 para o WSS 3.0.

    Bom, nós temos uma base de dados em access em que as tabelas estão ligadas ao sharepoint. Basicamente, cada vez que se cria um novo item na base de dados, este entra automaticamente no sharepoint para consulta, pois é lá que residem as tabelas originais. O Access funciona como BackOffice.

    Criei um workflow o qual é activado baseado em alguns factores aquando do seu carregamento no access. Por exemplo, quando a variável X for igual a TRUE, activa o workflow e envia um email para algumas pessoas.´

    O problema é que quando é criado o item em access e a variável X é TRUE, o workflow é activado e conclui com sucesso, mas nenhum email é enviado... estranho. Se formos ao sharepoint e ao item recentemente criado, activarmos manualmente o workflow, este conclui com sucesso enviando o tal email para os destinatários.

    Por outro lado, nós conseguimos também introduzir dados a partir de uma lista Excel via Access com a opção (Dados Externos -> Excel). Deste modo, quando a variavel X = True, o workflow é activado e conclui com exito, e envia todos os emails que tem a enviar com exito.

    Afinal o que pode estar errado? O workflow foi criado com as opções de inicio automático quando um novo item é criado ou manualmente atraves do sharepoint. Não existem erros no workflow, caso contrário, nem manualmente funcionava.

    Devo dizer que o workflow tem 1 condição SE... e 50 condições SENÂO..., todas no mesmo workflow, mas não me parece que seja do tamanho...

    Dos users também não serão, pois conseguem manualmente iniciar o workflow, ou se os itens forem carregados via Excel, o workflow funciona...

    Algum de vocês me pode dar uma ajuda? Já não sei o que fazer para por a funcionar o workflow quando um novo item é adicionado a partir do access.

    Obrigados.

    domingo, 19 de dezembro de 2010 10:16

Respostas

  • Olá Carlos ferreira bom dia, cara esse problema provavelmente é que o workflow está sendo executando com a conta que você instalou o SP, faça o seguinte crie uma nova conta e adicione essa conta como administrador do site, ou em politica de usuário no central ADM dê controle total na web app e recrie o fluxo com esse usuário, porque a conta que você criou o fluxo deve tentar ativar o fluxo no caso de inserção dos dados via access e contas de "sistema" não executam alguns fluxos automaticamente, só manualmente. Algo parecido já aconteceu comigo então tente fazer com que esses fluxos iniciem por outra conta.
    Caso a reposta tenha resolvido por favor Marque esse post como "RESPOSTA" para que se encerre essa Thread. E se lhe foi util também Marque como "votar como Útil" Caso não tenha resolvido, sinta-se a vontade para fazer novas perguntas. MCP - Win2k3 server | MCP - Windows XP | MCDST - Windows XP | MCSA - Win2k3 Server| MCTS - MOSS 2007|
    • Marcado como Resposta Richard Juhasz quinta-feira, 8 de dezembro de 2011 19:05
    segunda-feira, 27 de dezembro de 2010 14:28

Todas as Respostas

  • Será que ninguém me consegue responder? Nem uma ideia?

    quinta-feira, 23 de dezembro de 2010 18:04
  • Olá Carlos ferreira bom dia, cara esse problema provavelmente é que o workflow está sendo executando com a conta que você instalou o SP, faça o seguinte crie uma nova conta e adicione essa conta como administrador do site, ou em politica de usuário no central ADM dê controle total na web app e recrie o fluxo com esse usuário, porque a conta que você criou o fluxo deve tentar ativar o fluxo no caso de inserção dos dados via access e contas de "sistema" não executam alguns fluxos automaticamente, só manualmente. Algo parecido já aconteceu comigo então tente fazer com que esses fluxos iniciem por outra conta.
    Caso a reposta tenha resolvido por favor Marque esse post como "RESPOSTA" para que se encerre essa Thread. E se lhe foi util também Marque como "votar como Útil" Caso não tenha resolvido, sinta-se a vontade para fazer novas perguntas. MCP - Win2k3 server | MCP - Windows XP | MCDST - Windows XP | MCSA - Win2k3 Server| MCTS - MOSS 2007|
    • Marcado como Resposta Richard Juhasz quinta-feira, 8 de dezembro de 2011 19:05
    segunda-feira, 27 de dezembro de 2010 14:28