none
Organização - Status Falha após importação de solução RRS feed

  • Pergunta

  • Ola, realizei uma migração de CRM4.0 para 2011, esta migração foi realizada em um novo servidor com uma instalação limpa do CRM 2011, realizei o backup do banco e importei-o no CRM2011. Depois realizei a instalação do CRM 2013 no modo "In-place" sobre o CRM 2011. Ambos os processos finalizaram com sucesso.

    Após essa migração verifiquei no Deployment Manager que a organização estava habilitada, testei a navegação e estava ok com todos os dados migrados.

    Depois foi importado a "Solution" customizada que utilizamos. Durante os testes dos usuários notamos que os processos não estavam rodando, eles ficavam travados com o status "Waiting for resources", após uma pesquisa encontrei o seguinte artigo que relata o mesmo problema e foi verificado no Deployment Manager a organização estava com status de falha.

    https://techjukebox.wordpress.com/2012/03/14/crm-2011-workflow-expansion-task-waiting-for-resources/

    Verifiquei que realmente a organização estava com falha, porém foi verificado após a migração que a organização estava habilitada. Porém a solução deste artigo é excluir a organização e criar uma outra, não posso fazer isso, tenho 600gb de dados da empresa.

    É possível que este erro do status da organização ficar como falha tenha ocorrido após a importação da Solution customizada, já que estava funcionando após a migração?

    Preciso corrigir este na organização, alguém já passou por isso ou tem alguma ideia de como solucionar?

    Valeu

    quarta-feira, 1 de abril de 2015 14:23

Todas as Respostas

  • Observação: Entre a instalação do CRM 2013 e a instalação da solution foi realizado a instalação do Service Pack 1 e do Update Rollup para Service Pack1.

    quarta-feira, 1 de abril de 2015 15:16
  • Boas Rodrigo,

    Algumas perguntas básicas, o AsyncService está a correr, se não tiver tenta colocar a correr caso falhe verifica todos os logs (event viewer e trace do servidor). Caso esteja a correr vá até as tarefas de sistema e verifique o que está a dar erro e veja a mensagem de erro que pode estar a causar.

    Outra sugestão é ver este KB eu já tive alguns problemas destes e quase sempre ou no registry ou na BD MSCRM_Config que tem todas as configurações e endereços estão informações erradas.

    Espero ter ajudado.
    Se respondi a sua pergunta por favor marque como resposta e\ou como útil.


    Pedro Azevedo Crm Specialist 4.0\2011

    • Sugerido como Resposta Azevedo PedroMVP quarta-feira, 1 de abril de 2015 16:23
    quarta-feira, 1 de abril de 2015 16:23
  • O serviço AsyncService está rodando sim, irei verificar este KB.
    quarta-feira, 1 de abril de 2015 17:21
  • Outra observação é que após a instalação do service pack e rollup update realizei a desinstalação do Report Extensions 2011 e instalei o 2013.
    quarta-feira, 1 de abril de 2015 17:30
  • Azevedo Pedro, creio que o problema não tem relação com o artigo, inclusive porque este artigo é referente a versão 4.0. Este problema está ocorrendo na versão 2013. Ressalto que após a migração a organização estava com status=enable e agora está como "Failed".
    Outro detalhe que esqueci de mencionar é que os processos rodaram normalmente até o dia 27/03 e justamente neste dia realizei o upgrade do Report Extensions (No servidor SQL) e a instalação da Solution customizada.

    Creio que o problema possa ter ligação à instalação desta Solution já que é um pacote customizado pelos desenvolvedores da minha consultoria.

    quarta-feira, 1 de abril de 2015 18:12
  • Boas Rodrigo,

    Eu penso que o problema vem do upgrade do Reporting Extensions e não da solution, já agora o que tinha esta solution, se tiver workflows ou plugins desabilita-os e vê se continua com o mesmo problema.

    Em relação ao reporting extensions correu tudo bem? Já tentastes colocar novamente a organização enabled? Já vistes os logs (userlogged, trace ou event viewer), ao editares as definições da organização ele dá erro?

    O problema de excluir e criar uma nova organização é uma questão de tempo?

    Espero ter ajudado.
    Se respondi a sua pergunta por favor marque como resposta e\ou como útil.


    Pedro Azevedo Crm Specialist 4.0\2011

    quinta-feira, 2 de abril de 2015 10:48
  • Olá Pedro, em relação ao solution, cheguei a desabilita-la. Dentro da solution existem os seguintes itens:

    *JavaScripts

    *GIF

    *ICO

    *Workflows

    *Direitos de Acesso

    *Modelos de Artigo

    *Modelos de Contrato

    No Deployment Wizard não existe a opção de Habilitar a organização.

    Irei habilitar o Trace do CRM.

    segunda-feira, 6 de abril de 2015 21:32
  • Boas Rodrigo,

    Mas podes editar as definições da organização e assim forçando que ela se ative novamente. Outra alternativa é verificares as tarefas de sistema e ver se existe alguma tarefa em espera, ou com erro e tentar eliminar.

    Espero ter ajudado.
    Se respondi a sua pergunta por favor marque como resposta e\ou como útil.


    Pedro Azevedo Crm Specialist 4.0\2011

    terça-feira, 7 de abril de 2015 13:39