none
Mapear unidade de rede, com usuario local. RRS feed

  • Pergunta

  • Boa tarde srs!

    Estou com uma pequena dificuldade que acredito que vocês podem me ajudar.

    Tem uma estação, que tem uma pasta compartilhada que chama stwin, e que é mapeada em 2 estações. Mas e feita manualmente. Resolvi então realizar via Script. O fiz da seguinte maneira:

    @echo off

    net use z: /delete
    net use z: \\tarifador\stwin /user:tarifador/administrador senha

    Mas as estações estão dentro do dominio. E a pasta somente funciona se for mapeada com o usuario administrador local. No script coloquei o nome da estação e o usuario e a senha. Mas diz que não e possivel apresenta o erro:

    O contexto de usuario fornecido e invalido.

    Como posso realizar esta configuração?

    Agradeço

    Daron Silva


    segunda-feira, 11 de maio de 2009 19:34

Respostas

  • Olá senhores!

    Bom como não tive uma solução, creie um usuario com privilegios e fiz o script com esse usuario. Agora funciona normalmente.

    Att

    Daron Silva
    quarta-feira, 20 de maio de 2009 11:20

Todas as Respostas

  • Olá,

    O computador \\tarifador está no dominio também???

    Verifique as permissões do compartilhamento (tanto na guia Compartilhamento, quanto na guia Security da pasta)

    O mapeamento você quer fazer para o usuário logado???

    Você já tem alguma pasta mapeada nas propriedades do usuário no AD (na guia profile você tem como conectar à uma pasta)

    Faça os testes e nos retorne.

    Até mais,

    Jesiel

    Obs.: Se útil, classifique.
    segunda-feira, 11 de maio de 2009 19:41
  • Sim o tarifador está sim no dominio.
    As permissoes, tentei colocar os 2 usuarios com controle total na pasta, mas por alguma restrição do aplicativo somente funciona se for mapeado com o usuario adm local, senao nao funciona.

    Esse mapeamento e para o usuario logado, mas no script tem que conectar com o usuario adm local

    No ad não ira funcionar pois preciso que seja com outro usuario, desta forma acredito que seja somente com o usuario que configurei esta opçao...


    Att

    Daron Silva
    segunda-feira, 11 de maio de 2009 19:46
  • Olá,

    Na verdade você consegue com administrador local, pois não autenticou no dominio com usuário local (não precisa ser administrador).

    Você não vai conseguir passar usuario diferente do dominio para mapeamento...

    Qual é o propósito de colocar outro usuário do dominio??? Talvez existe outra alternativa para sua situação.

    Até mais,

    Jesiel
    segunda-feira, 11 de maio de 2009 22:52
  • OLá Jesiel!

    Então quer dizer que por script não posso mapear com um usuario que não seja do dominio? Nossa não sabia dessa!

    Bom o que acontece e que o aplicativo Sumus (tarifador) foi configurado para usar as configurações em z:, com isso somente uma conta com privilegios administrativos, consegue logar sem erros e acesso completo. E as contas dos usuarios não tem esses acessos. O engraçado e que a partir do wizard do windows, lá sim eu consigo fazer que seja mapeado com o usuario adm local da maquina. Por conta disso pensei que era possivel via script...

    Agradeço a atenção

    Daron Silva
    terça-feira, 12 de maio de 2009 12:17
  • Olá,

    Então...

    Mas você precisa executar o aplicativo com privilégios administrativos ou o problema é que só mapeia com privilégios adminitrativos???

    Se o problema for somente o mapeamento... vamos tentar resolver alterando as permissões...

    Faz um teste conectando o micro (tarifador) manualmente: \\tarifador e mapeia manual pra ver se vai...

    Se não for... é problema de permissão...

    Aí você tem que ir na pasta onde está compartilhado ( no tarifador) e ir na guia segurança... dar permissão para o usuário ou grupo que você está testando.

    Depois ir na guia Compartilhamento e dar permissão também.. para o usuário ou grupo.

    Faça os testes e nos retorne.

    Até mais,

    Jesiel
    terça-feira, 12 de maio de 2009 13:23
  • Oi

    Bom... o aplicativo funciona normalmente com os usuarios, então e mapear com os privilegios.
    Quanto as permissões, ja havia colocado os usuarios deles com acesso irrestrito e completo ao compartilhamento. Feito de maneira manual, seleciono o caminho e mapeia, mas quando vou usar dentro do aplicativo apresenta o erro.
    Agora se mando mapear, e seleciono "Conectar-se com um nome de usuario diferente" e coloco: tarifador\administrador e senha, funciona perfeitamente.

    E um caso bem estranho.

    Att
    Daron Silva
    quarta-feira, 13 de maio de 2009 15:25
  • Olá senhores!

    Bom como não tive uma solução, creie um usuario com privilegios e fiz o script com esse usuario. Agora funciona normalmente.

    Att

    Daron Silva
    quarta-feira, 20 de maio de 2009 11:20
  • Daron, tranquilo?

     

    net use z: \\tarifador\stwin /user:tarifador\administrador password /persistent:yes (utilizando o parametro /persistent ele guarda essa configuração e não precisará conectar sempre)

    (cuidado com a barra que estava utilizando apos o nome do computador "tarifador" a barra é essa: "\")

     

    Em vez de criar um usuário com privilegio para isso, pode dar acrescentar o seu usuário do dominio no grupo "Power User" do computador tarifador..

    Isso também é uma solução.

     

    Teste e caso tenha ajudado comente e vote por favor..

     

    abraços

     


    Gabriel Moraes | Microsoft Certified Professional
    quinta-feira, 24 de março de 2011 19:19
  • Bom dia

    Coloque assim:

    @echo off

    net use z: /delete
    net use z: \\tarifador\stwin /user:administrador@tarifador senha

    Isto se seu domínio for tarifador.

    Abraços,

    quinta-feira, 16 de agosto de 2012 14:31