none
Erro na Replicação com Hyper-v Replica RRS feed

  • Pergunta

  •  Olá Srs.

    Venho vivenciando um Drama com esse Hyper-v Replica.   Eu Posso um Ambiente com 2 Hots Hyper-v na Mesma Rede onde existe um Host principal que replica as Vms para o Servidor de Replica e seguida o Servidor de Replica extende as replicas para um Site Remoto que fica em outro Bairro da Cidade.  o Site Principal está conectado ao Site Remoto por uma VPN Lan to Lan. 

    Blz a Replicação dentro da Rede local Funciona Perfeitamente já possui 1 ano que nunca ocorreu nenhuma falha.  Porém na replicação para o Site Remoto  sempre de vez em quando uma Unica Réplica que e a do Banco de Dados ( SQL Server) amanhece com estado de Critical, quando eu vou verificar a mesma parou de replicar desde a noite passado. ao fazer toda checagem vejo que não houve nenhuma Queda no Link pois as demais replicas encontram-se com estado Normal na replicação.  Acontece somente com essa.

    Ao Verificar no visualizador de eventos sempre e registrado os eventos abaixo:

    ID: 32315 - AVISO

    O Hyper-V não pôde replicar as alterações da máquina virtual 'APP02' (ID da máquina virtual 3C017DEF-3E16-4718-8C64-FED8A6A4E85A). O Hyper-V tentará novamente a replicação após 5 minuto(s).

    ID: 32552 - ERRO

    O Hyper-V não pôde replicar as alterações da máquina virtual 'APP02' porque o servidor de réplica recusou a conexão. O possível motivo é que a operação de replicação está pendente no servidor de réplica da mesma máquina virtual que está demorando mais do que o previsto ou que tem uma conexão existente. (ID da máquina virtual 3C017DEF-3E16-4718-8C64-FED8A6A4E85A)

    Conclusão, Eu já li tudo que vocês possam imaginar sobre Hyper-v replica na internet, e ate hoje nunca encontrei uma explicação mais precisa pare esse eventos.  Vira e mexe eu tenho esse Problema e eu so resolvo tenho que remover a replica e reexportar a replica para um HD Externo e importa no Site Remoto.  Mais me gera muito Retrabalho sem falar do trastorno.

    Gostaria de saber dos amigos se alguém ja encontrou esse problema, eu precisaria realmente saber o que está ocasionando esse problema para que de fato eu possa encontrar uma solução definitiva.  Eu ja fiz tantos procedimentos e sem sucesso.

    quarta-feira, 7 de janeiro de 2015 00:21

Respostas

Todas as Respostas

  • Olá,

    Quando se trata de réplica do Hyper-V é bom ter esse post (http://blogs.technet.com/b/virtualization/archive/2012/06/21/interpreting-replication-health-part-2.aspx) do time de produto da Microsoft sempre guardado.

    Como é a estrutura de rede pela qual os nós se comunicam?


    Sergio Figueiredo
    Microsoft Certified Solutions Associate

    • Marcado como Resposta Fagner SN quarta-feira, 14 de janeiro de 2015 00:54
    quarta-feira, 7 de janeiro de 2015 11:13
  • Bom dia Fagner tudo bem ? Pode ser que realmente tenha um Bug nessa estrutura de replicação, onde tem banco de dados SQL com site remoto. Mas pra efeito de teste tente iniciar a cópia inicial pela Rede, uma vez que vc tem conexão entre os sites. Mesmo que demore um pouco, veja como se comportará nesse primeiro processo.

    Tratando-se de um site remoto tente a possibilidade de utilizar o protocolo 443 Criando um certificado digital. Mesmo que de um pouco mais de trabalho inicialmente.

    http://social.technet.microsoft.com/wiki/pt-br/contents/articles/12828.windows-server-2012-configurando-o-hyper-v-replica-em-grupo-de-trabalho-sem-dominios.aspx


    João Carlos Xavier de Macedo Specialist Platforms Microsoft MCP,MCT,MCSA,MCTS,MCITP, ENTERPRISE VIRTUALIZATION WINDOWS SERVER 2008 R2,MCSE WINDOWS SERVER 2012


    • Editado Joao Macedo quarta-feira, 7 de janeiro de 2015 12:21 Link
    quarta-feira, 7 de janeiro de 2015 12:17
  • Quando existem problemas de timeout com o uso do recurso Hyper-V Replica você precisa pensar um pouco mais além.

    Este tipo de erro não está somente relacionado ao enlace de dados que interliga os sites, mas também com a conexão entre o host Hyper-V e o Storage, o que pode ser devido ao driver utilizado para gerenciar estas conexões. Há casos reconhecidos entre servidores e Storages DELL com o uso do DELL HitKit.

    Há relatos de que o número de Recovery Points (que é o número de snapshots disponíveis no Hyper-V Replica) pode também interferir e gerar este tipo de comportamento, então, verifique o número e reduza o mesmo para 1 ou 2 Recovery Points e teste novamente. Replication Settings > Recovery Points > Additional Recovery Points.

    Com relação ao enlace de dados que interliga os sites, você habilitou a compressão de dados para as VMs no momento em que você habilitou a replicação para verificar se o problema persiste?

    Como você mencionou que isto é algo eventual (de vez em quando...), você já verificou se não há nada concorrendo com o processo de replica no mesmo momento (backup por exemplo)?

    quarta-feira, 7 de janeiro de 2015 12:44
  • A questão de Kerberos ou HTTPS está correta?

    ___________________

    André Novello - Blog - MCP - MS - MCITP Virtualization  Administrator - MVP 2014 Hyper-V 

    quarta-feira, 7 de janeiro de 2015 12:55
  • João Estou utilizando uma CA  do Meu Domínio. o método de autentificação utilizado entre o hosts para replicação no site remoto e 443 com certificado digital e tudo. Está Funcionando perfeitamente. ]

    Outro Ponto eu não uso storage Cada Host armazena as Vms seus seus discos Loais. então descarto essa possibilidade. 

    Outro Ponto e impossível exportar a Carga Inicial Pela Rede visto que essa VM tem 190GB não há link que suporte transferir isso. Por eu exporto para um HD Externo.

    Outro Ponto eu cheguei a pensar que fosse o backup mais Desativei todos os Backups do Windows Server e aconteceu.

    quarta-feira, 7 de janeiro de 2015 13:44
  • Tem Vários usuários encontrando problemas também.

    https://social.technet.microsoft.com/Forums/en-US/a5e6b6b7-becd-4b05-9976-1634357727da/hyperv-2012-replica-giving-timeouts?forum=winserverhyperv

    Sinceramente acho que o recurso de replica do Hyper-v precisar ser muito aperfeiçoado próximo aos melhores players do Mercado no que diz respeito a esse recurso.

    quarta-feira, 7 de janeiro de 2015 13:48
  • Bom dia Fagner,

    Uma duvida o link que tem na thread que marcou lhe ajudou como resposta ? Vi que tem um passo a passo explicando o que fazer e os possíveis troubleshoot a serem executados caso tenha erro.

    Abraços


    Matheus Leopardi Mello Canelada Campos

    Esse conteudo e fornecido sem garantias de qualquer tipo, seja expressa ou implicita.

    TechNet Community Support

    Por favor, lembre-se de Marcar como Resposta as respostas que resolveram o seu problema. Essa e uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais facil para os outros visitantes encontrarem a resolusao mais tarde.

    quinta-feira, 8 de janeiro de 2015 11:49
  • Está usando VSS lá em Adicional Points pra fazer essa cópia?

    sábado, 10 de janeiro de 2015 16:15
  • Algum dos posts neste tópico ajudou a resolver o seu problema ou respondeu a sua pergunta? Nós gostaríamos de fechar este tópico, se possível, mas queremos ter certeza de que você recebeu uma resposta satisfatória. Por favor, marque o post adequado como resposta clicando no botão "Marcar como Resposta" ou responda-nos avisando que nenhum dos posts resolveu o seu problema. Obrigado.

    Matheus Leopardi Mello Canelada Campos

    Esse conteudo e fornecido sem garantias de qualquer tipo, seja expressa ou implicita.

    TechNet Community Support

    Por favor, lembre-se de Marcar como Resposta as respostas que resolveram o seu problema. Essa e uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais facil para os outros visitantes encontrarem a resolusao mais tarde.

    segunda-feira, 12 de janeiro de 2015 16:02
  • Não cheguei a solução mais marquei um resposta que agregou mais conhecimento a ser aplicado.
    quarta-feira, 14 de janeiro de 2015 00:55