none
Lentidão na inicialização de VMs RRS feed

  • Pergunta

  • Olá Senhores,

    Tenho um Hyper-V instalado num WS2008 Server Core Enterprise x64 com 2 placas de rede.

    Criei uma rede virtual associada à segunda placa de rede, utilizada apenas pelas VMs.

    Durante a inicialização da VM e após o logon, deixei um ping -t na VM, pois achei muito lento.

    Pois bem, durante a inicialização e durante o processamento do logon (aplicando configurações do usuário), me deparei com muitas perdas de pacote (Esgotado o tempo limite do pedido) e também algumas respostas com o tempo muito alto (acima de 1000ms).

    Quando o logon do usuário termina de ser processado, a resposta do ping volta ao normal e fica em 1ms, normal numa rede LAN.

    Podem me ajudar a diagnosticar o problema ?

    Obrigado.


    Paul Haro - Microsoft Certified Professional
    quarta-feira, 19 de outubro de 2011 18:39

Respostas

  • Amigo,

    Desabilita o TCP Chimmey Offload e seja feliz!

    http://support.microsoft.com/kb/951037

     

    Essas placas sempre dão esse erro. Elas vem com a informação que suportam o TCP Offload, mas na verdade não funciona.


    Se foi útil marca como resposta! _________________________________________________ Rafael Bernardes - It Hero 2009 Award Microsoft Certified Technology Specialist rafael@bernardes.org http://blog.bernardes.org 21 8162-3956 21 7894-5536
    • Marcado como Resposta Paul Haro quinta-feira, 20 de outubro de 2011 13:37
    quinta-feira, 20 de outubro de 2011 02:02
  • Paulo,

    faça isso que o meu amigo Rafael disse.

    Por ser um controlador de ethernet genérico, irá melhorar essa perda. 

    E nós reporte.

    [ ]'s


    ITIL V3 Foundations | http://guilhermemaia.org
    • Marcado como Resposta Paul Haro quinta-feira, 20 de outubro de 2011 13:37
    quinta-feira, 20 de outubro de 2011 10:33
  • Senhores,

    Funcionou !!! PQP !!! O desempenho ficou fantástico !!

    No meu caso, meu WS 2008 é a versão Core.

    Tive que executar o seguinte procedimento:

    - Através de outro Servidor, conectei remotamente no registro do meu Host Hyper-V e alterei os seguintes parâmetros:

    HKLM\System\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002BE10318}\0000

    *IPChecksumOffloadIPv4 -> Alterei o valor para 0 (zero)

    *LsoV1IPv4 -> -> Alterei o valor para 0 (zero)

    *TCPChecksumOffloadIPv4 -> Alterei o valor para 0 (zero).

    ---

    Com base nas informações que vocês me passaram, encontrei o seguinte link informando as alterações:

    http://social.technet.microsoft.com/Forums/en-US/windowsserver2008r2virtualization/thread/8aeb63b7-e368-457d-bd41-fe55d0caded4

    Agradeço muito a ajuda de vocês, Guilherme e Rafael !!!

    Abs.

     


    Paul Haro - Microsoft Certified Professional
    • Marcado como Resposta Paul Haro quinta-feira, 20 de outubro de 2011 13:38
    quinta-feira, 20 de outubro de 2011 13:37

Todas as Respostas

  • Paulo,

    Veja se Integration Services está instalado corretamente na VM.

    Maiores informações: http://technet.microsoft.com/en-us/library/cc732470(WS.10).aspx#BKMK_step4

    E nós reporte.

     


    ITIL V3 Foundations | http://guilhermemaia.org
    quarta-feira, 19 de outubro de 2011 18:51
  • Olá Guilherme,

    Na configuração da VM, consta como instalado. Todas as opções estão instaladas.

    Mesmo assim, rodei novamente e reiniciei a VM.

    Após o logon, fui até o painel de controle e entrei no Windows Update.

    Só de mandar procurar atualizações, ocorreu o mesmo problema.

    O mesmo problema ocorre quando dou um "\\" na maquina virtual, à partir do meu notebook. O ping -t no servidor hyper-v não apresenta nenhum problema. A comunicação funciona perfeitamente.

    Obrigado.


    Paul Haro - Microsoft Certified Professional
    • Editado Paul Haro quarta-feira, 19 de outubro de 2011 19:23 erro digitação
    quarta-feira, 19 de outubro de 2011 19:19
  • Paulo,

    De qualquer forma desinstale e desligue a VM e instale novamente, se mesmo assim não funcionar..

    - Que S.O que está instalado na VM?
    - Todos o drivers estão instalando corretamente no HOST Server Core? principalmente o de rede?
    - Que tipo de rede você está atribuindo nesta VM? Network Adpater? ou Legacy Network Adapter?

    Estou no aguardo das respostas

    [ ]'s

     


    ITIL V3 Foundations | http://guilhermemaia.org
    quarta-feira, 19 de outubro de 2011 19:29
  • Olá Guilherme,

    Eu executei este procedimento e o problema persiste.

    - Instalei o WS2008 Enterprise R2 x64 na VM.

    - Os drivers estão atualizados e as atualizações do Windows Update estão em dia. A placa de rede do Host é uma Broadcom NetXtreme Gigabit Ethernet

    - Onde eu confirmo esta opção de Network Adapter ou Legacy Network Adapter ?

    Na configuração de rede da VM, consta o nome da rede que eu associei ao adaptador externo.

    Obrigado pela ajuda.


    Paul Haro - Microsoft Certified Professional
    quarta-feira, 19 de outubro de 2011 19:49
  • Paulo,

    se estão todos instalados ta tudo bem.

    Para verificar se Legacy Network Adapter veja no print abaixo.

    OBS: O uso Legacy Network somente é recomendado para VMs que não possuam suporte a instalação do
    Integration Services ou em casos de uso de PXE em máquinas virtuais. No caso do PXE, no qual um sistema é
    inicializado através da rede antes do boot do sistema operacional, o driver da placa Legacy é o único driver
    de rede inicializado no momento do boot, tornando-a a única placa com suporte ao uso de PXE.

    [ ]'s


    ITIL V3 Foundations | http://guilhermemaia.org
    quarta-feira, 19 de outubro de 2011 20:04
  • Oi Guilherme,

    No meu caso, está como "Adaptador de rede". Pelo visto não é o Legacy.

    Pelo Gerenciador do Hyper-V funciona corretamente.  Pelo TS, devido à perda de pacotes, a conexão é sofrível. A cada clique, pacotes são perdidos.

    Minhas placas de rede:

    - Broadcom (On-board) para o Host Hyper-V. Acabei de baixar e atualizar o driver com a versão mais recente.

    - Controlador Ethernet generico baseado no Marvel Yukon 88E8053 (off-board) para as VMs.

    A opção "permitir que o sistema operacional de gerenciamento compartilhe este adaptador de rede" está habilitada.

     

    Obrigado.

     


    Paul Haro - Microsoft Certified Professional

     


    • Editado Paul Haro quarta-feira, 19 de outubro de 2011 20:24 imagem
    quarta-feira, 19 de outubro de 2011 20:19
  • Esta imagem mostra o que ocorre durante o logon:

    Obrigado.

     

     


    Paul Haro - Microsoft Certified Professional
    quarta-feira, 19 de outubro de 2011 20:32
  • Amigo,

    Desabilita o TCP Chimmey Offload e seja feliz!

    http://support.microsoft.com/kb/951037

     

    Essas placas sempre dão esse erro. Elas vem com a informação que suportam o TCP Offload, mas na verdade não funciona.


    Se foi útil marca como resposta! _________________________________________________ Rafael Bernardes - It Hero 2009 Award Microsoft Certified Technology Specialist rafael@bernardes.org http://blog.bernardes.org 21 8162-3956 21 7894-5536
    • Marcado como Resposta Paul Haro quinta-feira, 20 de outubro de 2011 13:37
    quinta-feira, 20 de outubro de 2011 02:02
  • Paulo,

    faça isso que o meu amigo Rafael disse.

    Por ser um controlador de ethernet genérico, irá melhorar essa perda. 

    E nós reporte.

    [ ]'s


    ITIL V3 Foundations | http://guilhermemaia.org
    • Marcado como Resposta Paul Haro quinta-feira, 20 de outubro de 2011 13:37
    quinta-feira, 20 de outubro de 2011 10:33
  • Bom dia senhores,

    Executei o comando netsh int tcp set global chimney = disabled

    Pelo que lí no documento, este comando desabilita a opção TCP Chimney Offload no Sistema Operacional.

    Estou pesquisando uma maneira de desabilitar esta opção na placa de rede generica (destinada para as VMs), visto que tenho o WS2008 Server Core.

    Assim que possível, postarei o resultado.

    Muito obrigado pela ajuda.


    Paul Haro - Microsoft Certified Professional
    quinta-feira, 20 de outubro de 2011 13:00
  • Senhores,

    Funcionou !!! PQP !!! O desempenho ficou fantástico !!

    No meu caso, meu WS 2008 é a versão Core.

    Tive que executar o seguinte procedimento:

    - Através de outro Servidor, conectei remotamente no registro do meu Host Hyper-V e alterei os seguintes parâmetros:

    HKLM\System\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002BE10318}\0000

    *IPChecksumOffloadIPv4 -> Alterei o valor para 0 (zero)

    *LsoV1IPv4 -> -> Alterei o valor para 0 (zero)

    *TCPChecksumOffloadIPv4 -> Alterei o valor para 0 (zero).

    ---

    Com base nas informações que vocês me passaram, encontrei o seguinte link informando as alterações:

    http://social.technet.microsoft.com/Forums/en-US/windowsserver2008r2virtualization/thread/8aeb63b7-e368-457d-bd41-fe55d0caded4

    Agradeço muito a ajuda de vocês, Guilherme e Rafael !!!

    Abs.

     


    Paul Haro - Microsoft Certified Professional
    • Marcado como Resposta Paul Haro quinta-feira, 20 de outubro de 2011 13:38
    quinta-feira, 20 de outubro de 2011 13:37
  • Paulo,

    Que bom que funcionou.

    Eu que agradeço ( :

    Precisando estamos a disposição.

    [ ]'s


    ITIL V3 Foundations | http://guilhermemaia.org
    quinta-feira, 20 de outubro de 2011 14:33