none
Lentidão ao acessar o Windows Server 2003 a partir do Windows7 RRS feed

  • Pergunta

  • Estou com alguns servidores Windows 2003 apresentando lentidão quando acessados a partir de estações Windows7. O acesso a console destes servidores é normal, estes mesmos servidores quando acessados a partir de estações Xp são normais ou ainda quando acessados a partir de outras win2003 também são normais. A lentidão é apresentada somente quando acessadas de estações windows7. Já criei uma máquina do zero para descartar problemas na imagem e o problema persiste. Alguém sabe dizer se existe alguma correção para este tipo de problema?
    segunda-feira, 12 de março de 2012 12:52

Respostas

  • Boa Tarde Nacarle,

    Vamos para mais um teste.

    No windows 7, execute o prompt do dos como administrador e digite este comando.

    netsh interface tcp set global autotuninglevel=disabled


    Só peço que não demore para responder, após 1 semana que você retornou.
     


    Rafael S. AMARAL
    U. P. Mackenzie



    • Editado Rafael S. AMARAL segunda-feira, 19 de março de 2012 20:52
    • Sugerido como Resposta Rafael S. AMARAL segunda-feira, 26 de março de 2012 11:38
    • Marcado como Resposta Nacarle segunda-feira, 26 de março de 2012 13:52
    segunda-feira, 19 de março de 2012 20:40
  • Boa Tarde,

    Ele desativa essa função autotuninglevel.

    Obs: esqueci de informar, quando executar o comando de disable, reinicie a máquina em seguida.

    Não esqueça de executar com a opção run as administrator o prompt do dos.


    Antes de você executar, faça outro comando e printa a tela:

    netsh interface tcp show global

    Provavelmente irá aparecer uma linha:

    Nível de Autoajuste da Janela de Recepção   : normal


    O primeiro comando que te passei irá desativar essa função.


    Dica: Delete print do registro, já que contém informações da empresa. Quando você for printar e tiver dados como nome da empresa, etc.....  apague esses dados. Aparentemente o registro está ok.!



    Ficamos no aguardo.


    Rafael S. AMARAL
    U. P. Mackenzie




    • Editado Rafael S. AMARAL quarta-feira, 21 de março de 2012 18:11
    • Sugerido como Resposta Rafael S. AMARAL segunda-feira, 26 de março de 2012 11:38
    • Marcado como Resposta Nacarle segunda-feira, 26 de março de 2012 13:51
    quarta-feira, 21 de março de 2012 18:06
  • Nada :(
    • Marcado como Resposta Nacarle sexta-feira, 23 de março de 2012 14:52
    segunda-feira, 19 de março de 2012 20:28

Todas as Respostas

  • Nacarle,

    Verifique se nas Configurações de IP o DNS está com o IP do Servidor de DNS. Caso não esteja coloque.

    Em seguida verifique se o Windows 7 está encontrando o DNS Server com o comando "nslookup". Verifique se o IP que aparece no Prompt de Comando é o IP do Servidor de DNS de sua rede mesmo.

    Abraços!


    Caso a resposta tenha lhe atendido, favor marcar como resposta. Assim os próximos que estiverem com a duvida será facilmente sanada e se possível, marcar como util, caso aplicável. Abraços! Matheus Sanches

    segunda-feira, 12 de março de 2012 13:37
  • Oi Matheus,

    Acho que não fui tão clara, o DNS está certinho sim. O problema não é nem ao conectar via MSTSC, o problema é após a conexão estabelecida, os servidores ficam impróprios para trabalho. Lentos ao clicar em qualquer coisa.

    Obrigada pela ajuda!

    terça-feira, 13 de março de 2012 15:03
  • Bom dia Nacarle,

    Espero que isso ajude.

    1. Executar e digite "appwiz.cpl" e enter   (appwiz.cpl é um atalho para o Adicionar e Remover programas)

    2. Clique em Ativar ou Desativar recursos do Windows
    3. Desmarque a opção Compactação Diferencial Remota.
    4. Clique em OK.



    Rafael S. AMARAL
    U. P. Mackenzie





    • Editado Rafael S. AMARAL quinta-feira, 15 de março de 2012 18:10
    • Marcado como Resposta Richard Juhasz segunda-feira, 19 de março de 2012 12:37
    • Não Marcado como Resposta Nacarle segunda-feira, 19 de março de 2012 20:19
    terça-feira, 13 de março de 2012 15:32
  • Nacarle,

    Verifique no "Gerenciador de Tarefas do Windows" se existe algo que esteja utilizando o processador/memoria. Caso tenha algum processo com grande consumo de processamento/memoria, nos informe o Nome e Usuario que é proprietario do mesmo.

    Verifique também, na inicialização do Windows se não existe muitos processos a serem carregados. Para isso siga os seguintes passos:

    1º Vá no "Iniciar";
    2º Vá no "Executar...";
    3º Digite "msconfig";
    4º Vá na aba "Inicialização";
    5º Verifique o que é realmente necessario e desmarque os demais.
    6º Clique em "OK";
    7º Faça logoff e se necessario reinicie o servidor.

    Caso seja uma VM, verifique na maquina virtual o desempenho e na maquina local.

    Verifique também, se existe algum evento no Eventviewer que esta com erro.

    Abraços!


    Caso a resposta tenha lhe atendido, favor marcar como resposta. Assim os próximos que estiverem com a duvida será facilmente sanada e se possível, marcar como util, caso aplicável. Matheus Sanches

    • Marcado como Resposta Richard Juhasz segunda-feira, 19 de março de 2012 12:37
    • Não Marcado como Resposta Nacarle segunda-feira, 19 de março de 2012 20:18
    terça-feira, 13 de março de 2012 15:37
  • Bom dia,

    novidades?

    Att,


    Fabiano Barreira

    MCP + MCDST + MCSA & MCSE on Windows Server 2003 + MCTS + MCITP
    Blog - http://fabianobarreira.wordpress.com

    quinta-feira, 15 de março de 2012 09:38
  • Oi Rafael,

    Me perdoem a demora, mas ainda não resolvi meu problema. Este procedimento deve ser feito na estação Win7, correto? Se sim, não funcionou.

    Conforme já citei, anteriormente pensei ser um problema nas imagens dos desktops, mas ao instalar uma máquina Win7 da mídia, vi que o problema é no 2003 mesmo. Deve existir algum bug :(


    • Editado Nacarle segunda-feira, 19 de março de 2012 20:25
    segunda-feira, 19 de março de 2012 20:25
  • Então Matheus, o problema não são nos servidores. Tipo, estou com dois 2003 mais críticos e ambos apresentam lentidão se acessados a partir de win7. Nas estações XP ou mesmo de outras 2003, está uma "bala".

    Via console também o servidor está com um tempo de resposta normal, este procedimento eu já havia feito antes.

    Obrigada como sempre!

    segunda-feira, 19 de março de 2012 20:27
  • Nada :(
    • Marcado como Resposta Nacarle sexta-feira, 23 de março de 2012 14:52
    segunda-feira, 19 de março de 2012 20:28
  • Boa Tarde Nacarle,

    Vamos para mais um teste.

    No windows 7, execute o prompt do dos como administrador e digite este comando.

    netsh interface tcp set global autotuninglevel=disabled


    Só peço que não demore para responder, após 1 semana que você retornou.
     


    Rafael S. AMARAL
    U. P. Mackenzie



    • Editado Rafael S. AMARAL segunda-feira, 19 de março de 2012 20:52
    • Sugerido como Resposta Rafael S. AMARAL segunda-feira, 26 de março de 2012 11:38
    • Marcado como Resposta Nacarle segunda-feira, 26 de março de 2012 13:52
    segunda-feira, 19 de março de 2012 20:40
  • Caso não funcione e para ganharmos tempo.

    Printa o resultado da chave a seguir:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters



    Modelo da placa de rede também.


    Rafael S. AMARAL
    U. P. Mackenzie


    • Editado Rafael S. AMARAL segunda-feira, 19 de março de 2012 20:46 Placa de rede
    segunda-feira, 19 de março de 2012 20:44
  • Boa Tarde Nacarle,


    Alguma novidade?


    Rafael S. AMARAL
    U. P. Mackenzie


    terça-feira, 20 de março de 2012 19:06
  • Boa tarde Rafael,

    O que este comando irá fazer?

    quarta-feira, 21 de março de 2012 16:09
  • Ah, o modelo da placa de rede: Intel(R) 82567LM-3 Gigabiy Network Connection
    quarta-feira, 21 de março de 2012 16:11
  • Boa Tarde,

    Ele desativa essa função autotuninglevel.

    Obs: esqueci de informar, quando executar o comando de disable, reinicie a máquina em seguida.

    Não esqueça de executar com a opção run as administrator o prompt do dos.


    Antes de você executar, faça outro comando e printa a tela:

    netsh interface tcp show global

    Provavelmente irá aparecer uma linha:

    Nível de Autoajuste da Janela de Recepção   : normal


    O primeiro comando que te passei irá desativar essa função.


    Dica: Delete print do registro, já que contém informações da empresa. Quando você for printar e tiver dados como nome da empresa, etc.....  apague esses dados. Aparentemente o registro está ok.!



    Ficamos no aguardo.


    Rafael S. AMARAL
    U. P. Mackenzie




    • Editado Rafael S. AMARAL quarta-feira, 21 de março de 2012 18:11
    • Sugerido como Resposta Rafael S. AMARAL segunda-feira, 26 de março de 2012 11:38
    • Marcado como Resposta Nacarle segunda-feira, 26 de março de 2012 13:51
    quarta-feira, 21 de março de 2012 18:06
  • Este é o primeiro comando solicitado.
    sexta-feira, 23 de março de 2012 15:02
  • Desabilitei e reiniciei, vou testar..
    sexta-feira, 23 de março de 2012 15:02
  • Bom dia Nacarle,

    Alguma novidade?

    Você fechou o post.


    Rafael S. AMARAL
    U. P. Mackenzie


    sexta-feira, 23 de março de 2012 15:11
  • Caramba, funcionou! Show de bola!!! :)

    Agora eu gostaria de saber qual o impacto desse "disable" nas estações. No caso, consegui na minha, mas gostaria de replicar este feito nas estações da equipe.

    Mais uma vez, obrigada!

    sexta-feira, 23 de março de 2012 22:16
  • Nacarle,

    Favor marcar como resposta a que lhe foi util e também votar como util.

    Assim iremos ajudas aos proximos que necessitarem

    Abraços!


    Caso a resposta tenha lhe atendido, favor marcar como resposta. Assim os próximos que estiverem com a duvida será facilmente sanada e se possível, marcar como util, caso aplicável. Matheus Sanches

    • Marcado como Resposta Nacarle segunda-feira, 26 de março de 2012 12:08
    • Não Marcado como Resposta Nacarle segunda-feira, 26 de março de 2012 13:54
    sexta-feira, 23 de março de 2012 22:31
  • Bom dia Matheus/ Rafael,

    Já marquei como resposta, gostaria apenas de saber o impacto desse "disable" na minha estação. Para eu fazer essa configuração nas demais estações, como faria? Minha preocupação é ao desabilitar este recurso, qual o impacto.

    Agradeço antecipadamente.

    segunda-feira, 26 de março de 2012 12:11
  • Bom dia Nacarle,

    Marque como resposta o que lhe foi útil, você marcou a resposta do Matheus (No caso não é essa que você tem que marcar como resposta). Eu coloquei como Propor como resposta a qual voce deve marcar.

    Em seguida te informo as demais dúvidas.


    Rafael S. AMARAL
    U. P. Mackenzie



    segunda-feira, 26 de março de 2012 12:16
  • Pronto! Me desculpe, mas na realidade tive que marcar as duas como resposta. Pois uma complementava a outra.

    Agora por favor me avisa qual o impacto deste disable.

    Obrigada!

    segunda-feira, 26 de março de 2012 13:53
  • Bom dia Nacarle,


    Que bom que funcionou! Marque como útil a resposta.



    Na verdade o que foi realizado, foi desabilitar o autotuninglevel que tem como função dimensionar a pilha TCP para maximizar o desempenho da rede.
    Ele mede os produtos que atrasam a largura de banda e as taxas de recuperação do aplicativo. Em seguida, o recurso Auto-Ajuste da Janela de Recepção adapta
    o tamanho da janela de recepção da transmissão contínua para aproveitar toda a largura de banda não utilizada. (Isso que provoca a lentidão).


    O impacto disso é caso você tenha algum dispositivo ANTIGO (como roteador, switch, etc...) pode causar lentidão na rede. Mas na minha opinião muito dificil acontecer.


    Outro ponto, caso você faça esse comando nas máquinas e depois você verifica alguma lentidão na rede, para habilitar o autotuninglevel, você faça o mesmo procedimento, mas com o
    seguinte comando:

    netsh interface tcp set global autotuninglevel=normal


    Para aplicar para os demais computadores, faça via GPO, abra um bloco de notas e copie o comando do disable e salva com a extensão .bat


    E nas sua próximas imagens você ja corrige fazendo este comando antes de fazer o ghost, ou outro software.






    Caso tenha mais dúvidas nos informe que tentamos esclarecer.





    Rafael S. AMARAL
    U. P. Mackenzie




    segunda-feira, 26 de março de 2012 13:56
  • Obrigada como sempre Rafael!

    Pensando bem vou efetuar somente na estação de quem reclamar. :)

    segunda-feira, 26 de março de 2012 15:59
  • Muito bom, resolveu o meu problema também, antes não tinha encontrado outra solução a não ser alterar as estações para windows xp.

    1-Mas pode me esclarecer, é necessário que eu retorne o autotuninglevel para normal?

    2-Posso aplicar como gpo para toda Rede, vai ter impacto nas estações com XP?

    ou apenas crio o grupo de estações com windows 7?

    quarta-feira, 25 de abril de 2012 12:29
  • Boa Noite Marcus,

    1- Mas pode me esclarecer, é necessário que eu retorne o autotuninglevel para normal?

    Sinceramente, não vejo o porque voltar o autotuninglevel para normal, pois o impacto é muito baixo. Isso deve ser alguma funcionalidade da Microsoft pensando que poderia ajudar em algo, mas que para algumas pessoas acabou não ajudando (justamente por esse fato de lentidão). 



    2-Posso aplicar como gpo para toda Rede, vai ter impacto nas estações com XP?
    Nunca apliquei no XP, então não sei se funciona, mas o que você pode fazer caso as máquinas Windows XP e 7 estejam na mesma OU é utilizar filtros WMI.


    Filtro WMI você configura informando que na OUxxxxxx só execute a GPO para máquinas por exemplo que são 7 e se tiver XP, a máquina não executa a GPO.
    http://technet.microsoft.com/pt-br/library/cc779036(v=ws.10).aspx   



    Espero que tenha te ajudado.


    Rafael S. AMARAL
    U. P. Mackenzie



    quinta-feira, 26 de abril de 2012 00:13
  • Rafael já obtive solução mas vou dar mais corda pelo porque esse problema ocorre.

    Aqui na empresa temos 3 servidores com Windows Server 2003.

    Porque será que a lentidão ocorreu no acesso a apenas a um servidor.

    quinta-feira, 26 de abril de 2012 13:33