none
FORMULA RRS feed

  • Pergunta

  • Minha dúvida é a seguinte:

    Quando envio um comando de formula do VBA para o Excel dá erro. Exemplo

    Sheets(“Plan1”).Cells(1,1).Formula=”=SE(A1>0;1;2)”

    Em outros casos funciona. Exemplo:

    Sheets(“Plan1”).Cells(2,1).Formula=”=ALEATÓRIO()”

    domingo, 1 de abril de 2018 10:12

Todas as Respostas

  • Renato, para usar ".Formula" deve traduzir o nome das funções para inglês, também trocando de ";" para ",". No seu caso:

    Sheets("Plan1").Cells(1, 1).Formula = "=if(A1>0,1,2)"

    Obs.: quando copiei sua expressão as suas aspas foram reconhecidas como outro caractere (ASC 148 e mão ASC 34), o que por si só já geraria erro.


    Filipe Magno

    domingo, 1 de abril de 2018 22:58