none
Outlook e certificado Wildcard RRS feed

  • Pergunta

  • Pessoal instalei um certificado Wildcard no exchange 2010 e o problema de certificado do OWA acabou porem quando o acesso é pelo Microsoft outlook esta aparecendo um erro de certificado. O acesso interno é empresa.local e o certificado é empresa.com.br. antes tudo funcionava perfeitamente com um certificado emitido por uma Ca interna. Alguem pode me dar uma ajuda??
    Bryan analista de suporte Jr
    quinta-feira, 22 de dezembro de 2011 13:43

Respostas

  • Bryan, já conferiu se o parâmetro CertPrincipalName do msExchAutoDiscoverConfig está como *.domain.corp ???

    Confira: Get-OutlookProvider

    Corrija: Set-OutlookProvider -Identity EXPR -CertPrincipalName *.contoso.com

    Referência: http://technet.microsoft.com/en-us/library/cc535023(EXCHG.80).aspx ;)


    Evolving!

    quinta-feira, 22 de dezembro de 2011 16:57
  • http://technet.microsoft.com/pt-br/library/aa996819.aspx

    Get-AutodiscoverVirtualDirectory |fl e verifica se as configurações de URL interna e externa estão de acordo.


    "Eu nunca vi nada selvagem ter pena de si mesmo, um pássaro vai cair morto de um galho, sem jamais ter sentido pena de si mesmo."
    • Marcado como Resposta Bryan Suporte sexta-feira, 23 de dezembro de 2011 21:14
    sexta-feira, 23 de dezembro de 2011 19:44
    Moderador

Todas as Respostas

  • Bryan, já conferiu se o parâmetro CertPrincipalName do msExchAutoDiscoverConfig está como *.domain.corp ???

    Confira: Get-OutlookProvider

    Corrija: Set-OutlookProvider -Identity EXPR -CertPrincipalName *.contoso.com

    Referência: http://technet.microsoft.com/en-us/library/cc535023(EXCHG.80).aspx ;)


    Evolving!

    quinta-feira, 22 de dezembro de 2011 16:57
  • A dica não resolveu meu problema continua o erro.


    Bryan analista de suporte Jr
    quinta-feira, 22 de dezembro de 2011 23:13
  • Alguem conseguiu implementar com WildCard sem esse problema?? vi em outros forum que apenas Certificados SAN podem ser utilizados para exchange e que Wildcard realmente geram esse tipo de problema.

     

     


    Bryan analista de suporte Jr
    sexta-feira, 23 de dezembro de 2011 12:57
  • Bryan,

    a URL que o usuário utiliza está batendo com *.domain.com no OutlookProvider. Dê um Get-OutlookProvider EXPR para conferir.

    Segue referência no histórico: http://social.technet.microsoft.com/Forums/en-US/exchangesvrclients/thread/cf954549-1b7d-4e75-a9bd-4163c41e8542/

    ;)


    Evolving!
    sexta-feira, 23 de dezembro de 2011 14:16
  • verifica nas configurações do Outlook AnyWhere que deve ter sido aplicada automaticamente pelo autodiscover

    esta com o nome certo do certificado. Uso certificado wildcard normalmente nos ambientes que administro.


    "Eu nunca vi nada selvagem ter pena de si mesmo, um pássaro vai cair morto de um galho, sem jamais ter sentido pena de si mesmo."
    sexta-feira, 23 de dezembro de 2011 17:21
    Moderador
  • sim apos executar o comando sugerido por voce passou a aparecer antes não tinha, poremo o problema não foi corrigido. Tambem tentei o comando com o "msstd"

    set-OutlookProvider -id EXPR -Server "[servername]" -CertPrincipalName "msstd: *.domain.com"


    Bryan analista de suporte Jr
    • Editado Bryan Suporte sexta-feira, 23 de dezembro de 2011 19:20
    sexta-feira, 23 de dezembro de 2011 18:51
  • http://technet.microsoft.com/pt-br/library/aa996819.aspx

    Get-AutodiscoverVirtualDirectory |fl e verifica se as configurações de URL interna e externa estão de acordo.


    "Eu nunca vi nada selvagem ter pena de si mesmo, um pássaro vai cair morto de um galho, sem jamais ter sentido pena de si mesmo."
    • Marcado como Resposta Bryan Suporte sexta-feira, 23 de dezembro de 2011 21:14
    sexta-feira, 23 de dezembro de 2011 19:44
    Moderador
  • as configurações internal e external url estão em branco.
    Bryan analista de suporte Jr
    sexta-feira, 23 de dezembro de 2011 20:18
  • configura de acordo com sua estrutura e testa.
    "Eu nunca vi nada selvagem ter pena de si mesmo, um pássaro vai cair morto de um galho, sem jamais ter sentido pena de si mesmo."
    sexta-feira, 23 de dezembro de 2011 20:33
    Moderador
  • Funcionou a url interna não estava configurada

    Obrigado Deivid Foggi e Felipe Feydit graças as suas repostas consegui resolver o problema.

    Feliz natal pra voces.

                                       

    Bryan analista de suporte Jr
    sexta-feira, 23 de dezembro de 2011 21:14
  • show,

    Feliz Natal !


    "Eu nunca vi nada selvagem ter pena de si mesmo, um pássaro vai cair morto de um galho, sem jamais ter sentido pena de si mesmo."
    sexta-feira, 23 de dezembro de 2011 21:44
    Moderador