locked
Caixa de Dialogo com erro - O valor não recai ao intervalo esperado RRS feed

  • Discussão Geral

  • Olá Pessoal!<o:p></o:p>

     

    Estou utilizando o Windows server 2012 r2 e tentando utilizar a ferramenta de replicação DFS, porem ao tentar criar um Grupo de Replicação e adicionar o nome do grupo do de replicação clico na opção avançar, quando vou adicionar novos servidores para ser membro do grupo de replicação clico no botão Adicionar e a caixa de diálogo “O valor não recai ao intervalo esperado” surge impossibilitando seguir com o procedimento.<o:p></o:p>

    Observei que esse erro surge após executar todos Windows Update disponíveis até 01/08/2017. Outras opções do Windows que exige a mesma caixa de diálogo o erro também surge impossibilitando de executar a ação.<o:p></o:p>

    Segue imagem do erro abaixo:<o:p></o:p>

    Att,


    quarta-feira, 2 de agosto de 2017 12:26

Todas as Respostas

  • Olá a todos.

    Estou com o mesmo erro problema no DFSR e meu cenário é o mesmo que o seu. Caso a comunidade tenha alguma dica, seria útil.

    Att,

    sábado, 26 de agosto de 2017 13:53
  • No momento estou com o mesmo problema no DFSR e meu cenário é o com Windows Server 2016 Standard.

    terça-feira, 29 de agosto de 2017 19:43
  • Prezados consegui hoje resolver esse problema. E espero que ajude a você e todos da comunidade. Esse problema ocorre porque nas atualizações feitas no seu servidor foi instalado o net framework 4.7. Basta desinstalar o kb referente ao net framework 4.7, que varia de acordo com a versão do sistema operacional em ambos os servidores e o grupo de membros de replicação ocorrerá tranquilamente.

    Esse erro ocorre porque essa D3DCompiler_47.dll, não está presente no sistema operacional. 

    Agora caso queira ter o net framework 4.7 instalado, basta desintalar o kb, em seguida instalar o D3DCompiler_47.dll e em seguida instalar novamente o kb referente a sua versão.

    Abaixo segue explicação melhor. 

    Sobre o.NET Framework 4.7

    O Microsoft.NET Framework 4.7 é uma atualização e altamente compatível no local para o Microsoft.NET Framework 4, 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1 e 4.6.2.

    Quando você instala esse pacote Microsoft .NET Framework 4.7 , você pode ver a seguir pacotes ou atualizações que são instaladas por sistema operacional:

    • No Windows 7 SP1 e no Windows Server 2008 R2 SP1, ele estará listado como um produto instalado sob o item programas e recursos no painel de controle.
    • No Windows Server 2012, ele é listado como atualizar para o Microsoft Windows (KB3186505) sob o item de Atualizações instaladas no painel de controle.
    • Em Windows 8.1 ou o Windows Server 2012 R2, ele é listado como atualizar para o Microsoft Windows (KB3186539) sob o item de Atualizações instaladas no painel de controle.
    • No Windows 10 versão 1607, ele é listado como atualizar para o Microsoft Windows (KB3186568) sob o item de Atualizações instaladas no painel de controle.

    Observação:

    Os recursos do.NET Framework 4.7 WPF assumem uma dependência D3DCompiler_47.dll. Por padrão, este D3DCompiler_47.dll não está presente no Windows 7 SP1, Windows Server 2008 R2 SP1 ou Windows Server 2012. Portanto, essas plataformas requerem D3DCompiler_47.dll ser instalado para que os recursos do.NET Framework 4.7 WPF funcionam conforme o esperado.

    Você também pode ver a versão pelo regedit: hklm\software\Microsoft\Net framework setup\NDP\V4\full, ao clicar em full, do lado direito você verá uma chave com nome de "VERSION".

    Espero ter ajudado. abraços.

    sábado, 9 de setembro de 2017 02:46
  • Prezados consegui hoje resolver esse problema. E espero que ajude a você e todos da comunidade. Esse problema ocorre porque nas atualizações feitas no seu servidor foi instalado o net framework 4.7. Basta desinstalar o kb referente ao net framework 4.7, que varia de acordo com a versão do sistema operacional em ambos os servidores e o grupo de membros de replicação ocorrerá tranquilamente.

    Esse erro ocorre porque essa D3DCompiler_47.dll, não está presente no sistema operacional. 

    Agora caso queira ter o net framework 4.7 instalado, basta desintalar o kb, em seguida instalar o D3DCompiler_47.dll e em seguida instalar novamente o kb referente a sua versão.

    Abaixo segue explicação melhor. 

    Sobre o.NET Framework 4.7

    O Microsoft.NET Framework 4.7 é uma atualização e altamente compatível no local para o Microsoft.NET Framework 4, 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1 e 4.6.2.

    Quando você instala esse pacote Microsoft .NET Framework 4.7 , você pode ver a seguir pacotes ou atualizações que são instaladas por sistema operacional:

    • No Windows 7 SP1 e no Windows Server 2008 R2 SP1, ele estará listado como um produto instalado sob o item programas e recursos no painel de controle.
    • No Windows Server 2012, ele é listado como atualizar para o Microsoft Windows (KB3186505) sob o item de Atualizações instaladas no painel de controle.
    • Em Windows 8.1 ou o Windows Server 2012 R2, ele é listado como atualizar para o Microsoft Windows (KB3186539) sob o item de Atualizações instaladas no painel de controle.
    • No Windows 10 versão 1607, ele é listado como atualizar para o Microsoft Windows (KB3186568) sob o item de Atualizações instaladas no painel de controle.

    Observação:

    Os recursos do.NET Framework 4.7 WPF assumem uma dependência D3DCompiler_47.dll. Por padrão, este D3DCompiler_47.dll não está presente no Windows 7 SP1, Windows Server 2008 R2 SP1 ou Windows Server 2012. Portanto, essas plataformas requerem D3DCompiler_47.dll ser instalado para que os recursos do.NET Framework 4.7 WPF funcionam conforme o esperado.

    Você também pode ver a versão pelo regedit: hklm\software\Microsoft\Net framework setup\NDP\V4\full, ao clicar em full, do lado direito você verá uma chave com nome de "VERSION".

    Espero ter ajudado. abraços.

    sábado, 9 de setembro de 2017 02:46
  • Prezados consegui hoje resolver esse problema. E espero que ajude a você e todos da comunidade. Esse problema ocorre porque nas atualizações feitas no seu servidor foi instalado o net framework 4.7. Basta desinstalar o kb referente ao net framework 4.7, que varia de acordo com a versão do sistema operacional em ambos os servidores e o grupo de membros de replicação ocorrerá tranquilamente.

    Esse erro ocorre porque essa D3DCompiler_47.dll, não está presente no sistema operacional. 

    Agora caso queira ter o net framework 4.7 instalado, basta desintalar o kb, em seguida instalar o D3DCompiler_47.dll e em seguida instalar novamente o kb referente a sua versão.

    Abaixo segue explicação melhor. 

    Sobre o.NET Framework 4.7

    O Microsoft.NET Framework 4.7 é uma atualização e altamente compatível no local para o Microsoft.NET Framework 4, 4.5, 4.5.1, 4.5.2, 4.6, 4.6.1 e 4.6.2.

    Quando você instala esse pacote Microsoft .NET Framework 4.7 , você pode ver a seguir pacotes ou atualizações que são instaladas por sistema operacional:

    • No Windows 7 SP1 e no Windows Server 2008 R2 SP1, ele estará listado como um produto instalado sob o item programas e recursos no painel de controle.
    • No Windows Server 2012, ele é listado como atualizar para o Microsoft Windows (KB3186505) sob o item de Atualizações instaladas no painel de controle.
    • Em Windows 8.1 ou o Windows Server 2012 R2, ele é listado como atualizar para o Microsoft Windows (KB3186539) sob o item de Atualizações instaladas no painel de controle.
    • No Windows 10 versão 1607, ele é listado como atualizar para o Microsoft Windows (KB3186568) sob o item de Atualizações instaladas no painel de controle.

    Observação:

    Os recursos do.NET Framework 4.7 WPF assumem uma dependência D3DCompiler_47.dll. Por padrão, este D3DCompiler_47.dll não está presente no Windows 7 SP1, Windows Server 2008 R2 SP1 ou Windows Server 2012. Portanto, essas plataformas requerem D3DCompiler_47.dll ser instalado para que os recursos do.NET Framework 4.7 WPF funcionam conforme o esperado.

    Você também pode ver a versão pelo regedit: hklm\software\Microsoft\Net framework setup\NDP\V4\full, ao clicar em full, do lado direito você verá uma chave com nome de "VERSION".

    Espero ter ajudado. abraços.

    sábado, 9 de setembro de 2017 02:46
  • Eu também tenho um servidor Windows Server 2012 R2 e mesmo removendo essa atualização eu ainda recebo a mensagem do erro. Teve mais alguma coisa que precisou fazer para a resolução do problema?

    Grato!

    quarta-feira, 4 de outubro de 2017 13:56
  •  Estou implantando um projeto com DFS e também aqui está com o mesmo erro. E com o tutorial acima não resolve. 

    Pesquisando eu vi na internet um cara fazendo update do Direct  X. Enfim, eu fiz também esse update e resolveu momentaneo, consigo até adicionar o servidor primário mas o secundário não.

    Ao fechar o gerenciamento de dfs e abri-lo novamente o mesmo já não aceita adicionar o servidor primário.

    Se alguem tiver alguma outra solução, por favor nos informe!

    quinta-feira, 9 de novembro de 2017 13:06
  • Senhores (as), também tive o mesmo problema e este procedimento também não funcionou. Aparentemente a Microsoft ainda não lançou um KB para a resolução.

    A única forma que encontrei foi criar via PowerShell:

    New-DfsReplicationGroup -GroupName "Nome do Grupo de Replicação" | Add-DfsrMember -GroupName "Nome do Grupo de Replicação" -ComputerName "Servidor01", "Servidor02"

    Espero ter ajudado...

    Vlw
    quinta-feira, 9 de novembro de 2017 13:40
  • este procedimento nao funciona
    quinta-feira, 16 de janeiro de 2020 23:49