locked
Autenticar SMTP para Smatphone RRS feed

  • Pergunta

  •  

     Anderson Patricio - MVP wrote:

    Ola Leandro,

    Primeiramente é nao abrir o relay para os teus usuários da rede interna, somente para servidores de aplicacao que realmente necessitem e em alguns casos podes habilitar autenticacao no smtp para liberar o relay autenticado, com isto tu nao te preocupa com o tráfego interno.

    Em relaçao as black lists, vc pode estar com o relay aberto.. segue alguns links para te ajudar:

    http://www.andersonpatricio.org/Tutoriais/Tutoriais.asp?Tut=013

    E para configurar teus clientes internos por MAPI, segue o link:

    http://www.andersonpatricio.org/Tutoriais/Tutoriais.asp?Tut=209

     

     

    Boas Anderson;

     

     Segui o seu tutorial para o envio dos e-mails internos, mas agora meu cenário mudou, tenho 2 smartphones que precisam enviar mensagens via SMTP do servidor, gostaria que eles se autenticassem para poderem usar esse recurso mas não estou conseguindo configurar isso, vc tem alguma sugestão ?? Aqui temos um AJato com Ip dinâmico rodando sobre um dyndns o OWA perfeitamente.

     

    Obrigado;

     

    Luiz

    terça-feira, 18 de setembro de 2007 20:26

Respostas

  • Ola Luiz Orlandi,

     

    O problema é que as tuas configurações estao diferentes das originais, tu está configurado para relay aberto.

     

    De uma olhada neste tutorial:

    http://www.andersonpatricio.org/tutoriais/tutoriais.asp?tut=013

     

    Na lista de relay nao pode ter ninguém nemo teu exchange server, se tiver só algum servidor de aplicaçõa , mas nada além disso.

     

     

    Deixe exatamente como está neste tutorial comisto tu evita que os caras te usem como relay server. Na opção de baixo deixa marcado Allow all computers wich sucessfully

     

    Acredito que com isto estará funcionando.

    sexta-feira, 21 de setembro de 2007 14:27
  •  

    Ola Luiz,

     

    Quais configurações que colocaste no smartphone? Colocou nome de usuário e senha para autenticar no SMTP?

     

    Se tiver sem autenticaçao o smartphone, ferrou tu só vai conseguir mandar para usuarios locais, pq este é o design do protocolo smtp e consequentemente do exchange server.

     

    O teu log está pegando só os primeiros campos, por isto tu nao ve nada, tem que ir no smtp virtual server e adicionar os campos. Ai vai ficar mais fácil de tu enxergar o que realmente está ocorrendo.

     

    Cara nao toh vendo resposta dos teus posts Sad Tipo tu testou com o Outlook autenticado e funcionou?

     

    Na verdade tu nao tem um problema é comportamento padrao, só preciso saber onde tu está parando para dizer o que tu pode estar fazendo.

     

    abracao,

     

    terça-feira, 25 de setembro de 2007 18:51

Todas as Respostas

  • Anderson;

     

    Os smartphones estão pegando as mensagens via host, fazem o login com a senhas das contas do exchange e baixam as mensagens, a configuração do SMTP está como descrita no seu tutotial, somente excluindo o tick onde fala que somente as contas autenticadas podem fazer relay, ao invés disso, eu acrescentei os usuários liberados no botão que tem abaixo desse tick (não me lembro de cabeça o que está escrito no botão !!!)

     

    Obrigado;

     

    Luiz

    terça-feira, 18 de setembro de 2007 20:30
  • Ola Luiz Orlandi,

     

    Tudo blz? me passei.. pensei que tu tivesse j'a resolvido, a configuracao para aceitar o autenticado tem que estar marcado para tu poder passar usuario e senha no teu dispositivo e funcionar. Tem como marcar e testar?

     

     

     

    terça-feira, 18 de setembro de 2007 20:44
  • Boas Anderson;

     

     No final acabei deixando desmarcado e adivinhhhaaaaa ???, rsss, a galera enviou muitos spams através do servidor essa noite, bom, marquei e ainda não tive tempo de testar, descliquei o login anônimo tb só pra garantir....

     

     

     

     Jogo duro, viu !!!

     

    Abs;

     

    Luiz

    sexta-feira, 21 de setembro de 2007 14:15
  • Ola Luiz Orlandi,

     

    O problema é que as tuas configurações estao diferentes das originais, tu está configurado para relay aberto.

     

    De uma olhada neste tutorial:

    http://www.andersonpatricio.org/tutoriais/tutoriais.asp?tut=013

     

    Na lista de relay nao pode ter ninguém nemo teu exchange server, se tiver só algum servidor de aplicaçõa , mas nada além disso.

     

     

    Deixe exatamente como está neste tutorial comisto tu evita que os caras te usem como relay server. Na opção de baixo deixa marcado Allow all computers wich sucessfully

     

    Acredito que com isto estará funcionando.

    sexta-feira, 21 de setembro de 2007 14:27
  • Anderson;

     

     Já acertei as configurações e vou testá-las agora a tarde, mas acredito ter solucionado o problema, checando a funcionalidade marco o tópico como válido.

     

    Desde já agradeço a atenção e o empenho, seu site é ótimo, parabéns !!!

     

    Luiz

    sexta-feira, 21 de setembro de 2007 14:54
  • Anderson;

     

     As configurações que vc demonstra no seu tutorial foram feitas, mas não consigo fazer o smarthphne enviar, ele sempre me retorna um erro dizendo que não consegue enviar.

    Ali onde vc pede para mexermos em Connection Control, estou mantendo as configurações como o disposto, porém tenho dúvidas com relação ao primeiro botão "Acess Control", qdo se clica em authentication, a primeira opção, está marcada como "anounimous acess", qdo isso está tickado consigo enviar os e-mails, mas me preocupa, pois já tivemos problemas com o relay aberto, e não quero insistir nos erros.

     

    Obrigado;

     

    Luiz

    terça-feira, 25 de setembro de 2007 14:31
  • Ola Luiz Orlandi,

     

    Anonymous é obrigatório se vc deseja receber e-mails da internet. Mas tu temque fechar pelo relay senao volta o problema.

     

    este teu smartphone nao tem OMA ou ActiveSync nao? Smile

     

    O que deveria ser é: anonymous marcado, no relay tu nao permitir nenhuma maquina (igual ao tutorial de relay aberto) e a checkbox de usuarios autenticados poderem fazer relay estar marcado.

     

    Tu consegue fazer isto de uma maquina com outlook express? caso a resposa seja sim, e somente do dispositivo nao, é um problema local deste dispostiivo. Mas nao acredito que seja este o caso.

     

     

    terça-feira, 25 de setembro de 2007 14:38
  • Anderson;

     

     localmente via telnet, consigo conectar na porta 25 e mandar qq tipo de e-mail, até onde sei, isso é normal estando-se na rede interna, o que me preocupa é vindo de fora, vou estar em outro local durante a tarde e vou testar a conexão de uma rede externa.

     Quanto a Activesync, ainda não consegui fazer funcionar isso, ele até conecta, mas não sincroniza nada, a impressão que tenho é que a conexão cai antes dele começar a receber, porém prefiro resolver esse lance do SMTP antes.

     

     Obrigado pela atenção !!!

     

    Abs;

     

    Luiz

     

    terça-feira, 25 de setembro de 2007 15:14
  • Ola Luiz Orlandi,

     

    Teste de telnet tu vai testar o envio como anonymous nao é a mesma situaçao de envio autenticado. Me diz uma coisa, tu autentica neste dispositivo via smtp?

     

    ActiveSync no exchange ano tem muito o que fazer, mais é habilitar no teu firewall, mas isto é assunto para outro tópico.

     

    terça-feira, 25 de setembro de 2007 15:26
  •  

    Pois é Anderson;

     

     Pois é, eu consigo fazer o envio por telnet, como anonymous, coloquei as configurações no smartphone, mas ainda não entendi certinho os logs, e isso tá me deixando louco... dá uma olhadinha:

     

    14:49:38 200.169.124.136 EHLO - 250
    14:49:41 200.169.124.136 MAIL - 250
    14:49:41 200.169.124.136 RCPT - 250
    14:49:43 200.169.124.136 DATA - 250
    14:49:43 200.234.221.235 - - 0
    14:49:43 200.234.221.235 EHLO - 0
    14:49:43 200.234.221.235 - - 0
    14:49:43 200.234.221.235 AUTH - 0
    14:49:43 200.234.221.235 - - 0
    14:49:43 200.234.221.235 - - 0
    14:49:43 200.234.221.235 MAIL - 0
    14:49:43 200.234.221.235 - - 0
    14:49:43 200.234.221.235 RCPT - 0
    14:49:43 200.234.221.235 - - 0
    14:49:43 200.234.221.235 DATA - 0
    14:49:43 200.234.221.235 - - 0
    14:49:43 200.169.124.136 QUIT - 240

     

    15:01:38 192.168.0.172 RCPT - 250
    15:01:48 200.234.221.235 - - 0
    15:01:48 200.234.221.235 EHLO - 0
    15:01:48 200.234.221.235 - - 0
    15:01:48 200.234.221.235 AUTH - 0
    15:01:48 200.234.221.235 - - 0
    15:01:48 200.234.221.235 - - 0
    15:01:48 200.234.221.235 TURN - 0
    15:01:48 200.234.221.235 - - 0
    15:01:48 200.234.221.235 QUIT - 0

     

     Estou ficando sem saber mais o que fazer... aff...

     

     Obrigado pelo seu tempo, e desculpe a enxurrada de perguntas.

     

    Luiz.

    terça-feira, 25 de setembro de 2007 15:33
  •  

    Ola Luiz,

     

    Quais configurações que colocaste no smartphone? Colocou nome de usuário e senha para autenticar no SMTP?

     

    Se tiver sem autenticaçao o smartphone, ferrou tu só vai conseguir mandar para usuarios locais, pq este é o design do protocolo smtp e consequentemente do exchange server.

     

    O teu log está pegando só os primeiros campos, por isto tu nao ve nada, tem que ir no smtp virtual server e adicionar os campos. Ai vai ficar mais fácil de tu enxergar o que realmente está ocorrendo.

     

    Cara nao toh vendo resposta dos teus posts Sad Tipo tu testou com o Outlook autenticado e funcionou?

     

    Na verdade tu nao tem um problema é comportamento padrao, só preciso saber onde tu está parando para dizer o que tu pode estar fazendo.

     

    abracao,

     

    terça-feira, 25 de setembro de 2007 18:51
  •  

    Oi Anderson;

     

     obrigado pelas respostas, chequei agora de uma conexão externa, e realmente está funcionando, vou colar abaixo o log do telnet que fiz.... me parece ok agora !!!! eeeeeeeeeeeeeeeeee...

     

    220 greencapital.com.br Microsoft ESMTP MAIL Service, Version: 6.0.3790.3959 rea
    dy at  Tue, 25 Sep 2007 15:57:46 -0300
    helo
    250 greencapital.com.br Hello [200.204.126.5]
    mail from: user@dominio.com.br
    500 5.3.3 Unrecognized command
    mail from: alguem@teste.com.br
    250 2.1.0 alguem@teste.com.br....Sender OK
    rcpt to: luiz.orlandi@gmail.com
    550 5.7.1 Unable to relay for luiz.orlandi@gmail.com

     Chequei no smartphone e está enviando e recebendo normalmente (com usuário e senha no smtp) ficou perfeito !!! Super, mega, power, obrigado !!!

     Próximo post vou passar para o activesync (assim que estiver com o smartphone na mão novamenrte).

     

     

    Valeu !!1

     

    Luiz

    terça-feira, 25 de setembro de 2007 19:01