none
Serviço MSSQLERVER nao está inicializando RRS feed

  • Pergunta

  • Pessoal,

    Tenho a impressão que todo começo quando em SQL Server Configuration Manager\SQL Server 2005 Network Configuration\Protocols for MSSQLSERVER\Propriedades do TCP/IP; e na guia IP Addresses.
    Há 2 IPs, um do nosso servidor e outro 127.0.0.1, e ambos estão desabilitado. E habilitei os 2.
    Pediu para reiniciar o serviço, é já foi reiniciar o: SQL Server (MSSQLSERVER), porem veja a mensagem que apresentou:

    The request failed or the service did not respond in a timely fashion. Consult the event log or other applicable error logs for details.

    Ai, foi e voltei a configuração inicial, reiniciei o serviço, e ... a mesma msg de erro aparece.
    Conclusão o banco está parado.

    O trecho do log: C:\Arquivos de programas\Microsoft SQL Server\MSSQL.1\MSSQL\LOG\ERRORLOG:
    2009-04-27 12:21:24.39 spid51      Configuration option 'show advanced options' changed from 0 to 1. Run the RECONFIGURE statement to install.
    2009-04-27 12:21:24.45 spid51      Configuration option 'Agent XPs' changed from 1 to 0. Run the RECONFIGURE statement to install.
    2009-04-27 12:21:24.51 spid51      Configuration option 'show advanced options' changed from 1 to 0. Run the RECONFIGURE statement to install.
    2009-04-27 12:21:27.67 spid12s     Service Broker manager has shut down.
    2009-04-27 12:21:28.79 spid5s      SQL Server is terminating in response to a 'stop' request from Service Control Manager. This is an informational message only. No user action is required.
    2009-04-27 12:21:28.84 spid5s      SQL Trace was stopped due to server shutdown. Trace ID = '1'. This is an informational message only; no user action is required.
    2009-04-27 12:21:29.01 Server      The SQL Network Interface library could not deregister the Service Principal Name (SPN) for the SQL Server service. Error: 0x2098. Administrator should deregister this SPN manually to avoid client authentication errors.

    Como faço para voltar a startar o serviço do banco ?
    segunda-feira, 27 de abril de 2009 18:16

Todas as Respostas

  • Caro,

     Para fazer um teste e ver se é isso mesmo, tente desabilitar o protocolo TCP/IP, e habilitar apenas o shared memory.  E tente iniciar o serviço, se der certo, provavelmente essa configuração que você realizou afetou, bastará desfazer.

    Abraços
    Gilberto Neto
    Gilberto Neto Blog: http://gilberto-neto.spaces.live.com/default.aspx
    • Sugerido como Resposta Gilberto Neto segunda-feira, 27 de abril de 2009 18:20
    segunda-feira, 27 de abril de 2009 18:20

  • Fiz o que pediu, deixando o Shared Memory e Named Pipes Enable, porem ao reiniciar o serviço, aconteceu o mesmo erro.


    E se eu for SSMS tentar autenticar no Database Engine, a mensagem abaixo:


    TITLE: Connect to Server
    ------------------------------

    Cannot connect to IPRESB002.

    ------------------------------
    ADDITIONAL INFORMATION:

    An error has occurred while establishing a connection to the server.  When connecting to SQL Server 2005, this failure may be caused by the fact that under the default settings SQL Server does not allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server) (Microsoft SQL Server, Error: 2)

    For help, click: http://go.microsoft.com/fwlink?ProdName=Microsoft+SQL+Server&EvtSrc=MSSQLServer&EvtID=2&LinkId=20476

    ------------------------------
    BUTTONS:

    OK
    ------------------------------

    Pessoal, colabora ai,
    valew.
    segunda-feira, 27 de abril de 2009 19:03
  • Agora, só deixei o Shared memory enable, porem não reiniciou.
    segunda-feira, 27 de abril de 2009 19:08
  • Boa Noite,

    Tente iniciar o serviço apartir do Prompt ou do Services.Msc

    [ ]s,

    Gustavo Maia Aguiar
    http://gustavomaiaaguiar.spaces.live.com

    Piores Práticas - Uso do COUNT(*)
    http://gustavomaiaaguiar.spaces.live.com/blog/cns!F4F5C630410B9865!538.entry
    Classifique as respostas. O seu feedback é imprescindível
    segunda-feira, 27 de abril de 2009 19:19
  • Pessoal,
    apresentou outra mensagem, que se referia ao logon.
    Fui em services.msc, e no servico do MSSQLSERVER em propriedades, em mudei o logon para a Conta do sistema local.

    Funfou, engraçado, é que isso não foi mexido. Porem, acho melhor assim, msm.

    Bom, agradeço a colaboração, ....
    e peço que me colaborem no seguinte:
    ... não estou conseguido rodar o SP3 do sql server (SQLServer2005SP3-KB955706-x86-ENU.exe).

    Na tela da Authentication, há 2 produtos o Database Services e Reporting Services, onde no Teste para Seleção da instância, o status do Reporting Services falha.
    segunda-feira, 27 de abril de 2009 19:42
  • Boa Tarde,

    Por favor poste uma nova dúvida. Se o serviço foi reestabelecido o problema foi encerrado.
    Não devemos misturar assuntos diferentes na mesma thread, pois, isso prejudica o fórum.

    [ ]s,

    Gustavo Maia Aguiar
    http://gustavomaiaaguiar.spaces.live.com

    Piores Práticas - Uso do COUNT(*)
    http://gustavomaiaaguiar.spaces.live.com/blog/cns!F4F5C630410B9865!538.entry
    Classifique as respostas. O seu feedback é imprescindível
    segunda-feira, 27 de abril de 2009 19:46
  • Pessoal,
    desculpe, sou novo aqui.


    Muito grato pela colaboracao,
    valew.
    Ja estou postando outro.
    segunda-feira, 27 de abril de 2009 19:52
  • Caro,

     Apenas, por questão de segurança, não é recomendado subir os serviços do SQL Server com a conta local system.   Cria um novo usuário, e coloca para subir esse serviço.  E verifica as permissões que ele precisaria (acessar rede, etc)

    Abraços
    Gilberto Neto
    Gilberto Neto Blog: http://gilberto-neto.spaces.live.com/default.aspx
    • Sugerido como Resposta Gilberto Neto segunda-feira, 27 de abril de 2009 20:20
    segunda-feira, 27 de abril de 2009 20:20