none
Erro ao excluir site no Foundation RRS feed

Respostas

  • Wladimir bom dia,

    Este problema pode ocorrer devido a alguns fatos, então vamos por partes, uma das correções realmente era a execução do SP1, como você disse que já executou e não obteve sucesso, vamos para os próximos passos.

    Normalmente este erro acontece porque o banco de dados da web application do SharePoint precisa ser atualizado, para isso execute a seguinte cmdlet:

    Get-SPContentDatabase
    Este cmdlet irá te mostrar qual o seu GUID referente a base de dados de conteúdo do SharePoint

    Em seguida atualize a base de dados com o seguinte cmdlet:

    Upgrade-SPContentDatabase -Identify GUID
    A GUID é a que você obteve ao executar a cmdlet Get-SPContentDatabase

    Isso já deve resolver seu problema, mas se não foi resolvido, tente os seguintes passos:

    Se você estiver com o UAC ativado em seu Sistema Operacional, desative.
    Faça o teste novamente

    Caso não funcione, execute o navegador como administrador para tentar excluir o site
    Faça o teste novamente

    Caso não funcione, execute a linha de comando:

    stsadm -o -deleteweb -url http://site_a_ser_excluido

    Provavelmente executando estes procedimentos acima seu problema estará resolvido.

    Abraços,


    Carlos Carvalho Citrangulo Junior
    Microsoft Certified Desktop Support Technician
    MCTS Microsoft Windows Vista Configuration
    MCTS SharePoint 2010 Configuration
    MCITP Enterprise Support Technician
    http://carloscitrangulo.wordpress.com
    http://citrangulosharepoint.wordpress.com


    domingo, 1 de abril de 2012 19:32

Todas as Respostas

  • Wladimir,

    Acho que já passei por esse problema algumas vezes, mas não lembro o que eu fiz.

    Recomendo vc pegar o ID de Correlação e procurar no log de erros do SharePoint. Depois veja se acha alguma coisa e/ou poste aqui.


    Atenciosamente,

    Fabian André Gehrke
    MCITP e MCPD SharePoint 2010
    http://fabiangehrke.com.br

    terça-feira, 13 de março de 2012 16:23
    Moderador
  • Aplicamos o SP1 no servidor do sharepoint e problema continuou.

    Li em alguns foruns e  vamos aplicar aplicar esse hotfix  http://support.microsoft.com/kb/2536599/pt-br (Que mais parece outro SP - quase 1GB)

    Detalhe: Pelo Sharepoint Designer e pelo console consigo excluir sites normalmente.

    quarta-feira, 14 de março de 2012 14:59
  • cole aqui os logs relacionados ao ID do erro mostrado acima e poderemos te dar uma explicação melhor.

    Ivan Costa http://www.blogsdeti.com.br @ivannw

    sexta-feira, 16 de março de 2012 12:52
  • Wladimir bom dia,

    Este problema pode ocorrer devido a alguns fatos, então vamos por partes, uma das correções realmente era a execução do SP1, como você disse que já executou e não obteve sucesso, vamos para os próximos passos.

    Normalmente este erro acontece porque o banco de dados da web application do SharePoint precisa ser atualizado, para isso execute a seguinte cmdlet:

    Get-SPContentDatabase
    Este cmdlet irá te mostrar qual o seu GUID referente a base de dados de conteúdo do SharePoint

    Em seguida atualize a base de dados com o seguinte cmdlet:

    Upgrade-SPContentDatabase -Identify GUID
    A GUID é a que você obteve ao executar a cmdlet Get-SPContentDatabase

    Isso já deve resolver seu problema, mas se não foi resolvido, tente os seguintes passos:

    Se você estiver com o UAC ativado em seu Sistema Operacional, desative.
    Faça o teste novamente

    Caso não funcione, execute o navegador como administrador para tentar excluir o site
    Faça o teste novamente

    Caso não funcione, execute a linha de comando:

    stsadm -o -deleteweb -url http://site_a_ser_excluido

    Provavelmente executando estes procedimentos acima seu problema estará resolvido.

    Abraços,


    Carlos Carvalho Citrangulo Junior
    Microsoft Certified Desktop Support Technician
    MCTS Microsoft Windows Vista Configuration
    MCTS SharePoint 2010 Configuration
    MCITP Enterprise Support Technician
    http://carloscitrangulo.wordpress.com
    http://citrangulosharepoint.wordpress.com


    domingo, 1 de abril de 2012 19:32
  • Pelo stsadm deu certo...
    quinta-feira, 26 de julho de 2012 20:46