none
Certificado Digital em VM RRS feed

  • Pergunta

  • Pessoal, depois de usar bastante o fórum para responder, hoje tenho que perguntar.

    Estou tentando resolver como usar o certificado digital num Seven 64 Ultimate no Hyper-V. Tem algum recurso diferente para isso? Pois utilizo as leitoras Perto - Perto CCID - Omnikey, as 3 instaladas no Seven aparecem Operacionais mas quando conecto o certificado não aparece.

    Irei utilizar o SPED e para transmissão faz-se necessário o cartão. Os usuários se conectam por RDP. Estou ainda testando em 1 VM. Instalei todos os softwares possíveis do cartão (Serasa). Testei todos que tinha. Aí para completar a explicação eu já tiquei opções de levar USB para a máquina, já tiquei cartão inteligente, porta e tudo possível. O que tenho de resposta da VM é: Quando abro o Administração do Token ele aparece as 3 leitoras que instalei e mostra lá Ausente -> eu plugo o cartão e aparece presente e depois Operacional. Isso faço normalmente no computador local. Quando eu tinha Server 2003 eu usava (sem VM claro) o cartão digital via RDP e ia normal, mas agora com VM não sei o que está ocorrendo.

    terça-feira, 5 de março de 2013 20:08

Respostas

  • Então eu tentei tentei, e nada. Por não desistência (eu ia por numa máquina física apenas para transmitir) eu tentei em outra VM. Instalei a Perto Smart CCID nessa nova VM e pelo desânimo achei que ia dar na mesma e de repente foi. Agora vou testar em outras Vms e tentar voltar um snapshot dessa primeira que havia tentado. Mas obrigado a todos pela ajuda. O que pode ter acontecido é a instalação de um monte de driver, que eu acho que não era pra fazer diferença, mas vou ver se conserto.
    quarta-feira, 6 de março de 2013 15:09

Todas as Respostas

  • André,

    Neste caso eu só consegui de uma forma, vou tentar exemplificar

    Primeiro passo é o CARTAO OU TOKEN está instalado e PLUGADO na maquina que vai ser terminal no caso que vai executar o MSTSC para conectar no Windows SEVEN, sendo assim quando você abrir o MSTSC vai lá em RECURSOS LOCAIS depois clica em MAIS e marca CARTOES INTELIGENTES. Ai quando você se conectar seu Windows Seven 64 vai reconhecer seu cartão normalmente. Mas lembrando o CARTAO OU TOKEN tem que ficar plugado na estação e não no servidor do Hyper-v.

    Fora isso só utilizando o outro tipo de certificado daquele que usa um arquivo sempre confundo não sei se é A1 ou A3.

    Leandro Keppel

    Microseguro Informática

    Skype: microseguro

    quarta-feira, 6 de março de 2013 05:33
  • Obrigado pela resposta. Ontem procurei de monte na internet em inglês que é mais fácil. Fiz de todas as formas. Até pensei em usar VDI já que remotefx faz redirecionamento. Falaram 2 formas de fazer, e uma delas é essa de ticar no RDP o cartão inteligente. Achei um USB REDIRECTOR mas é pago claro que resolve esse problema. Procurei por Smart Card hyper-v e todos dizendo que usam software de terceiro. Pra mim não está adiantando. Está detectando a leitora na VM, mas o cartão não aparece o certificado quando clico em Mostrar IDs Digitais. Vou continuar na tentativa.
    quarta-feira, 6 de março de 2013 09:40
  • André,

    Se não estou enganado, estes certificados podem ser do tipo A1 e A3, ou seja:

    • A1: Armazenado no computador
    • A3: Armazenado num token ou cartão

    Talvez seja mais fácil você reemetir o certificado no formato A1 e deixa-lo armazenado dentro da máquina virtual. Isso se aplica ao seu ambiente?

    Fonte: http://www.portaldosped.com.br/pagina/certificacao-digital

    Obs.: Só depois de postar que vi que o Leandro ja sugeriu isso.


    Uellington Santos - MCSE Server Infrastructure/Private Cloud



    quarta-feira, 6 de março de 2013 14:07
  • Então eu tentei tentei, e nada. Por não desistência (eu ia por numa máquina física apenas para transmitir) eu tentei em outra VM. Instalei a Perto Smart CCID nessa nova VM e pelo desânimo achei que ia dar na mesma e de repente foi. Agora vou testar em outras Vms e tentar voltar um snapshot dessa primeira que havia tentado. Mas obrigado a todos pela ajuda. O que pode ter acontecido é a instalação de um monte de driver, que eu acho que não era pra fazer diferença, mas vou ver se conserto.
    quarta-feira, 6 de março de 2013 15:09
  • Ola André, estou com o mesmo problema no momento.

    Troquei o computador de usuário final e agora não consigo acessar a VM e utilizar o PERTO CCID na VM. Funciona apenas na maquina local, mesmo configurando de forma correta a conexão remota, marcando cartões inteligentes em recursos locais. Quando tento de qualquer outra máquina vai perfeitamente para a VM, só esta que acabei de colocar no usuário final que não. Penso que seja algo do TRUST na instalação do PERTO CCID.

    Conseguiu algo referente a isso?

    quinta-feira, 3 de agosto de 2017 18:00
  • Você instalou os softwares necessário da leitora? tem que instalar o driver e o software deles.
    quinta-feira, 3 de agosto de 2017 18:50