none
Remover exchange 2007 do AD. RRS feed

  • Pergunta

  •  

    Pessoal,

     

     

    Quando tento instalar o meu exchange 2007 aparece esse erro abaixo, gostaria de alguém poderia me ajudar...

     

     

    Organization Preparation
    Failed

    Error:
    The well-known object entry B:32:A7D2016C83F003458132789EEB127B84:CN=Exchange Servers\0ADEL:e60b372e-cd97-4fc2-bc8f-907728f0bc8d,CN=Deleted Objects,DC=domain,DC=com of the otherWellKnownObjects attribute on container object CN=Configuration,DC=domain,DC=com points to an invalid DN or a deleted object.  Please remove the entry and rerun the task.

    segunda-feira, 10 de novembro de 2008 14:08

Respostas

  • Ola Norbertoc,

     

    Junto com a dica do Anderson, e atropelando o post dele Smile ele já citou o que você deve apagar, você ja encontrou essa pasta - Deleted Itens? Você deseja apagar nomes servers de instalações anteriores correto? Sendo assim tem que ir nessa pasta.

     

    Apenas uma curiosidade, esse ambiente é de produção? Porque se tiver outra solução qualquer te aconselho acabar com tudo e começar do zero...

     

    Abs.

     

    terça-feira, 11 de novembro de 2008 12:27
  • B:32:A7D2016C83F003458132789EEB127B84:CN=Exchange Servers\0ADEL:e60b372e-cd97-4fc2-bc8f-907728f0bc8d,CN=Deleted Objects,DC=domain,DC=com of the otherWellKnownObjects attribute on container object CN=Configuration,DC=domain,DC=com

     

     

    abre o configuration e começa da direta para esquerda com o nome que tu já tem.

     

    Dentro do configuration tu vai ter Deleted Objects e ele estará lá.

     

    segunda-feira, 10 de novembro de 2008 19:43
  • Pessoal,

     

     

    Consegue resolver o problema, andei pesquisando e fiz algumas consultas a outros profissionais que deu a dica seria pelo comando LDP.EXE e dai so foi procurar o erro e deletar...

     

    http://support.microsoft.com/default.aspx/kb/224543

     

     

    Consegui instalar o exchange sem problema algum, de toda forma obrigado a todos pela ajuda...

     

     

    quinta-feira, 20 de novembro de 2008 17:35
  • Ja marquei as opções que serviram como ajuda.

     

    Sim, utilizei o ldp.exe

     

     

    Mais uma vez obrigado a todos...

    quinta-feira, 20 de novembro de 2008 18:40

Todas as Respostas

  • Ola Norberto,

     

    Tem que ir naquela partiçao indicada através do ADSiEdit naquele caminho ali e remover, tu andou fazendo alguma coisa manual né? removendo o server de uma forma nao tradicional correto?

     

    segunda-feira, 10 de novembro de 2008 14:31
  • Então,

     

     

    Ja tentei varias vezes instalar o exchange 2007 porém quando estava instalando tudo certinho aparecia alguns servidores que nunca vi, porém fiquei sabendo q tentaram instalar anteriormente.

    Então apos esse erro apresentado acima, gostaria de saber como proceder para excluir os resto des outras instalações, tem esse ADSIedit porém nao sei que caminho tenho que seguir.

     

    Pode me ajudar ???

     

    Obrigado pela atençaõ...

    segunda-feira, 10 de novembro de 2008 17:58
  • Ola Norberto,

     

    TEm que abrir o adsiedit.msc e ir no caminho especificadono eventviewer e apagar.

     

    O caminho t'a ecrito la

    segunda-feira, 10 de novembro de 2008 18:32
  • Oi Anderson,

     

     

    Então conseguei acessar via ADSIedit.msc porém não sei onde apago esse eventviewer e dai apaguei todos eventos, então porém ainda quando tento instalar o exchange ele apresenta o mesmo erro. Tem alguma outra coisa a fazer ?...

     

     

     

    segunda-feira, 10 de novembro de 2008 19:41
  • B:32:A7D2016C83F003458132789EEB127B84:CN=Exchange Servers\0ADEL:e60b372e-cd97-4fc2-bc8f-907728f0bc8d,CN=Deleted Objects,DC=domain,DC=com of the otherWellKnownObjects attribute on container object CN=Configuration,DC=domain,DC=com

     

     

    abre o configuration e começa da direta para esquerda com o nome que tu já tem.

     

    Dentro do configuration tu vai ter Deleted Objects e ele estará lá.

     

    segunda-feira, 10 de novembro de 2008 19:43
  • Opa,

     

     

    Então so para ver se entendi...

     

     

    Quando abro o ASDIedit.msc ele me abre uma tela assim:

     

    Configuration + nome do dominio Ok

     

    CN=DisplaySpecifiers

    CN=Extended-Rights

    CN=ForestUpdates

    CN=LostAndFoundConfig

    CN=NTDS Quotas

    CN=Partitions

    CN=Physical Locations

    CN=Services

    CN=Sites

    CN=WellKnown Security Principals

     

     

    Tenho que deletar tudo que esta dentro de cada CN ? pois dentro delas existem algumas sub-pastas e alguns arquivos TXT.

     

    Já deletei a pasta CN=Microsoft Exchange System Objects OK.

     

    Obrigado pela atenção...

    segunda-feira, 10 de novembro de 2008 19:57
  • Naoooooo

     

    tu só precisa deletar aquela entrada, nada mais que isso, ai.. acho que tu pode ter ferrado com tudo. tu tem algum outro exchange funcionando na organizaçao?

     

     

    segunda-feira, 10 de novembro de 2008 20:06
  • Opa,

     

     

    Não tenho outro exchange na rede não, gostaria de saber qual entrada tenho que deletar. a unica coisa que deletei foi essa pasta  : CN=Microsoft Exchange System Objects OK  e mais nada.

     

    Então qual o procedimento a fazer ?

     

     

    Obrigado !!!

    segunda-feira, 10 de novembro de 2008 20:09
  • Ola Norbertoc,

     

    Junto com a dica do Anderson, e atropelando o post dele Smile ele já citou o que você deve apagar, você ja encontrou essa pasta - Deleted Itens? Você deseja apagar nomes servers de instalações anteriores correto? Sendo assim tem que ir nessa pasta.

     

    Apenas uma curiosidade, esse ambiente é de produção? Porque se tiver outra solução qualquer te aconselho acabar com tudo e começar do zero...

     

    Abs.

     

    terça-feira, 11 de novembro de 2008 12:27
  • Opa,

     

    Estou fazendo sim em ambiente de teste, olha já deletei alguns servidores que aparecia porém ao tentar instalar o exchnage 2007 apresenta o mesmo erro:

    Na verdade nao achei a pasta ainda não, sabe o caminho que ela fica ? ver o que tem quando abro o ADSIEDIT.MSC pelo Run.

     

    Poderia me da uma dica onde encontro essa pasta delete itens ?

     

    Já deletei a pasta CN=Microsoft Exchange System Objects OK.

     

    Domain [sossegodc.dominio.br]

    DC=pe,DC=dominio,DC=br

    CN=Builtin

    CN=Computers

    OU=Domain Controllers

    OU=DR

    CN=ForeignSecurityPrincipals

    CN=LostAndFound

    CN=NTDS Quotas

    CN=Program Data

    CN=System

    OU=UNIDADES

    CN=Users

     

    Configuration + nome do dominio

     

    CN=DisplaySpecifiers

    CN=Extended-Rights

    CN=ForestUpdates

    CN=LostAndFoundConfig

    CN=NTDS Quotas

    CN=Partitions

    CN=Physical Locations

    CN=Services

    CN=Sites

    CN=WellKnown Security Principals

     

    Schema [sossegodc.dominio.br]

     

    CN=Schema,CN=Configuration,DC=br,DC=dominio,DC=br

     

     

    Obrigado a todos pela ajuda...

    terça-feira, 11 de novembro de 2008 13:18
  • Ola Norbertoc,

     

    Cara, não é por nada, mas se é ambiente de teste, apaga tudo e começa do zero. Não que você não tenha que fazer trobleshooting etc, mas é mais negócio fazer isso nesse momento...vai por mim! Wink

     

    Abs.

     

    terça-feira, 11 de novembro de 2008 13:29
  • Rodrigues,

     

     

    Encontrei a pasta server e deletei deletei tudo que tinha dentro ok. Entao também encontrei a pasta Deleted Itens e verifiquei que nao tinha mais nada.

    Tem mais algum procedimento a seguir ? tentei instalar o exchange novamente e o mesmo erro persistiu sera que tenho que reiniciar o Domain controller ?

     

     

    Configuration + nome do dominio

     

    CN=DisplaySpecifiers

    CN=Extended-Rights

    CN=ForestUpdates

    CN=LostAndFoundConfig

    CN=NTDS Quotas

    CN=Partitions

    CN=Physical Locations

    CN=Services + CN=Microsoft Exchange + CN=dominio + CN=ELC Folders Container + CN=Deleted Items.

    CN=Sites

    CN=WellKnown Security Principals

     

     

    Obrigado

    terça-feira, 11 de novembro de 2008 13:38
  • Ola Norbertoc,

     

    Não necessariamente, mas na minha opinião, ainda existe lixo, por isso o problema.

    Não sei o porque de insistir em um ambiente de teste, mas vá lá, dê uma olhada nos logs de instalação do Exchange e lá ele podera lhe ajudar melhor.

     

    Abs.

     

    terça-feira, 11 de novembro de 2008 13:59
  • Opa,

     

     

    Então o ambiente não é de teste, por isso queria tentar resolver dessa forma, senão terei que refazer os dois controladores de dominio que existem na rede.

    Ah outra pergunta é para deletar o que tem na pasta ou deletar a pasta delecte itens ?

     

    Mais uma vez obrigado...

     

     

     

     

    terça-feira, 11 de novembro de 2008 14:08
  •  

    Atropelando o post do Rodrigo e do Anderson, cara isso aqui ta muito confuso pelo o que eu entendi e todos entederam até agora você estava com ambiente de testes e agora o ambiente não é mais de testes...

     

    Cara do jeito que você ta enrolado eu te aconselho procurar uma consultoria especializada para te auxiliar nisso.

     

    Cuidado com o AdsiEdit porque se você apagar coisa errada lá seu AD pode não funcionar corretamente, e pelo que eu vi você apagou coisas demais nele é bem capaz que você precise reinstalar esses DCs....

    terça-feira, 11 de novembro de 2008 20:08
  • Oa Norberto,

     

    Cara eu achei que tu apagou muito fácil as configuraçoes do exchange e com é ambiente de produção é muito arriscado fazer isto on the fly Smile, te aconselho a abir um chamado com a MS ou ainda consultar uma consultoria da tua cidadae para tu nao ter problema la na frente.

     

    Basicamente, se vc ja matou aqui e acho que vc matou a arvore itneira, em teoria tu ja poderia instalar o exchange, o cleanup deixa assim se funcionar já está bom, tujá tinha um monte de lixo no AD mesmo, entao nao será dos piores, estou com medo de dizer para tu deletar e acabar apgando até informaçao que é necessária para o funcionamento do teu ad.

     

    terça-feira, 11 de novembro de 2008 20:18
  • Pessoal,

     

     

    Consegue resolver o problema, andei pesquisando e fiz algumas consultas a outros profissionais que deu a dica seria pelo comando LDP.EXE e dai so foi procurar o erro e deletar...

     

    http://support.microsoft.com/default.aspx/kb/224543

     

     

    Consegui instalar o exchange sem problema algum, de toda forma obrigado a todos pela ajuda...

     

     

    quinta-feira, 20 de novembro de 2008 17:35
  • Nossa Norberto, tu foste pelo caminho mais perpetuoso, mas marca as outras dicas que te ajudaram tb.

     

    tu acasbate removendo via ldp ou adsiedit.msc?

     

    quinta-feira, 20 de novembro de 2008 17:42
  •  

    O LDP.EXE faz exatamente a mesma coisa que o AdsiEdit, não entendi porque você conseguiu com ele mesmo tentando fazer várias vezes com o Adsi.

     

    Mas fico feliz que tenha resolvido o problema.

    quinta-feira, 20 de novembro de 2008 18:24
  • Ja marquei as opções que serviram como ajuda.

     

    Sim, utilizei o ldp.exe

     

     

    Mais uma vez obrigado a todos...

    quinta-feira, 20 de novembro de 2008 18:40